Groups
Groups
Sign in
Groups
Groups
swupdate
Conversations
About
Send feedback
Help
Group path
swupdate
Contact owners and managers
1–30 of 4422
Welcome to the
swupdate@googlegroups.com
mailing list !
This is the place for discussions and fixes around the SWUpdate's project (
https://github.com/sbabic/swu
pdate
)
To post to the list, you should be a member of the list.
Mark all as read
Report group
0 selected
Raimar Sandner
,
Stefano Babic
2
6:29 AM
[RFC] Additional AEAD encryption path for SWUpdate: design and integration plan
Hi Raimar, On 8/3/26 17:10, 'Raimar Sandner' via swupdate wrote: > Hello Stefano, all,
unread,
[RFC] Additional AEAD encryption path for SWUpdate: design and integration plan
Hi Raimar, On 8/3/26 17:10, 'Raimar Sandner' via swupdate wrote: > Hello Stefano, all,
6:29 AM
Christian Storm
, …
Stefano Babic
10
3:45 AM
[PATCH] cpio_utils: Return error on short reads
On 8/3/26 22:49, 'Christian Storm' via swupdate wrote: > Return -ENODATA from _fill_buffer
unread,
[PATCH] cpio_utils: Return error on short reads
On 8/3/26 22:49, 'Christian Storm' via swupdate wrote: > Return -ENODATA from _fill_buffer
3:45 AM
Christian Storm
,
Stefano Babic
2
3:45 AM
[PATCH] Lua/specs: Fix image:read() annotation
On 8/3/26 22:56, 'Christian Storm' via swupdate wrote: > Signed-off-by: Christian Storm
unread,
[PATCH] Lua/specs: Fix image:read() annotation
On 8/3/26 22:56, 'Christian Storm' via swupdate wrote: > Signed-off-by: Christian Storm
3:45 AM
Christian Storm
,
Stefano Babic
2
3:45 AM
[PATCH] copyhandler: Fix format string compiler warning
On 8/3/26 22:53, 'Christian Storm' via swupdate wrote: > Fix the compiler warning >
unread,
[PATCH] copyhandler: Fix format string compiler warning
On 8/3/26 22:53, 'Christian Storm' via swupdate wrote: > Fix the compiler warning >
3:45 AM
Wes Malone
,
Stefano Babic
2
3:42 AM
Fwd: Intermediate CA revocation
Hi Wes, On 8/3/26 23:46, Wes Malone wrote: > Hello all, > > Why should the Openssl CMS image
unread,
Fwd: Intermediate CA revocation
Hi Wes, On 8/3/26 23:46, Wes Malone wrote: > Hello all, > > Why should the Openssl CMS image
3:42 AM
Storm, Christian
,
Stefano Babic
2
3:35 AM
CPIO_CRCASCII checksum handling in Lua
Hi Christian, On 8/4/26 10:58, 'Storm, Christian' via swupdate wrote: > Hi, > >
unread,
CPIO_CRCASCII checksum handling in Lua
Hi Christian, On 8/4/26 10:58, 'Storm, Christian' via swupdate wrote: > Hi, > >
3:35 AM
Stefano Babic
Jul 29
[PATCH] Rename entry point for Webserver in a general way
As mongoose is not anymore the only Webserver available, the entry points *_mongoose can be renamed
unread,
[PATCH] Rename entry point for Webserver in a general way
As mongoose is not anymore the only Webserver available, the entry points *_mongoose can be renamed
Jul 29
Ayoub Zaki
Jul 29
[PATCH] crypto: CMS: add new Kconfig CONFIG_CMS_REQUIRE_HYBRID_PQC to require classic + PQC signatures
When a CMS update is signed with both a classic (RSA, ECDSA) and a post-quantum (ML-DSA, SLH-DSA)
unread,
[PATCH] crypto: CMS: add new Kconfig CONFIG_CMS_REQUIRE_HYBRID_PQC to require classic + PQC signatures
When a CMS update is signed with both a classic (RSA, ECDSA) and a post-quantum (ML-DSA, SLH-DSA)
Jul 29
Bastian Germann
Jul 29
[PATCH] test: Concatenate test results with &&
The test results which are calculated are discarded because they are concatenated with ";".
unread,
[PATCH] test: Concatenate test results with &&
The test results which are calculated are discarded because they are concatenated with ";".
Jul 29
Bastian Germann
Jul 29
[PATCH] test: Fix expected hash error value
The do_concrete_hash function expects the wrong return. It should expect no error, which is encoded
unread,
[PATCH] test: Fix expected hash error value
The do_concrete_hash function expects the wrong return. It should expect no error, which is encoded
Jul 29
Bastian Germann
Jul 28
[PATCH 1/2] acceptance-tests: enable running webserver with cert
Enable running the webserver tests with CMS-signed images. To that end, let the script call the
unread,
[PATCH 1/2] acceptance-tests: enable running webserver with cert
Enable running the webserver tests with CMS-signed images. To that end, let the script call the
Jul 28
Bastian Germann
Jul 28
[PATCH 2/2] config: add CONFIG_SIGALG_CMS to the defaults
The acceptance-tests suite only deals with unsigned or CMS-signed images. As it is run for all
unread,
[PATCH 2/2] config: add CONFIG_SIGALG_CMS to the defaults
The acceptance-tests suite only deals with unsigned or CMS-signed images. As it is run for all
Jul 28
Philippe Reynes
,
Stefano Babic
4
Jul 28
[PATCH] add a property install-if-hash-different
When the property install-if-hash-different is true, swupdate checks if the destination already
unread,
[PATCH] add a property install-if-hash-different
When the property install-if-hash-different is true, swupdate checks if the destination already
Jul 28
Bastian Germann
,
Stefano Babic
15
Jul 28
[PATCH 1/5] mongoose: Move definition from interface to impl
On 7/28/26 00:03, Bastian Germann wrote: > The roadmap lists an alternative webserver
unread,
[PATCH 1/5] mongoose: Move definition from interface to impl
On 7/28/26 00:03, Bastian Germann wrote: > The roadmap lists an alternative webserver
Jul 28
Ulrich Teichert
,
Stefano Babic
2
Jul 28
[PATCH 1/1] Change version information logging from TRACE to INFO level
On 7/28/26 10:19, 'Ulrich Teichert' via swupdate wrote: > Change version information
unread,
[PATCH 1/1] Change version information logging from TRACE to INFO level
On 7/28/26 10:19, 'Ulrich Teichert' via swupdate wrote: > Change version information
Jul 28
Ulrich Teichert
,
Stefano Babic
5
Jul 28
RFC: Logging of version info?
Hi Stefano, >> No, only two of them and logging these with level INFO would be appropiate, >
unread,
RFC: Logging of version info?
Hi Stefano, >> No, only two of them and logging these with level INFO would be appropiate, >
Jul 28
Jonas Juffinger
,
Stefano Babic
3
Jul 28
[meta-swupdate][PATCH] swupdate.inc: add OFL-1.1 to LICENSE
On 7/28/26 09:14, Jonas Juffinger wrote: > Every package level license must also be listed in the
unread,
[meta-swupdate][PATCH] swupdate.inc: add OFL-1.1 to LICENSE
On 7/28/26 09:14, Jonas Juffinger wrote: > Every package level license must also be listed in the
Jul 28
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Add comment for missing MAC / IP validation
On 7/24/26 16:51, 'Christian Storm' via swupdate wrote: > In contrast to U-Boot,
unread,
[PATCH][libubootenv] uboot_env: Add comment for missing MAC / IP validation
On 7/24/26 16:51, 'Christian Storm' via swupdate wrote: > In contrast to U-Boot,
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Fix libuboot_validate_flags() boolean type validation
On 7/24/26 16:50, 'Christian Storm' via swupdate wrote: > At this stage of validation, set
unread,
[PATCH][libubootenv] uboot_env: Fix libuboot_validate_flags() boolean type validation
On 7/24/26 16:50, 'Christian Storm' via swupdate wrote: > At this stage of validation, set
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Reject empty strings in validate_int()
On 7/24/26 16:49, 'Christian Storm' via swupdate wrote: > Check whether value's first
unread,
[PATCH][libubootenv] uboot_env: Reject empty strings in validate_int()
On 7/24/26 16:49, 'Christian Storm' via swupdate wrote: > Check whether value's first
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Handle environment cannot be locked
On 7/24/26 16:47, 'Christian Storm' via swupdate wrote: > Return an error from
unread,
[PATCH][libubootenv] uboot_env: Handle environment cannot be locked
On 7/24/26 16:47, 'Christian Storm' via swupdate wrote: > Return an error from
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Add default FreeBSD lock file path
On 7/22/26 14:38, 'Christian Storm' via swupdate wrote: > FreeBSD doesn't have /var/
unread,
[PATCH][libubootenv] uboot_env: Add default FreeBSD lock file path
On 7/22/26 14:38, 'Christian Storm' via swupdate wrote: > FreeBSD doesn't have /var/
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] uboot_env: Fix Wswitch compiler warnings
On 7/20/26 15:58, 'Christian Storm' via swupdate wrote: > FLAGS_NONE is not handled, add
unread,
[PATCH][libubootenv] uboot_env: Fix Wswitch compiler warnings
On 7/20/26 15:58, 'Christian Storm' via swupdate wrote: > FLAGS_NONE is not handled, add
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] extended_config: Remove unused STATE_NKEY
On 7/20/26 16:18, 'Christian Storm' via swupdate wrote: > STATE_NKEY is not used anywhere
unread,
[PATCH][libubootenv] extended_config: Remove unused STATE_NKEY
On 7/20/26 16:18, 'Christian Storm' via swupdate wrote: > STATE_NKEY is not used anywhere
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] extended_config: Fix switch-case STATE_STOP indendation
On 7/20/26 16:19, 'Christian Storm' via swupdate wrote: > Signed-off-by: Christian Storm
unread,
[PATCH][libubootenv] extended_config: Fix switch-case STATE_STOP indendation
On 7/20/26 16:19, 'Christian Storm' via swupdate wrote: > Signed-off-by: Christian Storm
Jul 27
Christian Storm
,
Stefano Babic
2
Jul 27
[PATCH][libubootenv] Add ENODATA #define on FreeBSD
On 7/22/26 14:37, 'Christian Storm' via swupdate wrote: > ENODATA is defined for STREAMS
unread,
[PATCH][libubootenv] Add ENODATA #define on FreeBSD
On 7/22/26 14:37, 'Christian Storm' via swupdate wrote: > ENODATA is defined for STREAMS
Jul 27
Philippe Reynes
,
Stefano Babic
2
Jul 27
[swugenerator][PATCH RESEND] Add support for PSS padding when signing with RSA
Hi Philippe, Paul, applied to -master, thanks ! Best regards, Stefano Babic On 7/10/26 13:27,
unread,
[swugenerator][PATCH RESEND] Add support for PSS padding when signing with RSA
Hi Philippe, Paul, applied to -master, thanks ! Best regards, Stefano Babic On 7/10/26 13:27,
Jul 27
Johannes Schrimpf
,
Stefano Babic
2
Jul 27
[meta-swupdate][PATCH] swupdate: fail the build when cpio drops files from the .swu
Hi Johannes, I get : patching file classes-recipe/swupdate-common.bbclass patch: **** malformed patch
unread,
[meta-swupdate][PATCH] swupdate: fail the build when cpio drops files from the .swu
Hi Johannes, I get : patching file classes-recipe/swupdate-common.bbclass patch: **** malformed patch
Jul 27
Oliver Kaestner
,
Stefano Babic
2
Jul 27
[meta-swupdate][PATCH] swupdate: don't set default mongoose port in args
On 6/4/26 18:51, 'Oliver Kaestner' via swupdate wrote: > Avoid setting the mongoose
unread,
[meta-swupdate][PATCH] swupdate: don't set default mongoose port in args
On 6/4/26 18:51, 'Oliver Kaestner' via swupdate wrote: > Avoid setting the mongoose
Jul 27
Hamish Guthrie
,
Stefano Babic
2
Jul 27
[meta-swupdate][PATCH] swupdate.inc: add OFL-1.1 to LICENSE:${PN}-www
Hi Hamish, On 7/25/26 08:50, 'Hamish Guthrie' via swupdate wrote: > The www sub-package
unread,
[meta-swupdate][PATCH] swupdate.inc: add OFL-1.1 to LICENSE:${PN}-www
Hi Hamish, On 7/25/26 08:50, 'Hamish Guthrie' via swupdate wrote: > The www sub-package
Jul 27