ROS Industrial Training Material Setup Problem

49 views
Skip to first unread message

Ercan DÜZGÜN

unread,
Dec 26, 2017, 7:25:38 AM12/26/17
to swri-ros-pkg-dev
Dear Users,

I started to study on ROS-Industrial Training Material kinetic. I am stuck on the first step: PC Setup. 
I tried "PC Configuration" step; comleted that "shell script" on github succesfully. 
Then, I checked configuration . As it is said there; I run this code "~/industrial_training/.check_training_config.bash" , but it gives this error: bash: /home/user/industrial_training/.check_training_config.bash: No such file or directory

I opened home/user directory (even showed the hidden files), but there is not industrial_training file there. 

However, during the executing of these codes (https://github.com/AustinDeric/ros-industrial-env), I didn't have any problem, I executed those codes line by line. And I thought that those codes would create that "industrial_training" folder inside home/user directory.

Do you have any suggestions?
Kind regards,
Ercan 

Josh Langsfeld

unread,
Dec 27, 2017, 11:26:35 AM12/27/17
to swri-ros-pkg-dev

Hello Ercan,

It looks like you discovered a mistake in the training documentation. The step to get the industrial_training repository is not noted for the “PC Configuration” method. We will get that fixed right away.

In the meantime, all you should need to do to get the repo is run git clone -b kinetic_devel https://github.com/ros-industrial/industrial_training.git ~/industrial_training. Then you can run the .check_training_config.bash file to verify your environment.

Thanks,

Josh Langsfeld

Research Engineer | Robotics and Automation | Intelligent Systems
Southwest Research Institute

Reply all
Reply to author
Forward
0 new messages