snd-c54232

4 views
Skip to first unread message

Erick Rosales

unread,
Jun 6, 2009, 12:09:40 AM6/6/09
to sus...@googlegroups.com, opensusesv, gui...@imatica.org
Me disculpo y recurro a sus conocimientos y pues talves tienen un
tiempito y nos colaboran por favor de antemano gracias y pues no tengo
a algun otro lugar por eso les pido su colaboracion.

Saludos, tratando de motivar mas a los niñ@s logre instalar con wine
el programa llamado Conejo Lector, cabe mencionar que se posee el cd
original pues me lo regalaron de paquete. Entonces las pc's tienen
instalado el opensuse 10.2 pero no se porque las pc's solo en la
cuenta root si funciona la tarjeta de sonido ya que desde
ajuste personales
me fui a
Timbres del sistema y dice "fueron emitidos"
y dice tambien Crystal Audio
0 Crystal Audio
Controlador Snd-cs4232

System Bell Ok

pero tenemos las pc's configuradas con cuentas de acuerdo al nivel que
fueron creadas desde

YaST Seguridad y Usuarios

y cuando estoy en la cuenta ciclo1 ejecuto el conejo lector aparece

no se encontro el controlador Wav para tarjeta de sonido

voy al konsole y escribo alsamixer: aparece fuction snd_ctl_open
failed for default No such device

cabe mencionar que las pc's son IBM 300 PL

System Summary
Processor Pentium II
System Memory 320Mb


Product Data
Machine type/model 686252U
flash eeprom NVKT41AUS
boot block revision level NV41A
system board identifier DBWMFVGYQD1
system serial number 23BMVYD
system UUID 32F4CCF6155F21129F870004AC5B6922
BIOS date 02/08/99
bios mode desktop

Camaleón

unread,
Jun 8, 2009, 10:41:58 AM6/8/09
to sus...@googlegroups.com
El 2009-06-06 a las 06:09 +0200, Erick Rosales escribió:

> Saludos, tratando de motivar mas a los niñ@s logre instalar con wine
> el programa llamado Conejo Lector, cabe mencionar que se posee el cd
> original pues me lo regalaron de paquete. Entonces las pc's tienen
> instalado el opensuse 10.2 pero no se porque las pc's solo en la
> cuenta root si funciona la tarjeta de sonido

¿Quieres decir que El Conejo Lector tiene audio sólo cuando lo ejecutas
desde la cuenta de root o que sólo te funcionan los sonidos (en
geenral) en suse para la cuenta de root?

Si es lo primero podría ser un problema con wine, pero si es lo segundo
quizá tengas que añadir al usuario del sistema al grupo "audio".

La verdad es que no recuerdo que hiciera falta hacer ésto en la 10.2,
pero por probar no pierdes nada :-)

Saludos,

--
Camaleón

Erick Rosales

unread,
Jun 8, 2009, 11:42:58 PM6/8/09
to sus...@googlegroups.com
El sonido solo es emitido en opensuse pero no en wine
nada lo hace funcionar y le instale el wine la ultima version
y nada como sera esta cosa? bueno
de antemano gracias por sus ayudas

Erick Rosales

unread,
Jun 8, 2009, 11:36:38 PM6/8/09
to sus...@googlegroups.com
Saludos con el problema del conejo lector no se en verdad como va
porque este dia a una pc ibm 300pl le instale el suse 9.1 y sin
cambiar nada de los parametros a wine nada ni hacer otra cuenta aparte
de la que se crea cuando se instala lo probe y me funciono el conejo
lector y pues no se como hacerle ya que el suse 9.1 a pesar que es
version viejita funciona mejor segun mi criterio pero pues no funciona
el kolourpaint ni kompoZer pero no es el caso como se podria hacer ya
que el conejo dice

no se encontro el controlador Wav para tarjeta de sonido

y en suse si bien fuerte lo genera ya que las pc's tienen sonido integrado

tiene alguna idea de este problema

On 6/8/09, Camaleón <noel...@gmail.com> wrote:
>

Camaleón

unread,
Jun 9, 2009, 5:06:44 AM6/9/09
to sus...@googlegroups.com
El 2009-06-08 a las 21:42 -0600, Erick Rosales escribió:

> El sonido solo es emitido en opensuse pero no en wine

Antes has mencionado que como root sí iba bien ¿a qué te referías
exactamente? :-?

Haz una prueba sencilla: ejecuta wine como usuario root y lanza el
Conejo Lector para ver si suena.

> nada lo hace funcionar y le instale el wine la ultima version
> y nada como sera esta cosa?

Si es un problema del wine exclusivamente, puedes probar lo que comentan
en su FAQ:

***
http://tiny.cc/dlJ0i

6.19. I'm using OSS in Wine and I have no sound.

Unless you're using a sound card with an emu10k1/2 chipset (SB
Live!/Audigy) or another type of card that supports "hardware mixing"
then you can only ever have one application using sound at the same
time. If you have aRts (KDE sound system), ESD (Gnome sound system) or
any music applications open then you simply won't hear anything from
Wine. You need to kill or close all these programs before being able to
get sound from Wine. To work out if anything has locked your sound-card
already, you can do cat /dev/urandom >> /dev/dsp. If you get an error
message it means that something is using it. If you get loud static
this means that your sound card is clear and ready for use.
***

Lo que tienes que hacer básicamente es ejecutar el comando:

***
cat /dev/urandom >> /dev/dsp
***

Si te dice algo como "dispositivo ocupado" o "device busy" no podrás
oir nada en el wine hasta que no cierres el subsistema de sonido (arts,
oss o el que uses). Esto lo puedes hacer desde el Centro de Control en
KDE (sonido y multimedia / sistema de sonido / activar el sistema de
sonido -debe estar desactivado-). Y probar de nuevo el comando. Sólo
cuando esté libre escucharás un sonido estridente (que podrás detener
con Ctrl+Z), pero que indica que el wine podrá sonar también.

Saludos,

--
Camaleón

Erick Rosales

unread,
Jun 9, 2009, 11:07:43 PM6/9/09
to sus...@googlegroups.com
Saludos mañana hare la prueba y para no confundir el hilo como root
me emite sonido pero como cuenta limitada no y me refiero a los sonidos
del sistema opensuse unos sonidos como de relajacion se escuchan
y el mentado conejo no trabaja como root ni como
la cuenta limitada para kinder no y como les comente
en suse si trabaja la maquina (pc) yo
podria decir perfectamente

gracias por su ayuda
Salu2
El Salvador

Reply all
Reply to author
Forward
0 new messages