Unable to look up revision

17 views
Skip to first unread message

David Banks

unread,
Jul 8, 2020, 1:57:17 PM7/8/20
to Subsurface Divelog
some basic information:
  • Which version are you using (hint: look at the About screen)?
  • Subsurface 4.9.6
  • Which OS are you running?
  • Windows
Subsurface has been working fine for 2 years, Windows laptop and Android mobile. When editing locations on laptop the the other day the laptop shutoff unexpectedly. Since then the laptop will not load the divelog from the cloud and responds with "Unable to look up revision 'debfl...@gmail.coml'

The mobile app loads, edits, manual syncs to cloud, etc.

Laptop loads wife's divelog fine when I change Preferences/cloud/credentials to her account

uninstalled and reinstalled Subsurface on laptop; no change.

Apparently the cloud file is corrupt but only in parts not loaded by the mobile app. Can the cloud file be reindexed? Can the Android log be exported and imported into Windows version?

Thank you for your help...
David

David Banks

unread,
Jul 8, 2020, 2:23:06 PM7/8/20
to Subsurface Divelog
SOLVED: I finally made sense of the previous reply to similar problem, and found the C:\Users\DEB\AppData\Roaming\Subsurface\cloudstorage folder, deleted its contents, and then Subsurface:File/Open Cloud Storage and all seems to work fine. I couldn't find that folder last night, I don't know why.

agar...@gmail.com

unread,
Jul 15, 2022, 12:31:00 AMJul 15
to Subsurface Divelog
Bringing this up from the past, just to say had the same issue and this solved it.
My computer died (ran out of battery) - then subsurface would crash when tried to open it. Rebooted, got this error. Followed instructions above, all good.

Alex

Reply all
Reply to author
Forward
0 new messages