OS Requirements

37 views
Skip to first unread message

Stephen Wynn

unread,
Aug 11, 2022, 2:40:28 PM8/11/22
to SubjectsPlus
We have been running SubjectsPlus on an IIS, but would like to upgrade & move to a Linux server.

Campus ITS has asked me for OS requirements. I responded by linking to the Requirements page (http://subjectsplus.com/wiki3/?title=Requirements_4.0), but this page does not have specific requirements or recommendations for operating systems. I interpret this to mean any OS at all that can run the specified applications (PHP, MySQL, etc.). But ITS is asking for more details about OS requirements. I'm not sure how to respond. Any advice?

Rogan Hamby

unread,
Aug 11, 2022, 3:27:44 PM8/11/22
to subjec...@googlegroups.com
Hi Stephen,

Your needs will depend a little on how much you are storing on it so this is just my personal  experience but may be helpful.  I'm working with systems running on Debian 9 and finding that 40 gigs and 4 gigs of memory is plenty for me. 

On Thu, Aug 11, 2022 at 2:40 PM Stephen Wynn <sw...@truman.edu> wrote:
We have been running SubjectsPlus on an IIS, but would like to upgrade & move to a Linux server.

Campus ITS has asked me for OS requirements. I responded by linking to the Requirements page (http://subjectsplus.com/wiki3/?title=Requirements_4.0), but this page does not have specific requirements or recommendations for operating systems. I interpret this to mean any OS at all that can run the specified applications (PHP, MySQL, etc.). But ITS is asking for more details about OS requirements. I'm not sure how to respond. Any advice?

--
You received this message because you are subscribed to the Google Groups "SubjectsPlus" group.
To unsubscribe from this group and stop receiving emails from it, send an email to subjectsplus...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/subjectsplus/53789c2d-2af5-4994-a22a-48d1bfa9879bn%40googlegroups.com.

charlesbr...@gmail.com

unread,
Aug 12, 2022, 9:48:16 AM8/12/22
to SubjectsPlus
Hi Stephen,

At the University of Miami Libraries, we're the primary developers and we run the following:

Ubuntu 20.04
Apache 2.4
Shares 7.5 GB of RAM with other apps in an Azure App Service Plan
PHP 7.4
MySQL 5.7, 125 GB

Although we have not tested it on Centos, I'm fairly confident that it will work as intended.
Basically, any Linux distribution that can run PHP, MySQL should be sufficient.

Thanks,
Charles

charlesbr...@gmail.com

unread,
Aug 12, 2022, 9:50:41 AM8/12/22
to SubjectsPlus
Hi Stephan,

Additionally, we recommend you install SP 4.6 to use with PHP 7.
Prior versions are not fully compatible with PHP 7.

Stephen Wynn

unread,
Aug 15, 2022, 11:48:14 AM8/15/22
to SubjectsPlus
Thanks Rogan & Charles! I've passed your comments on to campus ITS and they responded that this information was helpful.

Steve
Reply all
Reply to author
Forward
0 new messages