After successful installation: Failed to connect to the database with error SQLSTATE[HY000] [2005] Unknown MySQL server host 'mysqldb2.ehost-services.com:3306' (1)

1417 views
Skip to first unread message

Kurt Nielsen

unread,
Mar 4, 2011, 7:33:55 AM3/4/11
to storytlr...@googlegroups.com
I was so  hopeful then this happened

After successful installation: Failed to connect to the database with error SQLSTATE[HY000] [2005] Unknown MySQL server host '

mysqldb2.ehost-services.com:3306' (1)  I got to the option of either logging into the admin page or front and the above message resulted. It was all green lighted upon installation and in the end the install.php was removed. 

All requirements have been met for installation. Anyone have any ideas to fix this?

 
 
Thank you,
Kurt N.
 
 
 

Laurent Eschenauer

unread,
Mar 4, 2011, 8:02:30 AM3/4/11
to storytlr...@googlegroups.com
Hi Kurt, 

After successful installation: Failed to connect to the database with error SQLSTATE[HY000] [2005] Unknown MySQL server host '

mysqldb2.ehost-services.com:3306

I'm surprised to see a port number in there. Can you try to remove it ?

The line in your dbconfig should look like this:

Cheers,

Laurent

 

Kurt Nielsen

unread,
Mar 4, 2011, 8:34:38 AM3/4/11
to storytlr...@googlegroups.com
I will try what you suggested, but I also discovered something as well. I looked at the database in phpMy Admin and it highlighted an error:

phpMYAdmin reported:

3.11 The number of records for InnoDB tables is not correct.

phpMyAdmin uses a quick method to get the row count, and this method only returns an approximate count in the case of InnoDB tables. See $cfg['MaxExactCount'] for a way to modify those results, but this could have a serious impact on performance.

Kurt Nielsen

unread,
Mar 4, 2011, 8:40:08 AM3/4/11
to storytlr...@googlegroups.com
I changed it it to mysqldb2.ehost-services.com but no difference. I will try to reinstall as mysqldb2.ehost-services.com -maybe it somehow influenced the install.

Kurt Nielsen

unread,
Mar 4, 2011, 8:51:21 AM3/4/11
to storytlr...@googlegroups.com
I had to reinstall with mysqldb2.ehost-services.com specifically and it worked. simply changing the config.ini wasn't sufficient so I dropped the tables and removed the config.ini for a reinstall.

Laurent Eschenauer

unread,
Mar 4, 2011, 8:56:16 AM3/4/11
to storytlr...@googlegroups.com
On Fri, Mar 4, 2011 at 2:51 PM, Kurt Nielsen <ascensi...@gmail.com> wrote:
I had to reinstall with mysqldb2.ehost-services.com specifically and it worked. simply changing the config.ini wasn't sufficient so I dropped the tables and removed the config.ini for a reinstall.

Glad to see that it works. Ping us if any other issues. I'll file a bug report on the installer, we should parse the provided host and take care of the port in a different way.

Thanks,

Laurent

Kurt Nielsen

unread,
Mar 4, 2011, 9:40:33 AM3/4/11
to storytlr...@googlegroups.com
Thank you very much for your help Laurent! If your needing more ideas to contribute to your project, I would really like to promote the idea of including Adense script and integration of blip.tv :)
Reply all
Reply to author
Forward
0 new messages