Migrating from one server to another

7 views
Skip to first unread message

Andrew Wafaa

unread,
Jan 5, 2011, 9:34:25 AM1/5/11
to Storytlr ML
Aloha all,

I managed to get a shiny new server and decided to move my storytlr
instance from the old box to the new. I did a mysqldump of the storytlr
db, and then tarballed the storytlr directory. I moved both files over
to the new machine and restored them.

Problem is I get nothing but garbled gibberish when I try and access the
site. I just thought of a couple of reasons that could affect things -
when I moved servers I went onto a newer version of OS and also moved
from 32bit to 64bit.

System Details:
openSUSE 11.3 x86_64
Storytlr 1.0.1
PHP 5.3.4
MySQL 5.1.53
Zend 1.11.0

If you want to see how garbled things are head to http://www.wafaa.eu

Regards,

Andy

--
Andrew Wafaa
IRC: FunkyPenguin
GPG: 0x3A36312F
openSUSE: Get It, Discover It, Create It at http://www.opensuse.org

signature.asc

jean-francois lefebvre

unread,
Jan 5, 2011, 9:43:05 AM1/5/11
to awa...@opensuse.org, storytlr...@googlegroups.com
hello,

I think you should enable short tags in php.ini

Andrew Wafaa

unread,
Jan 5, 2011, 10:22:04 AM1/5/11
to jean-francois lefebvre, awa...@opensuse.org, storytlr...@googlegroups.com

Ah, excellent.  Many thanks for the quick fix.

--
Sorry for top posting

Andrew Wafaa
IRC: FunkyPenguin
GPG: 0x3A36312F
openSUSE: Get It, Discover It, Create It at http://www.opensuse.org

Andrew Wafaa

unread,
Jan 5, 2011, 10:26:47 AM1/5/11
to jean-francois lefebvre, storytlr...@googlegroups.com

Looks like I was a little too early in my celebration - i can now view
the default site - which is set to Stream, but I cant log-in or view any
tabs or tags.

It has been that long ago that I did the initial install I dont remember
changing anything else.

signature.asc

Laurent Eschenauer

unread,
Jan 5, 2011, 10:59:22 AM1/5/11
to storytlr...@googlegroups.com
> Looks like I was a little too early in my celebration - i can now view
> the default site - which is set to Stream, but I cant log-in or view any
> tabs or tags.

Have you mod_rewrite enabled for your apache ?

Andrew Wafaa

unread,
Jan 5, 2011, 11:17:42 AM1/5/11
to storytlr...@googlegroups.com

Yes, mod_rewrite is enabled on apache but I can't go anywhere other than
the landing page even search returns a 404 as with everything else.

signature.asc

Laurent Eschenauer

unread,
Jan 5, 2011, 2:42:14 PM1/5/11
to storytlr...@googlegroups.com
>> > Looks like I was a little too early in my celebration - i can now view
>> > the default site - which is set to Stream, but I cant log-in or view any
>> > tabs or tags.
>>
>> Have you mod_rewrite enabled for your apache ?
>
> Yes, mod_rewrite is enabled on apache but I can't go anywhere other than
> the landing page even search returns a 404 as with everything else.
>

You should have a .htaccess file in your storytlr root which is
enabling the rewrite of urls. You should also allow that .htaccess to
rewrite settings (make sure you have "AllowOveride All" as a directive
in your apache vhost configuration).

Let me know if it does the trick !

Cheers,

Laurent

Andrew Wafaa

unread,
Jan 5, 2011, 3:47:18 PM1/5/11
to storytlr...@googlegroups.com

Looks like apache wanted to play games - it kept changing my vhost
config file. Managed to fix it permanently and all is well again.

Huge thanks to everyone :)

signature.asc
Reply all
Reply to author
Forward
0 new messages