Bug: Cannot search in extension manager

Skip to first unread message

Brian Davison

Jun 7, 2024, 10:49:39 AMJun 7
to StarUML
I am using StarUML v.6.1.1 on a MacBook Pro M3 running MacOS 14.5 .

I am trying to search for extensions in the extension manager dialog. Entering a search term into the search field sometimes filters the list of extensions and sometimes it does not. If I press RETURN, the dialog closes. 

I have experimented with different search terms and the results are consistent. 

Case 1: Searching using "TypeSscript" as the search term.

The list of extensions is correctly filtered until I type the "S". At this point an error appears in the console:
Screenshot 2024-06-07 at 15.38.06.png

Case 2: Searching using "C# code generation" as the search term.

The same error appears after typing the second character and the list is not filtered:
Screenshot 2024-06-07 at 15.38.30.png

If I continue to type the rest of the search term, the same error occurs on every character :
Screenshot 2024-06-07 at 15.38.54.png

I have attached my .mdj file for reference.



Jun 8, 2024, 9:47:56 AMJun 8
to StarUML


Thank you for your feedback. We have just posted your issue on our main issue tracking system. It maybe fixed in the next minor release.

Thank you,

2024년 6월 7일 금요일 오후 11시 49분 39초 UTC+9에 brian.davis...@gmail.com님이 작성:
Reply all
Reply to author
0 new messages