> I'm writing out examples for the paper to check that it's
> consistent with current behavior and seeing this:
>
> # Step size = 1.8359
> # Diagonal elements of inverse mass matrix:
> # 0.529535
>
> Shouldn't "Step size" now be "time interval" or something
> like that?
Why would it be called that? We're always discretizing the flow with a numerical integrator by choosing a step size.
> And can we be super-specific and say the following?
>
> "Diagonal elements of diagonal inverse mass matrix:"
Is metric too esoteric? I would love to get rid of the "mass matrix" terminology.
In any case, we could have
"Elements of the diagonal (inverse mass matrix/inverse metric)"
"Elements of the (inverse mass matrix/inverse metric)"
> I also thought the header was going to change names for
> things, too:
>
> lp__,accept_stat__,stepsize__,treedepth__,theta
>
> What is accept_stat__? I couldn't find a previous discussion
> on the stan-dev list or in the latest manual.
accept_stat is the Metropolis acceptance probability. I haven't doc'd anything in the manual -- can we start a separate thread/issue noting which items need to be documented? With all of the changes in place I'm kind of lost as to what should be put into the manual.
> One issue is whether we're going to change lp__, which is
> used in the models. I like the idea of adding a function to
> increment lp__, so I'll make a pull request for that. I'll try
> to make it all-inclusive by hitting all the models and all the
> doc (I won't touch the output headers, though). I'd like our future
> pull requests to have everything in them at once so that the dev branch
> remains consistent between the doc and the code.
>
> Then we can deprecate direct access to lp__ and print the header
> however Michael thinks makes most sense.
Anything descriptive, whether it be "log_prob" or "log_post", of even "log_posterior".