Firmware issue on 0.2.14-r8.

7390 views
Skip to first unread message

sudoers

unread,
Mar 20, 2013, 7:33:20 PM3/20/13
to stalker-m...@googlegroups.com
Accidentally update the STB firmware to 0.2.14-r8 when plug in the new STB due to auto update is always enable.
I tried  via USB but  it says " Invalid File Header" , also tried via bios but it says something like :  "unsupported  architect "
 Does any body know how to  downgrade the firmware properly? Thanks.

JDVU

unread,
Mar 21, 2013, 3:52:31 AM3/21/13
to stalker-m...@googlegroups.com
http://wiki.iptv.infomir.com.ua/doku.php/en:faq:make_image_mag-200_250_new

четверг, 21 марта 2013 г., 1:33:20 UTC+2 пользователь sudoers написал:

netmaster

unread,
Mar 21, 2013, 6:32:47 AM3/21/13
to stalker-m...@googlegroups.com
stuck also at this "feature" today ...
Link you provided does not tell anything about how to downgrade firmware, but how to make new one. I do not need new firmware (at least not before 0.2.17 is released), I need to use my old custom firmware ...
Simplest way to avoid such a accident in the future is to prevent STB's to reach mag.infomir.com.ua


On Thursday, March 21, 2013 9:52:31 AM UTC+2, JDVU wrote:
http://wiki.iptv.infomir.com.ua/doku.php/en:faq:make_image_mag-200_250_new

Aleksey Zhurbitsky

unread,
Mar 21, 2013, 10:19:29 AM3/21/13
to stalker-m...@googlegroups.com
Try to update on 0.2.14-r3 from bootloader via multicast.

netmaster

unread,
Mar 21, 2013, 11:19:22 AM3/21/13
to stalker-m...@googlegroups.com
sended file http://soft.infomir.com.ua/mag250/release/0.2.14-r3/imageupdate via multicast


Image loaded successfully

Wrong Image


and that's all ... no downgrade ...

Aleksey Zhurbitsky

unread,
Mar 21, 2013, 12:02:44 PM3/21/13
to stalker-m...@googlegroups.com
You have done this according to the instructions and from bootloader?

netmaster

unread,
Mar 21, 2013, 1:26:46 PM3/21/13
to stalker-m...@googlegroups.com
yes. Pressed menu button at power on, etc. Selected MC Upgrade, and white block started to bounce back and forth when firmware transfer begin. Then those "Image loaded successfully" followed by "Wrong Image" messages also appeared at bootloader mode. After automatic reboot, MAG250 started with old r8 firmware like nothing happened.

netmaster

unread,
Mar 22, 2013, 4:03:26 AM3/22/13
to stalker-m...@googlegroups.com
after experimenting, I did successfully downgraded to 0.2.14-r3. Directions at the wiki was too confusing at least for me.
so, there is what must be done:

1. download mcast.zip and unpack it to some directory
2. download imageupdate and Bootstrap_250 file to the same directory
3. rename Bootstrap_250 to bootstrap
4. run mcast.exe
5. at the Stream 1, change IP address, port to 224.50.0.50:9000 (before was there 224.50.0.70:9000 or something)
6. verify, that Stream 1 have File name bootstrap and stream 2 imageupdate
7. power on MAG250 and hold down menu button on the remote
8. Select Upgrade Tools
9. Verify, that Use upgade is Yes (not sure is this necessary) and select MC Upgrade (with right arrow). "Loading image from multicast ..." appears
10. press Stream1 start and then Stream2 start
11. verify, that white block on the TV screen start moving and bootstrap loading has started
12. after while, screen color will change, and imageupdate loading starting.
13. at last, "write to the flash" screen appears followed by reboot.

Dimitar Ganchev

unread,
Mar 22, 2013, 7:07:44 AM3/22/13
to stalker-m...@googlegroups.com
After the box is automatically updated to 0.2.14-r8 after it was initially run for the first time, the up/downgrade from Stalker portal over http does not work anymore.

The "verify" function works fine, but nothing happens after pressing "Start update" and confirming the next dialog.
I have tried with http://soft.infomir.com.ua/mag250/release/0.2.14-r8/imageupdate and http://mag.infomir.com.ua/250/r/imageupdate_216_tr_b2

Regards,
Dimitar
Message has been deleted

Dimitar Ganchev

unread,
Mar 22, 2013, 8:55:27 AM3/22/13
to stalker-m...@googlegroups.com
I confirm that after the box upgrades itself to 0.2.14-r8 (or to 216_tr_b2) the only possible way to change it's firmware is via multicast. The update over USB does not work under any circumstances - from the BIOS or from the portal, with and without bootstrap. It does not update over http or usb even to the same version that is currently loaded in NAND (0.2.14-r8), so I'm afraid that we have completely lost the ability to change the firmware remotely.

Are you sure that the box will be able to update itself in the future?

Regards,
Dimitar

Aleksey Zhurbitsky

unread,
Mar 22, 2013, 10:09:04 AM3/22/13
to stalker-m...@googlegroups.com
http://wiki.infomir.eu/doku.php/en:faq:make_image_mag-200_250_new#customimage_-_prepearing_making
As far as i understand - you can make your own firmware with enabled updating via НТТP and USB. 

Dimitar Ganchev

unread,
Mar 22, 2013, 10:45:59 AM3/22/13
to stalker-m...@googlegroups.com
I don't want to make a custom firmware. I want to use your own default factory firmware.

When first started  without any user intervention, the box starts in it's internal portal. As the "autoupdate" option is ON by default, the box updates itself to the last available release version found in http://mag.infomir.com.ua/250/r/update_list.txt
Currently this last available release version is:

{"name":"0.2.14-r8", "url":"http://mag.infomir.com.ua/250/r/imageupdate_214_tr_r8", "type":"release", "date":"18 Mar 2013 19:56:53 GMT+0200", "descr":"Release-R8"},

So, whenever a customer unwraps it's newly bought mag250, it gets automatically updated to R8, no matter if he/she wants it or not, right?
Once autoupdated, the box can no longer be up/downgraded over http or usb. So, unless 0.2.14-r8 is the last version that you will ever release, I suppose there should be some way to remotely update the box whenever there is a new version released by you (by you, not by me).

Note that it does not even update from http://mag.infomir.com.ua/250/imageupdate  (says "invalid file header")

So, for all those guys that have update_url = 'http://mag.infomir.com.ua/' in their custom.ini, it will say "invalid file header". I suppose there is a change in the format since r8. What bothers me is that version r8 can not be "upgraded" even to itself, so I am afraid that when you are ready with r9, it will be still impossible to update over http. I hope you will fix this when 214-r9 or 0.2.16 becomes available.

Regards,
Dimitar

netmaster

unread,
Mar 22, 2013, 11:23:10 AM3/22/13
to stalker-m...@googlegroups.com
because most of the devices is bought not by end users, but by service providers, who most likely using own firmware anyway, then automatic update should be switched of by default. Even better, set up to use some bogus domain name (ex. http://infomir.update/mag250/imageupdate), what every provider can declare on DNS server and use to automatically load it's own custom firmware.

Dimitar Ganchev

unread,
Mar 22, 2013, 5:54:03 PM3/22/13
to stalker-m...@googlegroups.com
Well, you are almost right. Almost. When the box is to be used with custom firmware, then the initial autoupdate is just a little pain in the ass, but is not a big problem. The box will be updated by the operator with it's own custom firmware while the box is still connected to the operator's network (most probably over multicast) and under operator's supervision. The operator should be competent enough to change the firmware even if it is autoupdated by accident.

However, if the box will be used in over-the-top scenario (over the internet) with it's original firmware (as in my case), then it is a huge pain in the ass if it does not update at least once, or (as with 0.2.14-R8 from yesterday) refuses to update anymore.

The built-in firmware (the one loaded in the box by the factory) has wrong version number and is unrecognizable by Stalker portal. The boxes are currently shipped with 0.2.14-R6, but with wrong identification (in fact - empty). Stalker checks if the version is < 212, but the empty string is obviously lower than 212. If the version is detected to be below 212 (even if it is not), then the internal Stalker's settings menu is used instead of the external one. The internal setting menu, however, does not have firmware update option. So, if the box is not updated before starting the portal, it can not be updated anymore (well, at least not without entering BIOS at boot time, which is something the end-user should never be asked to do).

And as 214-R8 now refuses to update even to 214-R8 through Stalker's settings menu (both over http and over usb), I'm a little bit scared of what will happen when the next image is out and has to be loaded to all the boxes with 214-R8. If it still refuses to update over http, then we are stuck with R8.

Regards,
Dimitar

Anthony Suzanne

unread,
Apr 3, 2013, 4:45:50 AM4/3/13
to stalker-m...@googlegroups.com
Hi,

I follow this directions and http://wiki.infomir.eu/doku.php/en:faq:make_image_mag-200_250_new.
But where I make my own firmware, i can only update my mag250 with the http method because I haven't got the good bootstrap.

Have you got some informations about bootstrap instructions ?

Regard,
Anthony.

netmaster

unread,
Apr 4, 2013, 5:19:27 AM4/4/13
to stalker-m...@googlegroups.com
All that "new firmware" disaster is confusing. After reading many similar threads here, I still do not understand how exactly old custom images signed with public key should be updated to the custom r8. I did make new 0.2.14-r8 image with new op. utils. All went fine, until STB says "Wrong image" and reboot endlessly. From the FAQ section of the Wiki I found quote

PublicImage - image which is signed with standard public key STB_PUBLIC. Updating with HTTP only on manufacturer versions which are based on 0.2.14-r8

does this mean, that custom images, signed with public key can be installed only on top of the 0.2.14-r8 factory image?

CustomImage - image which is signed with custom key for firmware updating. This key is created by operator without manufacturer. Updating with such image can be done only on the other custom image based on 0.2.14-r8 and signed with the same key.

so, CustomImage also need a image based on 0.2.14-r8?

How to hell we supposed to remotely upgrade hundreds of devices from older custom image(s) signed with public key?

Since factory image go on top of any custom image, this must be possible, but how? Only way right now is to do automatic upgrade to factory image with Stalker, and then let him do automatic upgrade to new custom image with help of bogus DNS entry like I described early. This method is impossible in many cases, can be unreliable and is ugly workaround for sure ....

I do understand, that this is a place for Stalker related questions, and I could ask that big question directly from support. Instead of answering same question 100 times, support could write answer here or in the FAQ and then we all automatically would know the answer.

Thanks.

Klaas Jan Wierenga

unread,
Apr 16, 2013, 9:48:52 AM4/16/13
to stalker-m...@googlegroups.com

I have too have this problem of being unable to downgrade. For development purposes we need ssh access to the MAG250 which is impossible in releases 0.2.14-r3 and greater.

I can't use the multicast.exe program since I'm not running Windows. Is the multicast update possible from a Mac OSX machine?

My device is currently unusable....

Op donderdag 4 april 2013 11:19:27 UTC+2 schreef netmaster het volgende:

Aleksey Zhurbitsky

unread,
Apr 16, 2013, 10:03:49 AM4/16/13
to stalker-m...@googlegroups.com

Klaas Jan Wierenga

unread,
Apr 17, 2013, 4:52:04 AM4/17/13
to stalker-m...@googlegroups.com
Hi Aleksey,

Thanks for the tip. I'll try that.

Cheers,
KJ

Op dinsdag 16 april 2013 16:03:49 UTC+2 schreef Aleksey Zhurbitsky het volgende:

sudoers

unread,
May 15, 2013, 1:33:10 PM5/15/13
to stalker-m...@googlegroups.com

When downgrading to 0.2.14-r3, I was stuck on the screen above. Anybody seen this before?

Thanks.

NikosP

unread,
Nov 30, 2013, 7:01:16 AM11/30/13
to stalker-m...@googlegroups.com


On Thursday, March 21, 2013 1:33:20 AM UTC+2, sudoers wrote:


Hi all,
It seems that the Point of no return for downgrade capability is version 0.2.14-r3. All versions above, are not dowbgradable, with error diagnostic: "Invalid File Header", when trying to downgrade via inner portal & USB flash.

Here is a solution that worked for me:

1. Edit (Notepad+..works fine) imageupdate file of version 0.2.14-r3..you get at the beginning:

STB Model:MAG250
Date: Fri Nov 2 18:42:50 EET 2012
Image Version:214
Image Description:0.2.14-r3-250
Kernel size:2625315
Image  size:54484599
Start data...

DO NOT CARE FOR THE REST

2.
Modify the above 7 lines according following:

STB Model:MAG250
Date: Fri Nov 2 18:42:50 EET 2012
Image Version:214
Image Description:0.2.14-r3-pub-250
VerUpdateAPI:2
Kernel size:2625315
Image  size:54484599
Start data...

Modifications take place in ImageDescription field and adding VerUpdateAPI line

3. save file and place it to USB

4. Enter BIOS

5 Upgrade via BIOS and USB flash (where imageupdate and bootstrap files are located)

6. It probably works for lower versions than 0.2.14-r3...but did not test

Regards


noid

unread,
Oct 2, 2015, 5:48:03 PM10/2/15
to Stalker Middleware
lol
Reply all
Reply to author
Forward
0 new messages