Missing package(s) in LTS 5.9/5.10/5.11/5.12

36 views
Skip to first unread message

Manuel Chakravarty

unread,
Apr 12, 2016, 9:33:06 PM4/12/16
to Stackage
One of my beta testers just noticed something odd. At least one package, namely 'tagsoup', included in LTS Haskell 5.9-5.12, is listed on the website and is in the cabal.config files, but it is not being served by the Stackage package server (at least, not as part of the package index). Here is the package page:


However, if you specify LTS 5.9 to 5.12 as the resolver, `cabal install tagsoup` will fail with an error message claiming that the package does not exist. (Yes, this is assuming `cabal update` has been run.) To understand why that is happening, I manually grabbed


and the package is indeed not included in the index. This suggests that something is going wrong during index generation.

Does anybody have any idea what the underlying problem might be?

Manuel

Michael Snoyman

unread,
Apr 13, 2016, 2:57:41 AM4/13/16
to Manuel Chakravarty, Stackage
Good catch, thanks. I've made an update for this at:


The problem was that it was using the old 00-index.tar location, and therefore was missing some newer cabal files. Can you test again and confirm that things are fixed?

--
You received this message because you are subscribed to the Google Groups "Stackage" group.
To unsubscribe from this group and stop receiving emails from it, send an email to stackage+u...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Manuel M T Chakravarty

unread,
Apr 14, 2016, 11:02:47 PM4/14/16
to Michael Snoyman, Stackage
Thanks, Michael, for fixing this so quickly. It now works for me.

Manuel

Michael Snoyman <mic...@snoyman.com>:
Reply all
Reply to author
Forward
0 new messages