Installation Troubles

162 views
Skip to first unread message

Rinaldo B

unread,
Mar 27, 2013, 6:49:40 AM3/27/13
to spyke-...@googlegroups.com
Hi,

I couldnt get Spykeviewer to run. Here is the installation history (Lubuntu 12.10)

- First try I wanted to install it from the source

git clone git://github.com/rproepp/spykeviewer.git
sudo python setup.py install

- the instalattion aborted with

Processing guiqwt-2.2.1.zip
[...]
ImportError: No module named guidata.utils

- I figured I should have read the manual more slosely and install the dependencies via apt-get

sudo apt-get install python-guiqwt python-tables python-matplotlib

- then I ran setup.py again (it installs a few more dependencies via easy-install), installation was successfully completed
- I started spykeviewer...

rinaldo@rinaldo:~$ spykeviewer
Traceback (most recent call last):
File "/usr/local/bin/spykeviewer", line 9, in <module>
load_entry_point('spykeviewer==0.2.1', 'gui_scripts', 'spykeviewer')()
File "/usr/local/lib/python2.7/dist-packages/spykeviewer-0.2.1-py2.7.egg/spykeviewer/start.py", line 28, in main
from ui.main_window_neo import MainWindowNeo
File "/usr/local/lib/python2.7/dist-packages/spykeviewer-0.2.1-py2.7.egg/spykeviewer/ui/main_window_neo.py", line 28, in <module>
from plugin_editor_dock import PluginEditorDock
File "/usr/local/lib/python2.7/dist-packages/spykeviewer-0.2.1-py2.7.egg/spykeviewer/ui/plugin_editor_dock.py", line 10, in <module>
from spyderlib.utils.module_completion import moduleCompletion
ImportError: cannot import name moduleCompletion

- I figuered that maybe I got the source of the developer version and hence the trouble, googled up how to clone the master branch

git -b master clone git://github.com/rproepp/spykeviewer.git

- repeated installation via setup.py, same error :S

- Second try

sudo pip install spykeviewer

- no luck, still same error
- Third try via NeuroDebian, i found these lines to add the repo

wget -O- http://neuro.debian.net/lists/quantal.de-m | sudo tee /etc/apt/sources.list.d/neurodebian.sources.list
sudo apt-key adv --recv-keys --keyserver pgp.mit.edu 2649A5A9

- then 
sudo apt-get update
sudo apt-get install spykeviewer

- it installed lots of additional stuff, didnt really feel comfortable bout that
- started spykeviewer...

rinaldo@rinaldo:~$ spykeviewer
bash: /usr/local/bin/spykeviewer: No such file or directory

doh. I attach the full logs.

cheers,

rinaldo

Robert Pröpper

unread,
Mar 27, 2013, 8:57:27 AM3/27/13
to spyke-...@googlegroups.com
Hi Rinaldo,

wow - you managed to get some pretty specific installation problems! I
tried to reproduce the errors on a quick virtual Lubuntu install and
they only appear if one takes the specific steps you did (i.e. not
reading the manual closely at first ;-) ). I could not reproduce the
final issue with the missing executable, I suspect it stems from having
various different installations of Spyke Viewer at the same time though.

The reason for the launch error is that the Spyder guys apparently
changed the name of their moduleCompletion function some weeks ago...

Anyway, I've fixed this issue with very recent versions of Spyder in the
development branch. You actually got the same (non-develop) version in
all your installations, since the default branch on GitHub is the master
branch. So, to get a working Spyke Viewer, first uninstall the
NeuroDebian version:
sudo apt-get remove spykeviewer

Next, get the develop branch from GitHub (you need the development
version of spykeutils as well):
git clone git://github.com/rproepp/spykeutils.git -b develop
git clone git://github.com/rproepp/spykeviewer.git -b develop

Then, install both (spykeutils first) using setup.py install.

Best,
Robert
> --
> You received this message because you are subscribed to the Google
> Groups "Spyke Viewer" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to spyke-viewer...@googlegroups.com.
> To post to this group, send email to spyke-...@googlegroups.com.
> Visit this group at http://groups.google.com/group/spyke-viewer?hl=en.
>
>

Reply all
Reply to author
Forward
0 new messages