unable to upgrade to 5.3.3 from anaconda navigator

46 views
Skip to first unread message

Thomas Loeff

unread,
Nov 7, 2022, 11:33:16 PM11/7/22
to spyder
When I try to upgrade Spyder in Navigator, the upgrade doesn't finish. The only way I have gotten Sypder 5.3.3 is as a stand-alone.

Is there a way to uninstall anaconda and all of its components, folders, shortcuts etc. in case my previous installations are causing problems? I've tried plain uninstall, but I'm always left with folders etc.

M Hagen

unread,
Nov 18, 2022, 6:26:01 PM11/18/22
to spyder
Any response on this?
I also cannot upgrade Spyder from 5.2.2. Attempting to upgrade in the base env causes the install script to just hang due to some unknown conflict. It was suggested that I install in a new conda environment. I tried making a spyder533 named env. But I get a new error when I try to install *any* package in this new env:
"CondaSSLError: OpenSSL appears to be unavailable on this machine. OpenSSL is required to download and install packages." 
 
I also tried running the reset Spyder script and uninstalling Anaconda and reinstalling it. Both attempts brought no joy.
I appear to be stuck.
-Mark

Carlos Córdoba

unread,
Nov 19, 2022, 8:03:57 PM11/19/22
to spyd...@googlegroups.com
Hi,

It seems your Anaconda installation is corrupted, so it's better for you to remove it and reinstall it.


Cheers,
Carlos

El 18/11/22 a las 18:26, M Hagen escribió:
--
You received this message because you are subscribed to the Google Groups "spyder" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spyderlib+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/spyderlib/315fe905-76b4-4838-b779-48122d97a96an%40googlegroups.com.

Arun NY

unread,
Dec 14, 2022, 12:32:35 AM12/14/22
to spyder
I had the same issue. Uninstalling 5.2.2 and them installing 5.3.3 worked.
Reply all
Reply to author
Forward
0 new messages