Installation Problems, Springdale Linux

37 views
Skip to first unread message

flja...@shaw.ca

unread,
Feb 22, 2019, 10:44:21 PM2/22/19
to springdale-users
When I attempt to install either Springdale Linux 7.6 i386
from the boot .iso, or Springdale Linux 7.5 i386 from the
netinst.iso, specifying a Gnome desktop,
failure occurs with the diagnostic message,
"ntfsprogs is missing".  I've observed that in the
Springdale Linux 7.6 repositories, a 64-bit binary rpm
for ntfsprogs is available, but a 32-bit binary rpm is not.

On my CentOS7 test system,  I've done a 2-step build

(rpm -ivh --nomd5, rpmbuild -bb) from the ntfs-3g .src rpm,
which produces 3 .i686 binary rpm's, ntfs-3g, ntfs-3g-devel,
and ntfsprogs.  The first 2 are already available in the
Springdale Linux 7.6 repositories, but the 3rd one is not.

I believe my installation problems would be solved if the
3rd one was added in ??

Len Jarvis

JP

unread,
Feb 25, 2019, 2:26:33 PM2/25/19
to springdale-users
Good morning,

sure, that should be easy enough, I'll take a look.  Sorry for delay - distracted with work and rhel8...

Josko

--
You received this message because you are subscribed to the Google Groups "springdale-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to springdale-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

JP

unread,
Feb 25, 2019, 2:38:56 PM2/25/19
to springdale-users
OK, I see what the problem is.  We have them but they are in Addons repo - the easiest fix is to include that one on any machine that has an ntfs partition and then it should pick if up.  Have you tried that yet?

JP

Jay F. Shachter

unread,
Feb 25, 2019, 2:58:46 PM2/25/19
to springda...@googlegroups.com

Centuries ago, Nostradamus predicted that JP would write on Mon Feb 25 13:38:44 2019:

>
> OK, I see what the problem is. We have them but they are in Addons
> repo - the easiest fix is to include that one on any machine that
> has an ntfs partition and then it should pick if up. Have you tried
> that yet?
>

I had the same problem (and it was unfixable, so I gave up and
installed a variant of Fedora instead), and I don't understand what
you are telling us to do. Anaconda says that it cannot find
ntfsprogs, and that it is a fatal error, and it fails. Are you
telling us that we should Ctrl-Alt-F? to a text-only shell and
manually change the contents of /etc/yum.repos.d while anaconda is
running, before it chokes on the fatal error? How are we going to
know what to put into /etc/yum.repos.d when anaconda does not tell us
what baseurl we need to put in there? I have a better idea -- how
about you just put the ntfs packages into the repository that anaconda
already knows about? Are you unwilling to do that because it breaks
compatability with RHEL? I won't tell anyone if you don't.

Speaking of RHEL, and completely unrelated to the above -- is there a
Springdale 8 Beta iso, or are you waiting for an official release?


Jay F. Shachter
6424 North Whipple Street
Chicago IL 60645-4111
(1-773)7613784 landline
(1-410)9964737 GoogleVoice
http://m5.chicago.il.us
j...@m5.chicago.il.us

"But when she traced the killer's IP address ... it was in the 192.168/16 block!"

Benjamin Rose

unread,
Feb 25, 2019, 4:07:23 PM2/25/19
to springda...@googlegroups.com
Hello,

During the installation prep phase, there is an option to add additional repos during the installation. In this screenshot I found:


It would live under Software => Installation Source

Once in there, you can add the Addons repo. The URL for that from the primary mirror is:


Once it's added, you can proceed with the installation as normal, and "ntfsprogs" should this time be located as expected.

I defer to JP to decide whether or not we would include this as part of core, but in usual we tend to try and mirror what RHEL does as best as possible, even down to being bug-compatible from time to time. That's not to say we don't have patches of our own or set things up a little differently, especially as the software ages. But it is taken on a case by case basis.

RHEL8 progress is being made but we are nowhere near ready for any sort of release on that. The goal for now is to see what we can build without too much manual intervention. Ideally it goes pretty smooth and we can start testing an installation or two, but even then it would be in the goal of an internal bootstrap for a total mass rebuild, especially once a general release is made.

Ben

JP

unread,
Feb 25, 2019, 4:36:43 PM2/25/19
to springdale-users
Actually, it's even simpler then that - once network is activated (so go to networks, configure/activate your network interface), go once to "Installation source" screen, essentially just click OK but then if you go back to it you should see additional repositories (Addons/Updates/Computational) now populated and selectable.

Screenshot attached of what it should look like.

But, can add - I so rarely deal with windows/ntfs that I've never hit this pain point but can commiserate, have seen it enough.  I'll see about doing it tonight.

Josko

sdl7i386.png

flja...@shaw.ca

unread,
Feb 26, 2019, 2:55:54 PM2/26/19
to springdale-users
Examination of the Addons repo shows that,
for ntfs-3g and ntfs-3g-devel, both x86_64 and i686 binary rpm's are present,
but for ntfsprogs, only the x86_64 binary rpm is there, no i686 rpm.

If that missing i686 rpm could be added to the Addons repo, the
problem would be solved.
*********************************************************************************************
re: the suggestion, " the easiest fix is to include that one on any machine that
                                has an ntfs partition and then it should pick if up."

It occurred to me that a way to include the missing rpm is to install in a
local repo in a partition on my multi-partition test machine, but I
don't know what the syntax would be for a URL referencing the local repo
from the boot.iso network configuration dialogue ????

Len

JP

unread,
Feb 27, 2019, 2:30:09 PM2/27/19
to springdale-users
Hi Len,

actually that rpm is there and always was, weird that you are not seeing it.  But I did add it to the core as well so new installs should pick it up on their own from there too.

JP

--

flja...@shaw.ca

unread,
Mar 1, 2019, 12:12:19 AM3/1/19
to springdale-users
JP:   Further to your Feb. 27 comments:

With your addition of the ntfsprogs rpm to the core,  I got past that
problem but encountered a new failure.  In the Updates section of
the primary installation source file you show in your screen attachment, sdl7i386.png,
there is a new version of grub2-pc rpm, but it causes a failure because
there is no corresponding grub2-pc-modules rpm.

Your screen attachment seems to show a newer version
of "Installation Source" than what
is used by the Springdale Linux 7.6 i386 boot.iso,  which for
Additional repositories only has the category "New repository".
Trying to use the two entries you have illustrated causes an
error message, "duplicate repositories".
***************************************************************************************
What finally worked for me was to use as the primary repository,

springdale.math.ias.edu/data/springdale/7.6/i386/os
(which has no Updates section, and therefore uses the original
 grub2-pc and grub2-pc-modules),

and a secondary "new" repository,
springdale.princeton.edu/data/springdale/7.6/i386/os/Addons

which points directly at the Addons section to get ntfsprogs.
*****************************************************************************************
The installation went to completion (3.5 hours on my slow Internet
connection),  but the resultant login screen does not allow any
character entry.

I'm wondering if this bug was actually cured by something in the
Updates section which I've bypassed with my source maneuvers
above ????

Len


Len

On Friday, 22 February 2019 19:44:21 UTC-8, flja...@shaw.ca wrote:

flja...@shaw.ca

unread,
Mar 2, 2019, 12:21:03 AM3/2/19
to springdale-users
JP:   Further to my comments yesterday about not being able to
       login on my just-installed Springdale Linux 7.6 i386:

      Today, I found that I could login by using the screen keyboard,
       but could not enter any input in a terminal session, and could
       not enter a URL in a Firefox browser session.

      My test machine is an HP DC5700 with 8 partitions defined,
      and other Linux distros functioning normally in some of them.

      My normal keyboard plugs into a keyboard port on the back of
      the machine.

      As a guess, I disconnected that keyboard, substituted another one
      which plugs into a USB port, and rebooted the machine.
      I was surprised, relieved and totally puzzled to find that Springdale
      Linux 7.6 now works fine !!!

      My thanks to you and Jay and Benjamin for helping me find my
      way through this !


      Len

On Friday, 22 February 2019 19:44:21 UTC-8, flja...@shaw.ca wrote:
Reply all
Reply to author
Forward
0 new messages