What's your preference? /program for both? /programs for both? Keep
the two different names? I'm tempted to combine them just to keep the
clutter down. Remember, I'll be adding methods for /collections,
/feeds and /members. Part of the REST philosophy suggests that
something like /program/123 (to refer to a single program) should be
usable as /program (no #) to refer to *all* programs. I don't want to
get too cute or too philosophical about this, but I'm curious which
makes more sense to developers who will use the API.