protein prophet failing on Eclipse searches

14 views
Skip to first unread message

cabarnes...@gmail.com

unread,
Nov 29, 2022, 1:31:29 PM11/29/22
to spctools-discuss
Hi all,

Happy holidays!  I have a new Eclipse in the lab and have been running my Comet + TPP pipeline successfully on a lot of data downloaded from PRIDE lately, but have run into an error with the new DDA data generated on the Eclipse.  It seems to be failing at the protein prophet step and the error doesn't make much sense to me.  Any idea what is going on?

I'm running TPP 6.1 and Comet 2022.01 rev. 1 although the error below is from the output of the Comet search through the TPP interface.  I get a similar error on the command line at the same step.  


Here's the error message:

WARNING: no data - output file will be empty

command "C:/TPP/bin/ProteinProphet "interact.pep.xml" "interact.prot.xml"" failed: Operation not permitted

command "C:/TPP/bin/ProteinProphet "interact.pep.xml" "interact.prot.xml"" exited with non-zero exit code: 1
QUIT - the job is incomplete

Luis Mendoza

unread,
Nov 29, 2022, 7:34:48 PM11/29/22
to spctools...@googlegroups.com
Hi,
Congrats on the new instrument, and happy holidays as well!

The error seems to indicate that there is no input data for ProteinProphet to work with; can you verify that the input file contains validated search results with probabilities above 0.2 ?  Are there any other errors or warnings in the previous steps?

Feel free to directly send me the interact.pep.xml file and I can have a look as well.

Cheers,
--Luis


--
You received this message because you are subscribed to the Google Groups "spctools-discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spctools-discu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/spctools-discuss/1a4f392c-7ec1-411b-8300-90c0f6b48158n%40googlegroups.com.

David Shteynberg

unread,
Nov 30, 2022, 10:37:07 AM11/30/22
to spctools...@googlegroups.com
Hello,

Generally this message means that you have no PSMs with good likelihoods of being correct in this analysis set.
There are a few "usual suspect" reasons for why you would not observe any PSMs with non-zero probabilities among your results.

1. Poor quality data (e.g. empty sample)

2. Incorrect database (e.g. wrong organism, common contaminants missing)

3. Incorrect search parameters (e.g. wrong tolerances or incorrect static modifications specified)

Please go down the list to help yourself troubleshoot.

-David



 

cabarnes...@gmail.com

unread,
Nov 30, 2022, 7:51:05 PM11/30/22
to spctools-discuss
Hi all.  Thanks for resolving this error.  To everyone else, this was user error on my part.  
Reply all
Reply to author
Forward
0 new messages