bugged

31 views
Skip to first unread message

gmamo...@gmail.com

unread,
Feb 5, 2015, 9:14:30 AM2/5/15
to spatiocy...@googlegroups.com
error

Traceback (most recent call last):
  File "/usr/local/bin/ecell3-session-monitor", line 7, in <module>
    import ecell.ecs
  File "/usr/local/lib/python2.7/dist-packages/ecell/ecs.py", line 28, in <module>
    import ecell._ecs
ImportError: libecs.so.2: cannot open shared object file: No such file or directory

Can help?

Satya Arjunan

unread,
Feb 5, 2015, 9:49:52 AM2/5/15
to spatiocy...@googlegroups.com
Hi I can help :)

It seems you have installed Spatiocyte under /usr/local directory instead of the default $HOME/root. The problem is that it is unable to look for the libecs.so.2 file under in the LD_LIBRARY_PATH. Can you confirm if the file is in /usr/local/lib? If so, please add the following line in your ~/.bashrc file if you are using Linux, or ~/.profile if you on Mac OS X:

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH:.

Let me know if you still have any issues.

satya

gmamo...@gmail.com

unread,
Feb 5, 2015, 1:55:11 PM2/5/15
to spatiocy...@googlegroups.com
Solved! Thanks in advance!

Satya Arjunan

unread,
Feb 5, 2015, 6:50:43 PM2/5/15
to spatiocy...@googlegroups.com
Hi that's great!
FYI, the default installation directory is $HOME/root as given by the install directory prefix in this Linux install script https://github.com/ecell/spatiocyte/blob/master/install-spatiocyte-ubuntu.sh

Let me know if you have any other issues in future.

On 6 February 2015 at 03:55, <gmamo...@gmail.com> wrote:
Solved! Thanks in advance!

--
You received this message because you are subscribed to the Google Groups "Spatiocyte Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spatiocyte-use...@googlegroups.com.
Visit this group at http://groups.google.com/group/spatiocyte-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/spatiocyte-users/1ff293a2-83e0-4ee9-b6f1-299607983065%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Reply all
Reply to author
Forward
0 new messages