WSJTX Command Line Error - Unknown options

51 views
Skip to first unread message

Doug Lung

unread,
May 31, 2024, 2:23:15 AMMay 31
to SparkSDR
I've just started using SparkSDR on my Fedora 40 laptop. I like the program but am having a problem with WSJTX decodes above 0, where the program needs to call the installed wsjtx program. wsjtx is in the default location at /usr/bin/wsjtx. 

The error is:
"Command line error
Unknown options: 8, m, d."

SparkSDR was installed using the .rpm on SparkSDR.com and wsjtx is from the Fedora repository. I also tried using the "improved" rc version of WSJTX compiled from source and received the same error from it. 

Current versions are:
SparkSDR-2.0.33-0.x86_64
wsjtx-2.7.0-3.fc40.x86_64

Any suggestions on what I can to try to fix this? 

73,
     Doug, AH6DL


ahop...@googlemail.com

unread,
Jun 28, 2024, 4:20:13 AMJun 28
to SparkSDR
Hi Doug,
sorry I missed this message somehow.
What path do you have set in spark for wsjtx, it sounds like you have it pointing to the wsjtx executable when it should point to the jt9 executable.
73 Alan M0NNB

Doug Lung

unread,
Jun 28, 2024, 5:25:27 PMJun 28
to SparkSDR
Thanks Alan! 

That fixed it. I had the FT8 decoder pointed to wsjtx executable path. When I changed it to the jt9 executable path it started working. 

73 Doug AH6DL

Reply all
Reply to author
Forward
0 new messages