unable to run!

37 views
Skip to first unread message

Bg

unread,
Apr 8, 2013, 6:43:21 AM4/8/13
to sovereign...@googlegroups.com
java.lang.ClassNotFoundException: sneer.bricks.software.folderconfig.impl.FolderConfigImpl
    at basis.brickness.impl.ClassLoaderForBricks.doLoadClass(ClassLoaderForBricks.java:37)
    at basis.brickness.impl.EagerClassLoader.loadClass(EagerClassLoader.java:25)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at basis.brickness.impl.BrickImplLoader.loadImplClassFor(BrickImplLoader.java:29)
    at basis.brickness.impl.BricknessImpl.tryToLoadBrick(BricknessImpl.java:67)
    at basis.brickness.impl.BricknessImpl.loadBrick(BricknessImpl.java:57)
    at basis.brickness.impl.BricknessImpl.access$000(BricknessImpl.java:16)
    at basis.brickness.impl.BricknessImpl$1.provide(BricknessImpl.java:50)
    at basis.environments.EnvironmentUtils$1.provide(EnvironmentUtils.java:14)
    at basis.environments.CachingEnvironment$1.evaluate(CachingEnvironment.java:20)
    at basis.environments.CachingEnvironment$1.evaluate(CachingEnvironment.java:19)
    at basis.lang.CacheMap.get(CacheMap.java:54)
    at basis.lang.CacheMap.get(CacheMap.java:27)
    at basis.environments.CachingEnvironment.provide(CachingEnvironment.java:26)
    at basis.brickness.impl.BricknessImpl.provide(BricknessImpl.java:37)
    at basis.environments.Environments.my(Environments.java:25)
    at sneer.main.SneerSessionBase.prepare(SneerSessionBase.java:51)
    at sneer.main.SneerSessionBase.access$000(SneerSessionBase.java:30)
    at sneer.main.SneerSessionBase$1.run(SneerSessionBase.java:34)
    at basis.environments.Environments.runWith(Environments.java:13)
    at sneer.main.SneerSessionBase.<init>(SneerSessionBase.java:33)
    at sneer.main.SneerSession.<init>(SneerSession.java:11)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at sneer.main.Sneer.<init>(Sneer.java:19)
    at sneer.installer.Main.main(Main.java:16)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.javaws.Launcher.executeApplication(Unknown Source)
    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
    at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
    at com.sun.javaws.Launcher.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

Klaus Wuestefeld

unread,
Apr 8, 2013, 6:57:44 AM4/8/13
to sovereign...@googlegroups.com
Hi, I just reinstalled Sneer to test and it worked. Are you installing
Sneer for the first time today or could you have an old version
cached? What is your operating system and Java version?

Klaus
> --
> You received this message because you are subscribed to the Google Groups
> "Sovereign Computing" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sovereigncomput...@googlegroups.com.
> To post to this group, send email to sovereign...@googlegroups.com.
> Visit this group at http://groups.google.com/group/sovereigncomputing?hl=en.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>



--
Valeu, Klaus.

Leonardo Santos

unread,
Jul 4, 2013, 12:38:19 PM7/4/13
to sovereign...@googlegroups.com, ma...@klaus.pro
I'm getting the same error!

What info can I provide to help you understand the problem?

SO: Windows 7 Professional 64bits
Java: Java 7 update 25
Java SDK: Java 7 update 9


thanks!

Klaus Wuestefeld

unread,
Jul 4, 2013, 1:18:42 PM7/4/13
to Leonardo Santos, sovereign...@googlegroups.com
Please delete the sneer folder in your user's home folder and try
again. Let me know if the error repeats consistently.

We just had an install fest yesterday with Linux and Windows 7 and all
went well.

Klaus
--
Valeu, Klaus.

Leonardo G. T. dos Santos

unread,
Jul 4, 2013, 1:30:22 PM7/4/13
to Klaus Wuestefeld, sovereign...@googlegroups.com
I did try deleting and retrying several times. The only folder I have to delete is sneer on c:/user/username/sneer   right?


2013/7/4 Klaus Wuestefeld <ma...@klaus.pro>

Klaus Wuestefeld

unread,
Jul 4, 2013, 4:22:13 PM7/4/13
to Leonardo G. T. dos Santos, sovereign...@googlegroups.com
Yes. It does ask you for your passphrase every time, right?

Could you send the stack? I want to make sure its the same.

Klaus
--
Valeu, Klaus.

Leonardo G. T. dos Santos

unread,
Jul 4, 2013, 5:19:15 PM7/4/13
to Klaus Wuestefeld, sovereign...@googlegroups.com
No... it doesn't get to the point that asks me my password :(

I open the sneer.jnlp, accept the therms, see the install location and then wait a little bit... and... crash

Could not add application (screenshot follows)

Imagem inline 1

Arquivo de acionamento:

<jnlp codebase="http://dynamic.sneer.me/" href="sneer.jnlp" spec="1.0+">
  <information>
    <title>Sneer</title>
    <vendor>Sneer Team</vendor>
    <description>Free platform for sovereign applications.</description>
    <description kind="tooltip">Sneer</description>
    <homepage href="http://sneer.me"/>
    <icon href="logo16x16.png"/>
    <offline-allowed/>
    <shortcut online="true">
      <desktop/>
      <menu submenu="Sneer"/>
    </shortcut>
  </information>
  <update check="timeout" policy="always"/>
  <resources>
    <jar href="sneer-bootstrap.jar"/>
    <j2se href="http://java.sun.com/products/autodl/j2se" version="1.7+"/>
  </resources>
  <security>
    <all-permissions/>
  </security>
  <application-desc main-class="sneer.installer.Main">
    <argument>201307031716</argument>
  </application-desc>
</jnlp>

Stack:
Thanks again for the help :)





2013/7/4 Klaus Wuestefeld <ma...@klaus.pro>
image.png

Luan Reis

unread,
Aug 24, 2013, 9:32:15 PM8/24/13
to sovereign...@googlegroups.com, Klaus Wuestefeld
Hello! I'm getting the same error too. Exactly what Leonardo just described.
Reply all
Reply to author
Forward
0 new messages