MAC issue - reopen leads to the same error.

93 views
Skip to first unread message

Lawrence Fine

unread,
Oct 18, 2021, 4:09:14 PM10/18/21
to SonoBus Users
Screen Shot 2021-10-18 at 4.07.44 PM.png

Fabio Katz

unread,
Oct 25, 2021, 10:08:21 PM10/25/21
to SonoBus Users
I get a similar crash report when launching the standalone app (the Plugin works fine).

Cheers,
Fabio

Screen Shot 2021-10-25 at 10.05.22 PM.png

Jesse Chappell

unread,
Oct 25, 2021, 10:32:26 PM10/25/21
to Fabio Katz, SonoBus Users
Thanks, can you do what I mentioned in the previous message and copy and paste the entire *text* (it will be many pages of scrolling selection in that crash popup) and e-mail it to me directly? The screenshot does not give me the information I need for this one. 

Thanks!

Jesse

--
You received this message because you are subscribed to the Google Groups "SonoBus Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sonobus-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sonobus-users/0b6d298b-682f-47ff-9917-5614bc7f8febn%40googlegroups.com.

Jesse Chappell

unread,
Oct 29, 2021, 12:00:44 PM10/29/21
to Fabio Katz, Lawrence Fine, SonoBus Users
Thanks Fabio and Lawrence, for sending me the complete crash
reports... both appear to be crashing at the exact same place in the
code. Unfortunately, this is not reproducible here and no one else has
reported it. You are on different versions of macOS.... curious about
what audio interface is set up as your default on the system.

Also I suggest that both of you remove the sonobus configuration
folder at ~/Library/Application Support/SonoBus. You may have enable
showing the Library folder in your home directory by doing:
From the Home folder in Finder, choose View > Show View Options, and
select Show Library Folder

After removing the SonoBus folder in there, try to relaunch the standalone.

Jesse

On Mon, Oct 25, 2021 at 10:08 PM Fabio Katz <katz...@gmail.com> wrote:
>
> I get a similar crash report when launching the standalone app (the Plugin works fine).
>
> Cheers,
> Fabio
>
>
>
>
> On Monday, October 18, 2021 at 4:09:14 PM UTC-4 loren...@gmail.com wrote:
>>
>>

Lawrence Fine

unread,
Oct 29, 2021, 1:19:33 PM10/29/21
to Jesse Chappell, Fabio Katz, SonoBus Users
Thanks for the tips. PROBLEM? No "show library" ?

BEing a "novice" I hope I'm not doing anything to deepen these problems!
 
--
Live well! No matter how long or short that may be!
peace and love - - - - - - - - - l
Screen Shot 2021-10-29 at 1.17.38 PM.png

Jesse Chappell

unread,
Oct 29, 2021, 2:23:41 PM10/29/21
to Lawrence Fine, Fabio Katz, SonoBus Users
You need to select your Home folder before you choose "Show View
Options"... this is the folder in your sidebar that has a house icon
and is your user name.

Jesse
> To view this discussion on the web visit https://groups.google.com/d/msgid/sonobus-users/CALeA-c9iD8VDp4g%2BvQRG-Loumb1hg-0%3DVwCHHWSmBfobHv6B0A%40mail.gmail.com.

Marcin Pączkowski

unread,
Oct 29, 2021, 2:26:39 PM10/29/21
to Jesse Chappell, Lawrence Fine, Fabio Katz, SonoBus Users
You need to select your Home folder before you choose "Show View
Options"... this is the folder in your sidebar that has a house icon
and is your user name.
Alternatively, when you're in Finder, select "Go" from the top menu and the press Alt/Option - the Library entry should show up and you can open it from there.
Marcin

Lawrence Fine

unread,
Oct 29, 2021, 2:44:21 PM10/29/21
to Marcin Pączkowski, Jesse Chappell, Fabio Katz, SonoBus Users
still not getting the option.

Marcin Pączkowski

unread,
Oct 29, 2021, 3:59:35 PM10/29/21
to Lawrence Fine, Jesse Chappell, Fabio Katz, SonoBus Users
This is how it should like once you press the Alt/Option key:
image.png

Fabio Katz

unread,
Oct 29, 2021, 4:37:09 PM10/29/21
to Jesse Chappell, Lawrence Fine, SonoBus Users
Hi Jesse,

I have macOS 12.0.1 (Monterey) and my audio interface is PresSonus Quantum.

I tried deleting the ~/Library/Application Support/SonoBus folder and reinstalling 1.4.6, same crash on launch of standalone app.
I also tried selecting the Mac mini as the System Audio Output, no change.

Thanks,
Fabio

On Fri, Oct 29, 2021 at 12:00 PM Jesse Chappell <je...@sonosaurus.com> wrote:

Mika Juola

unread,
Jan 24, 2022, 7:04:33 AMJan 24
to SonoBus Users
Hi! Im new user (just installed Sonobs) First time I tied to open app, it crashed after it asked something about audio setup. Rebooted machine and tried again and same result. Then I changed my audio preferences to computers devices and after that Sonobus started OK! Then I made audio setup again and everything is working ok! Sorry my bad english, but hope you understand!

M1 pro, Audient EVO8

Mika

Evan Bovie

unread,
Mar 21, 2022, 5:20:55 PMMar 21
to SonoBus Users
Hey there, I've filed a bug #123 on GitHub regarding a crash similar to this. SonoBus seems to only work when the input and output audio devices share the same sample rate. You can check this using Audio MIDI Setup in macOS. As long this is the case, and those I/O devices are selected as the defaults, then SonoBus should launch.
Reply all
Reply to author
Forward
0 new messages