Question on sonic-mgmt-framework

31 views
Skip to first unread message

Amaresh Parida

unread,
Jan 7, 2022, 8:05:37 AMJan 7
to sonicproject
Hello,

I am trying to config redisdb through rest api mgmt interface.
I am facing issue where I could able to connect to the rest_server in the mgmt framework but the get and post operation are failing. In short not able to fetch or config the redisdb.

I am testing with standard sonic docker build downloaded from 

I am creating 2 container in one I am running "target/docker-sonic-vs.gz" and in other "target/docker-sonic-mgmt-framework.gz". While starting the mgmt-framework docker the rest_server was not starting and once I mount the volume /var/run/redis/redis.sock from sonic-vs container to sonic-mgmt-framework container, the rest_server is up but the redis database connectivity still not happening.

I have read the latest version of sonic-mgmt-framework spilt into 2. The original one (sonic-mgmt-framework)is having rest_server and sonic-mgmt-common which has the translib part. 
Questions: 
1> Do I am missing anything here? Whether the translib(sonic-mgmt-common) linked to the sonic-mgmt-framework?  Or do I need to do it by some means? Please suggest.
Here is how I run the docker:
--> docker run  --name APsonic -v /var/run/redis:/var/run/redis -d docker-sonic-vs:latest
--> docker run --name APsonicMgmtFr  -v /var/run/redis:/var/run/redis -d docker-sonic-mgmt-framework:latest

Here is my topology and few more details. Much appreciate your help.

topology.JPG


Thanks,
Amaresh


Reply all
Reply to author
Forward
0 new messages