Freebsd as vlan trunk controller.

10 views
Skip to first unread message

pe...@skyrunner.net

unread,
Nov 28, 2002, 3:32:24 PM11/28/02
to
I'm looking for pointers/tips/stories on configuring freebsd for use as a
vlan trunk controller for connecting to a cisco 2624 switch.

Any pointers to docs/how to's or personal experience is appreciated.

TIA


Peter Brezny
Skyrunner.net

To Unsubscribe: send mail to majo...@FreeBSD.org
with "unsubscribe freebsd-isp" in the body of the message

le...@primus.ca

unread,
Nov 28, 2002, 8:24:03 PM11/28/02
to
On Thu, 28 Nov 2002, Peter Brezny wrote:

> I'm looking for pointers/tips/stories on configuring freebsd for use as a
> vlan trunk controller for connecting to a cisco 2624 switch.
>
> Any pointers to docs/how to's or personal experience is appreciated.
>

Are you referring to the VLAN Trunking Protocol? If so, then from what I
can tell, the 2624 does not support VTP. It doesn't even seem to support
actual VLAN tagging. (And, if it supports one it should support the
other.) Instead, this switch just allows you to create multiple broadcast
domains within itself, not actual VLANs.

Also, I think you might be referring to doing a "router on a stick"
configuration. That is, every VLAN can talk to a single port. This
requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
trunking. As far as that goes, I've not looked into anything like that
before.

pe...@skyrunner.net

unread,
Nov 28, 2002, 10:36:09 PM11/28/02
to
Jason,
I had a typo, it's a 2924m-xl

Thanks for the tips however...

My main problem here is that I don't really know what I'm talking about.
I'm just now looking into configuring vlans with freebsd and literally know
very little more than about a half hours flip through the man pages.

I want a freebsd box with 2 fast Ethernet adapters to act as a router, and
instead of putting several multiport cards into that box, I want one of the
fast Ethernet adapters to go into a switch, which will have vlans. I want
the bsd system to send the traffic to the appropriate vlan, so that if I
desire, I could have the equivalent of 24 nic's in one freebsd box.

I believe what I am after is something that can handle the 802.1q

Any help on clearing up terminology and pointers to good hardware to use,
whether or not this Cisco 2924m-xl or another Cisco 1900.

I've got a lot of reading to do, i've only scraped the tip of the iceburg.
Any tips would be appreciated.


Peter Brezny
Skyrunner.net


-----Original Message-----
From: Jason Hunt [mailto:le...@primus.ca]
Sent: Thursday, November 28, 2002 8:23 PM
To: Peter Brezny
Cc: freeb...@FreeBSD.ORG
Subject: Re: Freebsd as vlan trunk controller.


On Thu, 28 Nov 2002, Peter Brezny wrote:

> I'm looking for pointers/tips/stories on configuring freebsd for use as a
> vlan trunk controller for connecting to a cisco 2624 switch.
>
> Any pointers to docs/how to's or personal experience is appreciated.
>

Are you referring to the VLAN Trunking Protocol? If so, then from what I
can tell, the 2624 does not support VTP. It doesn't even seem to support
actual VLAN tagging. (And, if it supports one it should support the
other.) Instead, this switch just allows you to create multiple broadcast
domains within itself, not actual VLANs.

Also, I think you might be referring to doing a "router on a stick"
configuration. That is, every VLAN can talk to a single port. This
requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
trunking. As far as that goes, I've not looked into anything like that
before.

hu...@island.net.au

unread,
Nov 28, 2002, 11:57:35 PM11/28/02
to
Hi Peter,

well hopefully this will be helpful.

Yes FreeBSD will be able to handle this. You will definately be looking to
use 802.1q as ISL is a Cisco proprietary standard and requires special
hardware. The 2924 will do this and 802.1q depending upon the software
version....

Doing VLAN trunking you will tell the switch which VLANs you want sent to
the port the FreeBSD computer is on (this might be all of them).

At the trunk end (FreeBSD computer) you will have a NIC. This will be the
parent (will not have an IP address) and for each VLAN that you want to
connect to define a what is known as a sub-interface or a cloned interface.

On the interface front I believe that the fxp driver is supposed to be the
best for most things.

man vlan
man ifconfig

contain a lot of info for what you are trying to do, also there is a nice
article here:

http://www.arved.de/bsd/vlan_en.html

that should hopefully sort out all the syntax for you.

Regards,

Hugh

mi...@sentex.net

unread,
Nov 29, 2002, 8:01:25 AM11/29/02
to

There have been many examples of this posted to the various FreeBSD =
lists.
a quick search via google groups should bring up further examples and
discussions. While other cards supposedly work, I only have experience
with the fxp (intel) cards.


e.g. on the cisco side,

interface FastEthernet0/2
description accounting network
duplex full
speed 100
switchport access vlan 151
no cdp enable

interface FastEthernet0/3
description the 192.168.135.0/24 network
duplex full
speed 100
switchport access vlan 100
no cdp enable

interface FastEthernet0/4
description trunk to my FreeBSD box
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,80,81,92,95,98,100,102-160,1000-1005
switchport mode trunk
no cdp enable


On the FreeBSD side fxp0 is plugged into fa0/4

#10.255.255.254 is an address not used anywhere in our network
ifconfig fxp0 10.255.255.254 netmask 255.255.255.255 media 100baseTX
mediaopt full-duplex

#this will join the vlan/collision domain on port fa0/3
/sbin/ifconfig vlan0 192.168.135.202 netmask 255.255.255.240 vlan 100
vlandev fxp0 mtu 1500 up

#if we defined only 1 vlan in the kernel, lets clone/create a new
#interface via the create command
#join the accounting vlan on fa0/2
ifconfig vlan1 create
/sbin/ifconfig vlan1 192.168.199.1 netmask 255.255.255.240 vlan 151 =
vlandev
fxp0 mtu 1500 up


---Mike

On Thu, 28 Nov 2002 22:35:50 -0500, in sentex.lists.freebsd.isp you =
wrote:

>Jason,
>I had a typo, it's a 2924m-xl
>
>Thanks for the tips however...
>
>My main problem here is that I don't really know what I'm talking about.

>I'm just now looking into configuring vlans with freebsd and literally =


know
>very little more than about a half hours flip through the man pages.
>

>I want a freebsd box with 2 fast Ethernet adapters to act as a router, =
and
>instead of putting several multiport cards into that box, I want one of =
the
>fast Ethernet adapters to go into a switch, which will have vlans. I =


want
>the bsd system to send the traffic to the appropriate vlan, so that if I
>desire, I could have the equivalent of 24 nic's in one freebsd box.
>
>I believe what I am after is something that can handle the 802.1q
>

>Any help on clearing up terminology and pointers to good hardware to =


use,
>whether or not this Cisco 2924m-xl or another Cisco 1900.
>

>I've got a lot of reading to do, i've only scraped the tip of the =


iceburg.
>Any tips would be appreciated.
>
>
>Peter Brezny
>Skyrunner.net
>
>
>-----Original Message-----
>From: Jason Hunt [mailto:le...@primus.ca]
>Sent: Thursday, November 28, 2002 8:23 PM
>To: Peter Brezny
>Cc: freeb...@FreeBSD.ORG
>Subject: Re: Freebsd as vlan trunk controller.
>
>
>On Thu, 28 Nov 2002, Peter Brezny wrote:
>

>> I'm looking for pointers/tips/stories on configuring freebsd for use =


as a
>> vlan trunk controller for connecting to a cisco 2624 switch.
>>
>> Any pointers to docs/how to's or personal experience is appreciated.
>>
>

>Are you referring to the VLAN Trunking Protocol? If so, then from what =
I
>can tell, the 2624 does not support VTP. It doesn't even seem to =


support
>actual VLAN tagging. (And, if it supports one it should support the

>other.) Instead, this switch just allows you to create multiple =


broadcast
>domains within itself, not actual VLANs.
>
>Also, I think you might be referring to doing a "router on a stick"
>configuration. That is, every VLAN can talk to a single port. This
>requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
>trunking. As far as that goes, I've not looked into anything like that
>before.
>
>
>-----Original Message-----
>From: Jason Hunt [mailto:le...@primus.ca]
>Sent: Thursday, November 28, 2002 8:23 PM
>To: Peter Brezny
>Cc: freeb...@FreeBSD.ORG
>Subject: Re: Freebsd as vlan trunk controller.
>
>
>On Thu, 28 Nov 2002, Peter Brezny wrote:
>

>> I'm looking for pointers/tips/stories on configuring freebsd for use =


as a
>> vlan trunk controller for connecting to a cisco 2624 switch.
>>
>> Any pointers to docs/how to's or personal experience is appreciated.
>>
>

>Are you referring to the VLAN Trunking Protocol? If so, then from what =
I
>can tell, the 2624 does not support VTP. It doesn't even seem to =


support
>actual VLAN tagging. (And, if it supports one it should support the

>other.) Instead, this switch just allows you to create multiple =


broadcast
>domains within itself, not actual VLANs.
>
>Also, I think you might be referring to doing a "router on a stick"
>configuration. That is, every VLAN can talk to a single port. This
>requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
>trunking. As far as that goes, I've not looked into anything like that
>before.
>
>
>
>
>To Unsubscribe: send mail to majo...@FreeBSD.org
>with "unsubscribe freebsd-isp" in the body of the message

Mike Tancsa (mi...@sentex.net)=09
http://www.sentex.net/mike

Reply all
Reply to author
Forward
0 new messages