[ask snoozeclient instalation]

52 views
Skip to first unread message

ferdi s. a.

unread,
May 22, 2012, 4:44:26 AM5/22/12
to snoozesoftware
helo, may i ask question in here?
i am a newbie, and want to try it. now i want to install cluster
deployment.
there are thing that make me confuse.
should i use 3 PC's?
1 for GM, 1 for LC and 1 for client?
because when i try to install client on GM, and run "snoozeclient
visualize". i got blank image.

please if somebodycan help me..

Eugen Feller

unread,
May 22, 2012, 9:15:11 AM5/22/12
to snoozes...@googlegroups.com
Hi,

On 22/05/12 10:44, ferdi s. a. wrote:
> helo, may i ask question in here?
sure.
> i am a newbie, and want to try it. now i want to install cluster
> deployment.
> there are thing that make me confuse.
> should i use 3 PC's?
the tutorial on the website
(http://snooze.inria.fr/documentation/deployment/cluster/) describes a
setup with all management components on one node and compute components
on the other nodes. You need at least one BN, two GMs, and one LC to
have a working Snooze cluster. One of the GMs will automatically become
the GL. For example by following the tutorial you could deploy as follows:

First Node: BN, TWO GMs, ZooKeeper, NFS
Second Node: LC
Third Node: LC

You can imagine many other component combinations. For example:

First Node: BN, GM1, ZooKeeper, NFS
Second Node: GM2, LC1
Third Node: LC2

The only thing you need to take care of are the control and monitoring
data ports if you run multiple Snooze components on a single machine. If
you do not set different ports you will run into port collision problems.

Hope it was helpful.

Best regards,
Eugen

> 1 for GM, 1 for LC and 1 for client?
> because when i try to install client on GM, and run "snoozeclient
> visualize". i got blank image.
you can run the client on any node. Which message do you see in the
status field?

ferdi s. a.

unread,
Jun 19, 2012, 1:31:18 AM6/19/12
to snoozes...@googlegroups.com

Hello Mr Eugen,
My configuration is
First Node: BN, TWO GMs, ZooKeeper, NFS (IP Address 192.168.1.3/24)
Second Node: LC (IP Address 192.168.1.111/24)
Third Node: LC (IP Address 192.168.1.5/24)

1.I have some problem when configure on LC. When i try this step on Second Node (IP address 192.168.1.111/24)

auto br0
iface br0 inet dhcp
    bridge_ports eth0
    bridge_stp on
    bridge_maxwait 0

it is always looking for DHCP IP. is it okay if I change it like this

auto br0 iface br0 inet static
    bridge_ports eth0 bridge_stp on bridge_maxwait 0
    address 192.168.1.112
    broadcast 192.168.1.255
    netmask 255.255.255.0
    gateway 192.168.1.1

2. When i try the final step
   $ /etc/init.d/snoozenode start
   My computer can't start it.

3. Is it possible to test performance my cluster? I want to know the difference using 1 LC and using 2 LC.
I'am very apreciate with your help Mr Eugen.

Best Regards.
Ferdi.

ferdi s. a.

unread,
Jun 21, 2012, 1:29:06 AM6/21/12
to snoozes...@googlegroups.com
Mr Eugen, when i run snoozeclient visualize. I got this message :
"Group leader description is not available"
Can you help me?

Eugen Feller

unread,
Jun 22, 2012, 8:08:31 PM6/22/12
to snoozes...@googlegroups.com
Hi,


On 21/06/12 07:29, ferdi s. a. wrote:
Mr Eugen, when i run snoozeclient visualize. I got this message :
"Group leader description is not available"
Can you help me?

this typically means that you have the bootstrap node online but the GL is not available/was not elected. Please see the GM log files /tmp/snooze* for more details.

Best regards,
Eugen
--
You received this message because you are subscribed to the Google Groups "snoozesoftware" group.
To view this discussion on the web visit https://groups.google.com/d/msg/snoozesoftware/-/cBjLlLKJr1AJ.
To post to this group, send email to snoozes...@googlegroups.com.
To unsubscribe from this group, send email to snoozesoftwar...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/snoozesoftware?hl=en.

ferdi s. a.

unread,
Jun 24, 2012, 8:53:49 AM6/24/12
to snoozes...@googlegroups.com
Oh, my bad. Thanks for instruction.
When i check on /tmp/snoozenode.log, i got my BN listening on wrong port.
Now I can run "snoozeclient visualize", but there are some problem too.

The graph are shown, but only GL(port 5002) and 1 GM(port 5003). The LC are not shown.

Actually I set GL(5000), GM 1 (5002), GM 2 (5003).
On snoozeclient config i wrote this
"general.bootstrapNodes = localhost:5000,192.168.0.2:5001"

On snoozenode.log LC, i got this message
"util.NetworkUtils  - Something critical happened during hypervisor connection: Error connecting to the hypervisor: unable to connect to libvirtd at '127.0.1.1': Connection refuse"

Can you help me sir?
thanks before.
To post to this group, send email to snoozesoftware@googlegroups.com.
To unsubscribe from this group, send email to snoozesoftware+unsubscribe@googlegroups.com.

ferdi s. a.

unread,
Jun 24, 2012, 11:01:17 PM6/24/12
to snoozes...@googlegroups.com
Today i try to run it again, but on snooze_node_bn.log i got this

[Thread-3] bootstrap.BootstrapBackend  - Group leader does not exist or has failed

i run snoozeclient visualize, and got blank image again.
I still confused how to create the GL. Can you help me Mr. eugen?

Eugen Feller

unread,
Jun 25, 2012, 3:02:58 AM6/25/12
to snoozes...@googlegroups.com
On 24/06/12 14:53, ferdi s. a. wrote:
Oh, my bad. Thanks for instruction.
When i check on /tmp/snoozenode.log, i got my BN listening on wrong port.
Now I can run "snoozeclient visualize", but there are some problem too.

The graph are shown, but only GL(port 5002) and 1 GM(port 5003). The LC are not shown.

Actually I set GL(5000), GM 1 (5002), GM 2 (5003).
On snoozeclient config i wrote this
"general.bootstrapNodes = localhost:5000,192.168.0.2:5001"

On snoozenode.log LC, i got this message
"util.NetworkUtils  - Something critical happened during hypervisor connection: Error connecting to the hypervisor: unable to connect to libvirtd at '127.0.1.1': Connection refuse"

Can you help me sir?
Seems libvird is not running on your LC node. Please see http://snooze.inria.fr/documentation/deployment/cluster/ for how to install and configure it properly.

To view this discussion on the web visit https://groups.google.com/d/msg/snoozesoftware/-/g_REpr47kQ0J.
To post to this group, send email to snoozes...@googlegroups.com.
To unsubscribe from this group, send email to snoozesoftwar...@googlegroups.com.

ferdi s. a.

unread,
Jun 25, 2012, 3:54:08 AM6/25/12
to snoozes...@googlegroups.com
I have try configure it properly, but the result still same.
i configure :
  • libvirtd.conf (listen_tls = 0 listen_tcp = 1 auth_tcp = "none")
  • libvirt-bin, (libvirtd_opts="-d -l")
  • qemu.conf (user = "snoozeadmin" group = "snooze")
  • service libvirt-bin restart
is there something that i miss? i still got that message.

ferdi s. a.

unread,
Jun 26, 2012, 2:27:14 AM6/26/12
to snoozes...@googlegroups.com
Mr eugen, is it a problem if i didn't set Bridge networking?
Must i set it?
I'm still confused how to setting IP address for each node. Should i set it in one network or not.

Please help me.

ferdi s. a.

unread,
Jul 2, 2012, 6:55:16 AM7/2/12
to snoozes...@googlegroups.com
My connection to Libvirt are working now. The problem is my libvirt didn't listening on TCP.
I did this, and now connection to libvirt are working.

nano /etc/init/libvirt-bin
on last line change into like this
exec /usr/sbin/libvirtd -d -l

after that, restart your libvirt and snoozenode. Done.
hope this help the others.

Best regards
Ferdi S. A.

Eugen Feller

unread,
Jul 2, 2012, 4:23:35 PM7/2/12
to snoozes...@googlegroups.com
Hi Ferdi,

great. Thank you very much. Which Linux distribution did you use? The
Snooze cluster tutorial for Debian:
http://snooze.inria.fr/documentation/deployment/cluster/ mentions that
you need to do those modifications to the /etc/default/libvirt-bin file.

Best regards,
Eugen
> --
> You received this message because you are subscribed to the Google
> Groups "snoozesoftware" group.
> To view this discussion on the web visit
> https://groups.google.com/d/msg/snoozesoftware/-/a82jsfFSHPAJ.
> To post to this group, send email to snoozes...@googlegroups.com.
> To unsubscribe from this group, send email to
> snoozesoftwar...@googlegroups.com.

ferdi ariawan

unread,
Jul 3, 2012, 2:02:49 AM7/3/12
to snoozes...@googlegroups.com
I use Ubuntu 10.10.
When i try to configure /etc/default/libvirt-bin it doesn't work
In my Linux, file that must be edited is /etc/init/libvirt-bin
and edit this on the last line
exec /usr/sbin/libvirtd -d -l
Reply all
Reply to author
Forward
0 new messages