Whatever happened to the Windows Integration

18 views
Skip to first unread message

Gert

unread,
Sep 10, 2019, 4:10:58 AM9/10/19
to SmartSVN
Moving from V9 to V11, the Windows integration appears to be gone. I am unable to find the old context menu in Windows Explorer, I have no icon overlays, and SmartSVN does not minimize to the notification area. Am I loosing my marbles???

SmartSVN Support

unread,
Sep 10, 2019, 4:54:15 AM9/10/19
to smar...@googlegroups.com
Did you restart (or logged out and back in) and started SmartGit?

--
Best regards,
Thomas Singer
syntevo GmbH
http://www.syntevo.com
> --
> You received this message because you are subscribed to the Google Groups
> "SmartSVN" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to
> smartsvn+u...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/smartsvn/7d08d160-0827-4d39-a65f-8e5ece33c593%40googlegroups.com.
>
SmartSVN 11.png

Gert

unread,
Sep 10, 2019, 5:10:27 AM9/10/19
to SmartSVN
   Hi Thomas,
First of all, it is SmartSVN, not SmartGIT (which I however use as well) :-)….

I did indeed restart without any effect. Then I uninstalled SmartSVN, deleted the entire SmartSVN filer under programs, and installed it again.

Now I have shell integration working when SmartSVN is running. So far so good.

However, SmartSVN does not start up automatically when logging in. And I also really miss the SmartSVN icon in the Notification Tray, just hanging around in the background.

SmartSVN Support

unread,
Sep 10, 2019, 5:33:11 AM9/10/19
to smar...@googlegroups.com
Hi Gert,

> First of all, it is SmartSVN, not SmartGIT

Sorry for this typo.

> However, SmartSVN does not start up automatically when logging in. And I
> also really miss the SmartSVN icon in the Notification Tray, just hanging
> around in the background.

You can start SmartSVN in the background using

smartsvn.exe --server-mode

Then only the tray icon will occur. This is also the only way to get the tray icon. I have updated the documenation at:


<http://www.syntevo.com/doc/display/SU/Shell+Integration>

--
Best regards,
Thomas Singer
syntevo GmbH
http://www.syntevo.com


> --
> You received this message because you are subscribed to the Google Groups
> "SmartSVN" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to
> smartsvn+u...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/smartsvn/5881b0e8-6fec-4cea-83f7-7b8c614fd271%40googlegroups.com.
>

Gert

unread,
Sep 10, 2019, 7:11:38 AM9/10/19
to SmartSVN
Server-mode command line argument is indeed working. And a shortcut with this argument has been installed in the StartUp directory of the Start folder. It does however appear as if it is not executed upon start-up. I will try to understand why :-( ……..


tirsdag den 10. september 2019 kl. 10.10.58 UTC+2 skrev Gert:
Reply all
Reply to author
Forward
0 new messages