[SLUG] Installing Richcomm PowerManager on Ubuntu-type system

192 views
Skip to first unread message

Edwin Humphries

unread,
May 7, 2013, 8:30:03 PM5/7/13
to slug
G'day,

Has anyone had success installing Richcomm PowerManager USB UPS
monitoring software? (It's the software that came with my UPS).

The install script assumes a RedHat-type file structure and displays
errors on not finding /etc/rc.d/rc.local in my Linux-Mint system; after
exiting the subsequent configuration script, it then shows "Init Usb
Failed!". This despite the fact that lsusb shows the UPS up as "Bus 002
Device 004: ID 0925:1234 Lakeview Research", and
disconnecting/reconnecting the UPS USB cable shows up in dmesg as:
[ 7764.788092] usb 2-3: USB disconnect, device number 3
[ 7779.004071] usb 2-3: new low-speed USB device number 4 using ohci_hcd
[ 7779.233251] generic-usb 0003:0925:1234.0004: hiddev0,hidraw2: USB HID
v1.00 Device [\xffffffd0\xffffff89\xffffff89 UPS USB MON V1.4] on
usb-0000:00:02.0-3/input0
[ 7780.006016] usb 2-3: usbfs: interface 0 claimed by usbhid while
'richcomm_usb' sets config #1

which all looks OK to my (admittedly untrained) eye.

I'm running LMDE 13 x64 KDE.

I have tried installing NUT, but it's somewhat beyond me, I'm afraid.

Help would be appreciated.

Thanks,
Edwin Humphries

--
This email is intended for the named addressee/s only and may contain
confidential or privileged information. If you are not a named addressee
please delete it and notify the sender.
--

"/At every moment he beholdeth a wondrous world, a new creation, and
goeth from astonishment to astonishment, and is lost in awe at the works
of the Lord of Oneness./" Baha'u'llah, The Seven Valleys
"./.. humans are interesting. With all the wonders there are in the
Universe, they invented boredom./" Terry Pratchet, Hogfather
"/The most beautiful thing we can experience is the mysterious. It is
the source of all true art and all science. He to whom this emotion is a
stranger, who can no longer pause to wonder and stand rapt in awe, is as
good as dead: his eyes are closed./" Albert Einstein
/"Stuff your eyes with wonder ... live as if you'd drop dead in ten
seconds. See the world. It's more fantastic than any dream made or paid
for in factories./" Ray Bradbury

edwinh.vcf

David Lyon

unread,
May 7, 2013, 8:38:54 PM5/7/13
to SLUG
I've not tried with any modern devices but the older UPS's used to toggle
the CTS or DTR
data line on the serial-port to tell the PC that power was available.

The driver would simply watch the pin and when it toggled the software
would start taking
action.

These lines are still made available via the USB driver but it looks like
the issue is with
the installation section.
--
SLUG - Sydney Linux User's Group Mailing List - http://slug.org.au/
Subscription info and FAQs: http://slug.org.au/faq/mailinglists.html

E-Money 4All

unread,
Jan 7, 2022, 3:08:36 AMJan 7
to Sydney Linux Users' Group
Richcomm PowerManager - can you send me Serial number please
Reply all
Reply to author
Forward
0 new messages