Missing symbols

10 views
Skip to first unread message

Oliver Larkin

unread,
Oct 9, 2021, 6:51:15 AM (8 days ago) Oct 9
to skia-d...@googlegroups.com
Hello,

I am trying to upgrade to a recent tagged release and getting some missing symbol errors (tried macOS and iOS so far). I tried chrome/95, then chrome/94 and got these errors both times. I think chrome/93 is ok.

Undefined symbols for architecture x86_64:

  "SkBidiIterator::ReorderVisual(unsigned char const*, int, int*)", referenced from:

      (anonymous namespace)::emit((anonymous namespace)::ShapedLine const&, SkShaper::RunHandler*) in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)

      (anonymous namespace)::ShapeThenWrap::wrap(char const*, unsigned long, SkShaper::BiDiRunIterator const&, SkShaper::LanguageRunIterator const&, SkShaper::ScriptRunIterator const&, SkShaper::FontRunIterator const&, (anonymous namespace)::RunIteratorQueue&, SkShaper::Feature const*, unsigned long, float, SkShaper::RunHandler*) const in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)

  "SkUnicode::Make()", referenced from:

      SkShaper::MakeBiDiRunIterator(char const*, unsigned long, unsigned char) in libskshaper.a(libskshaper.SkShaper.o)

      SkShaper::MakeScriptRunIterator(char const*, unsigned long, unsigned int) in libskshaper.a(libskshaper.SkShaper.o)

      SkShaper::MakeIcuBiDiRunIterator(char const*, unsigned long, unsigned char) in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)

      SkShaper::MakeHbIcuScriptRunIterator(char const*, unsigned long) in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)

      (anonymous namespace)::MakeHarfBuzz(sk_sp<SkFontMgr>, bool) in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)

      SkShaper::MakeShapeDontWrapOrReorder(sk_sp<SkFontMgr>) in libskshaper.a(libskshaper.SkShaper_harfbuzz.o)



Here is my build script: https://github.com/iPlug2/iPlug2/blob/graphics/skia-m90/Dependencies/IGraphics/build-skia-mac.sh

Does anyone know what I might be missing?

Thanks

Oli

Ben Wagner

unread,
Oct 11, 2021, 10:23:31 AM (5 days ago) Oct 11
to skia-d...@googlegroups.com
libskparagraph.a and libskshaper.a no longer directly call ICU but
instead use an abstraction which should be found as libskunicode.a .
Adding this should resolve the issue.
> --
> You received this message because you are subscribed to the Google Groups "skia-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to skia-discuss...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/skia-discuss/CALB_B1Cs-aUL%2BCBXmS_q_r9L7KZbbxBU-reB4AP_GJUYFWHYaQ%40mail.gmail.com.

Oliver Larkin

unread,
Oct 11, 2021, 4:29:41 PM (5 days ago) Oct 11
to skia-d...@googlegroups.com
Reply all
Reply to author
Forward
0 new messages