Build error on Fedora Linux

16 views
Skip to first unread message

Daljit

unread,
Oct 8, 2021, 1:41:35 PM (8 days ago) Oct 8
to skia-discuss
Hi, I was trying to build Skia on Fedora but ran into this compile error when I run ninja -C
 out/Clang

../../src/ports/SkFontHost_FreeType_common.cpp:438:14: error: use of undeclared identifier 'FT_COLR_COMPOSITE_PLUS'
        case FT_COLR_COMPOSITE_PLUS:
             ^
../../src/ports/SkFontHost_FreeType_common.cpp:992:5: error: unknown type name 'FT_ClipBox'
    FT_ClipBox colrGlyphClipBox;
    ^

I tried to look up this online, but can't really figured what the problem is. Anyone have any idea?

John Stiles

unread,
Oct 11, 2021, 9:27:46 PM (5 days ago) Oct 11
to skia-discuss
It sounds like you need a newer version of FreeType.

Ben Wagner

unread,
Oct 12, 2021, 10:05:00 AM (4 days ago) Oct 12
to skia-d...@googlegroups.com
All the COLRv1 support should be behind the TT_SUPPORT_COLRV1 macro.
Unfortunately, it's possible that this was being set by default before
the API was actually pinned down. I would be interested to know the
version of the Fedora FreeType package. From the build side one way to
work around this is to ensure TT_SUPPORT_COLRV1 is unset, which may
just mean undefining it at the top of SkFontHost_FreeType_common.cpp
(or otherwise ensuring it is never defined).
> --
> You received this message because you are subscribed to the Google Groups "skia-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to skia-discuss...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/skia-discuss/2696c516-bd97-41d3-93ec-ada9ef690f7cn%40googlegroups.com.

Daljit

unread,
Oct 16, 2021, 4:03:33 PM (18 hours ago) Oct 16
to skia-discuss
Unfortunately I don't have access to the system I was executing the build on. However, I just tried again on a fresh install of Fedora 34 and I was able to successfully able to build Skia without errors.
Reply all
Reply to author
Forward
0 new messages