sipXproxy[11606]:Unable to bind on tcp port 5060 (ok=0)

19 views
Skip to first unread message

Todd Hodgen

unread,
Apr 21, 2022, 5:23:11 PMApr 21
to sipxcom-users

I have an issue I’m trying to work through with a customer.

 

Problem started that an employee that is no longer there changed the root password, and nobody had access to it.

Next, a UPS that the server was connected to failed, and the server shut off during a test of the emergency generator.

 

They system was restarted several times before a GUI login was made available to them.  Once that came up – there were no registrations.   I’ve seen this many times from a disorderly shutdown on this system – generally a restart from Command Line will restore things fine.   In this case – we could not get to the command line.     This site unfortunately is out of State – and a 3 hour drive.   I walked the customer through a password reset of CENTOS 7, and we were able to get into service.    I discovered the registration was not running, along with Proxy.   Further, I found that the domain name was no longer valid.   The name had changed to sipx.domain.name.

 

I tried using sipxecs-setup to fix the domain name, with no luck.   So I did a database restart on the system and restored the backups that I had.   Once done, profiles were sent to the server, to the phones, and once successful, the server was restarted with a shutdown command.

 

Now the uglier part – proxy and registrar are shutdown, along with RLS and some others.  I am seeing an error re-occur on the command line – sipXproxy: SipUserAgent reports a problem, setting shutdown flag.    Unable to bind on tcp port 5060 (ok=o)     This is one I have not seen before.  I did a search on the error and I’m not finding where anyone has had it before.

 

Hoping someone has some pointers on this.  Unfortunately, it’s a healthcare facility that is out of service – so hoping to restore as soon as possible.  

 

Thoughts anyone?

 

Todd R. Hodgen

Gerald Drouillard

unread,
Apr 21, 2022, 5:25:45 PMApr 21
to Todd Hodgen, sipxcom-users
Did you try disabling those services, push profile, then re-enable?

--
You received this message because you are subscribed to the Google Groups "sipxcom-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sipxcom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sipxcom-users/SJ0P222MB05048FAC6001952F045FA22AFDF49%40SJ0P222MB0504.NAMP222.PROD.OUTLOOK.COM.

Todd Hodgen

unread,
Apr 21, 2022, 5:27:24 PMApr 21
to Gerald Drouillard, sipxcom-users

No, but I will try that now Gerald.  Thanks for the tip!

Todd Hodgen

unread,
Apr 21, 2022, 9:07:49 PMApr 21
to Gerald Drouillard, sipxcom-users

Thanks Gerald.  Tried that, nothing.   I ended up disabling all telecom tab items, sending profiles, then re-enabling a few at a time, but no resolution.    Might have to do a reload on the server.    Hoping some other sage advice finds its way!

 

From: Gerald Drouillard <ger...@drouillard.ca>
Sent: Thursday, April 21, 2022 2:26 PM
To: Todd Hodgen <t.ho...@misiusystems.com>
Cc: sipxcom-users <sipxco...@googlegroups.com>

Reply all
Reply to author
Forward
0 new messages