Fwd: Need help on installing qt5

49 views
Skip to first unread message

Loganathan Sellappa

unread,
Jan 4, 2017, 5:28:30 AM1/4/17
to singap...@googlegroups.com
Hello,

I'm trying to install capybara-webkit on rhel 6.8 as per the instructions at https://github.com/thoughtbot/capybara-webkit/wiki/Installing-Qt-and-compiling-capybara-webkit but I'm getting an error, can anyone let me know the alternative way to install qt5 ?

sudo yum install epel-release
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                | 2.1 kB     00:00     
amzn-updates/latest             | 2.3 kB     00:00     
3729 packages excluded due to repository priority protections
Package epel-release-6-8.9.amzn1.noarch already installed and latest version
Nothing to do
sudo yum install qt5-qtwebkit-devel
Loaded plugins: priorities, update-motd, upgrade-helper
3729 packages excluded due to repository priority protections
No package qt5-qtwebkit-devel available.


regards,
Loganathan


Ganesh Kaliannan

unread,
Jan 4, 2017, 6:28:18 AM1/4/17
to singap...@googlegroups.com

--
You received this message because you are subscribed to the Google Groups "Singapore Ruby Brigade" group.
To unsubscribe from this group and stop receiving emails from it, send an email to singapore-rb+unsubscribe@googlegroups.com.
To post to this group, send email to singap...@googlegroups.com.
Visit this group at https://groups.google.com/group/singapore-rb.
For more options, visit https://groups.google.com/d/optout.



--
Thanks & Regards,
Ganesh Kaliannan

Loganathan Sellappa

unread,
Jan 6, 2017, 5:06:45 AM1/6/17
to singap...@googlegroups.com
I've tried it already, but it failed due to dependency issues. 

or: Package: qt5-qtbase-gui-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libpng15.so.15()(64bit)

Error: Package: qt5-qtbase-gui-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libudev.so.1(LIBUDEV_183)(64bit)

Error: Package: qt5-qtbase-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libsystemd.so.0()(64bit)

Error: Package: qt5-qtbase-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libpcre16.so.0()(64bit)

Error: Package: qt5-qtbase-gui-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libpng15.so.15(PNG15_0)(64bit)

Error: Package: qt5-qtbase-gui-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libxcb-xkb.so.1()(64bit)

Error: Package: qt5-qtbase-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libsystemd.so.0(LIBSYSTEMD_209)(64bit)

Error: Package: qt5-qtbase-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libproxy.so.1()(64bit)

Error: Package: qt5-qtbase-gui-5.6.1-3.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libxcb-sync.so.1()(64bit)

Error: Package: qt5-qtwebkit-5.6.1-3.b889f46git.el7.x86_64 (dl.fedoraproject.org_pub_epel_7_x86_64_)

           Requires: libpng15.so.15()(64bit)


regards,
Loganathan

Ganesh Kaliannan

unread,
Jan 6, 2017, 6:24:54 AM1/6/17
to singap...@googlegroups.com
Then try install the dependencies and check again.

https://rpmfind.net/linux/rpm2html/search.php?query=libpng15.so.15()(64bit)

Thanks,
Ganesh Kaliannan

Loganathan Sellappa

unread,
Jan 6, 2017, 6:30:45 AM1/6/17
to singap...@googlegroups.com
I've tried like this but with every installation, I'm getting dependency issues for different packages. I'm looking for the repo with all the packages.

regards,
Loganathan

Reply all
Reply to author
Forward
0 new messages