$('div').concrete({
highlight: function(){
this.effect('bounce');
}
});
$('div.important').concrete({
highlight: function(){
this._super();
this.animate({background: 'white'});
}
});
$('#namediv').highlight();
---
Simon Welsh
Admin of http://simon.geek.nz/
Who said Microsoft never created a bug-free program? The blue screen
never, ever crashes!
> --~--~---------~--~----~------------~-------~--~----~
> You received this message because you are subscribed to the Google
> Groups "SilverStripe Development" group.
> To post to this group, send email to silverst...@googlegroups.com
> To unsubscribe from this group, send email to silverstripe-d...@googlegroups.com
> For more options, visit this group at http://groups.google.com/group/silverstripe-dev?hl=en
Is it just me, or is this missing links?
$('div').concrete({
highlight: function(){
this.effect('bounce');
}
});
$('div.important').concrete({
highlight: function(){
this._super();
this.animate({background: 'white'});
}
});
$('#namediv').highlight();
> Looks fun, I'm going to start using it in an app next week.
>
> Before I dive into it, does it behave the same as jQuery live? Or
> can it play nicely with live?
>
It should play nicely with live (and even livequery, although I don't
recommend it). The event handling is similar to live + the live-
extensions plugin (so you can use onchange, onsubmit, etc).
Steps 2, 3 and 4 of the tutorial cover the subtleties
http://hafriedlander.github.com/jquery.concrete/tutorial/step_02.html
http://hafriedlander.github.com/jquery.concrete/tutorial/step_03.html
http://hafriedlander.github.com/jquery.concrete/tutorial/step_04.html
Hamish Friedlander
SilverStripe
This looks very powerful. Two questions:
· Why is it called concrete? I am probably missing something obvious but a more descriptive name especially for the method call “concrete(...)” would seem to be more helpful.
· I would have thought that this sort of ability should be built into jquery core. Have you collaborated with the jquery team when developing this?
Pete
No virus
found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.421 / Virus Database: 270.14.14/2433 - Release Date: 10/15/09
12:02:00
> This looks very powerful. Two questions:
> · Why is it called concrete? I am probably missing
> something obvious but a more descriptive name especially for the
> method call “concrete(...)” would seem to be more helpful.
The technique the library is based around is called 'Concrete UI'. I
wanted a name that was short(ish), unlikely to clash with any other
library (which ruled out bind, attach, methods, etc), or suggest
metaphors that are either inaccurate or confusing (i.e. klass)
Feel free to suggest a better method name if you like. If there's a
community consensus on a better name (and I like it :), I'll alias
them for 1.0, and deprecate the original concrete method call for
whatever version comes after.
> · I would have thought that this sort of ability should be
> built into jquery core. Have you collaborated with the jquery team
> when developing this?
No. I'd be happy if they included it, but I doubt it's going to
happen. They're understandably wary of putting anything in regular
jQuery unless it's both small, universally useful, and focused on
making DOM manipulation easy. Hence why jQuery UI is a separate
library, and even things like color animation, json, class
construction and other things are plugins.
Having said that, once I've gotten this to 1.0, I'll be looking at
reducing the footprint of the selector code and seeing whether it's a
good candidate for integration. I'm also hoping to get this seen as
the de facto third part in the jQuery chain - jQuery for all sites,
jQuery.UI for complex sites, jQuery.Concrete for web applications -
but that'll depend a lot on community acceptance.
Hamish Friedlander
SilverStripe