Silk cannot be compiled

21 views
Skip to first unread message

Jindřich Mynarz

unread,
Dec 13, 2016, 2:40:02 PM12/13/16
to silk-di...@googlegroups.com
Hi,

I found that the current version of Silk from its GitHub repository (https://github.com/silk-framework/silk) cannot be compiled. I tried both the master branch and the develop branch. In both cases, running `sbt "project singlemachine" assembly` throws this exception:

[warn] /Users/mynarzjindrich/Dev/silk/silk-core/src/main/scala/org/silkframework/runtime/serialization/ValidatingXMLReader.scala:23: imported `ValidationException' is permanently hidden by definition of class ValidationException in package serialization
[warn] import org.silkframework.runtime.validation.{ValidationError, ValidationException}
[warn]                                                               ^
[error] /Users/mynarzjindrich/Dev/silk/silk-core/src/main/scala/org/silkframework/runtime/serialization/ValidatingXMLReader.scala:111: overloaded method constructor ValidationException with alternatives:
[error]   (error: String)org.silkframework.runtime.serialization.ValidationException <and>
[error]   (errors: Seq[org.silkframework.runtime.serialization.ValidationException.ValidationError])org.silkframework.runtime.serialization.ValidationException
[error]  cannot be applied to (List[org.silkframework.runtime.validation.ValidationError])
[error]         throw new ValidationException(validationErrors.reverse)
[error]               ^
[error] /Users/mynarzjindrich/Dev/silk/silk-core/src/main/scala/org/silkframework/runtime/serialization/ValidatingXMLReader.scala:148: overloaded method constructor ValidationException with alternatives:
[error]   (error: String)org.silkframework.runtime.serialization.ValidationException <and>
[error]   (errors: scala.collection.Seq[org.silkframework.runtime.serialization.ValidationException.ValidationError])org.silkframework.runtime.serialization.ValidationException
[error]  cannot be applied to (scala.collection.immutable.Seq[org.silkframework.runtime.validation.ValidationError])
[error]         throw new ValidationException(errors)
[error]               ^
[warn] one warning found
[error] two errors found
[error] (core/compile:compileIncremental) Compilation failed

My context:

$ sbt --version
sbt launcher version 0.13.8
$ javac -version
javac 1.8.0_74

Should I use a different branch?

- Jindřich

-- 
Jindřich Mynarz

Robert Isele

unread,
Dec 13, 2016, 5:41:00 PM12/13/16
to silk-discussion
Hi Jindřich,

I just executed './sbt "project singlemachine" assembly' on develop, which worked for me.

It seems that your version of sbt is older than the one configured in silk/project/build.properties.

Could you please retry using ./sbt instead of sbt so that the local copy of sbt as committed in the root of the repository is used?

You can also try to excute ./sbt clean before, to make sure that the build is clean.

Kind regards,
Robert



--
You received this message because you are subscribed to the Google Groups "Silk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to silk-discussion+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Jindřich Mynarz

unread,
Dec 14, 2016, 5:11:15 AM12/14/16
to silk-di...@googlegroups.com
Hi Robert,

indeed, cleaning the build with `./sbt clean` and using the provided version of SBT makes `./sbt "project singlemachine" assembly` work. It probably was caused on my side by some failed previous builds.

Thanks,

Jindřich

-- 
Jindřich Mynarz
Reply all
Reply to author
Forward
0 new messages