Docker - App installation error: LICENSE

49 views
Skip to first unread message

Giovanni Pipitò

unread,
Jan 28, 2022, 10:00:01 AMJan 28
to sFlow-RT
Hi,

I'm trying to install apps to my sflow-rt container but it replies with the following error:

Example:

sudo docker run -v /dockerdata/sflow-rt/app:/sflow-rt/app --entrypoint /sflow-rt/get-app.sh sflow/sflow-rt sflow-rt active-routes

error: app/active-routes-master/LICENSE (No such file or directory)

This is how I run my container:

sudo docker run -v /dockerdata/sflow-rt/local.conf:/sflow-rt/local.conf -v /dockerdata/sflow-rt/app:/sflow-rt/app -p 6345:6343/udp -p 8008:8008 -d --name sflow-rt-edge sflow/sflow-rt -Dsystem.propertyFiles=local.conf

Peter Phaal

unread,
Jan 28, 2022, 10:20:33 AMJan 28
to sFlow-RT
Does the directory /dockerdata/sflow-rt/app exist? What are the file permissions on the directory?

By defualt sFlow-RT runs as a non-privileged user. Depending on the file permissions you may need to set the -u flag to match ownership of the directory you want to write into.

Giovanni Pipitò

unread,
Jan 31, 2022, 7:06:11 AMJan 31
to sFlow-RT
Hi Peter,

I solved using -u root as you suggested:

sudo docker run -v /dockerdata/sflow-rt/local.conf:/sflow-rt/local.conf -v /dockerdata/sflow-rt/app:/sflow-rt/app -p 6345:6343/udp -p 8008:8008 -u root --name sflow-rt-edge sflow/sflow-rt -Dsystem.propertyFiles=local.conf

Thanks for your help.

Kind Regards
Reply all
Reply to author
Forward
0 new messages