'ImportError: No module named requests' error while creating Mininet topology

281 views
Skip to first unread message

Yubaraj Gautam

unread,
Aug 5, 2021, 10:11:59 AM8/5/21
to sFlow-RT

Hello sir,

I started the sflow-rt on one tab and on another tab, i tried to create the mininet topology by using "sudo mn --custom sflow-rt/extras/sflow.py --link tc,bw=10 --topo tree,depth=2,fanout=2 --controller remote" command. While doing this, i faced "ImportError: No module named requests" error. I installed requests module but i am facing the same error constantly. Currently, i am using  Ubuntu 18.04 and python 3.8.10.
Can you please help?

Best Regards,

Peter Phaal

unread,
Aug 5, 2021, 1:44:10 PM8/5/21
to sFlow-RT
Did you install the Python3 version of requests, e.g.

sudo apt-get install python3-pip
pip3 install requests

Peter Phaal

unread,
Sep 2, 2021, 2:07:37 PM9/2/21
to sFlow-RT
Try the latest version of sFlow-RT. The sflow.py script removes the dependency on the requests module.
Reply all
Reply to author
Forward
0 new messages