Export problem: File to import not found or unreadable

99 views
Skip to first unread message

Stef

unread,
Jun 20, 2013, 7:03:26 AM6/20/13
to serve...@googlegroups.com
Hello,

I've got a problem when exporting my project. I'm afraid I'm totally new to using serve and ruby as well as sass/compass, so please bear with me, I'm trying to learn as much as I can as I go along...

All works fine in development, but when I export the project, there seems to be a problem with compiling the css because I'm using zen-grids. 
This is the error message I get: 

Syntax error: File to import not found or unreadable: zen.


I have no idea how to find out more as I don't quite understand what happens in the background on export...

Any help would be much appreciated!

Thanks
Stef

John W. Long

unread,
Jun 20, 2013, 10:12:29 AM6/20/13
to serve...@googlegroups.com
I'm sorry about this Stef. Serve's export feature is really kind of rough in places. You may want to compile the CSS separately from the export step and use Serve just for the HTML for now.

--John

--
--
Serve Users Group
Mailing List: http://groups.google.com/group/serve-users/
Project: http://github.com/jlong/serve/
 
---
You received this message because you are subscribed to the Google Groups "Serve Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to serve-users...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Stef

unread,
Jun 24, 2013, 6:52:44 AM6/24/13
to serve...@googlegroups.com
Fair enough, thanks fo replying anyway, John!

Interestingly enough, I tried to compile the CSS from Terminal directly with 'compass compile' and got the same error message. Using the Scout GUI it's works fine...I'll try to investigate further once I have time. For now this is a workaround I can live with.

Stef
Reply all
Reply to author
Forward
0 new messages