"Bundle install" Error

12 views
Skip to first unread message

Cornelius Knopp

unread,
Jul 22, 2019, 8:11:52 AM7/22/19
to SEEK Developers
Hi,
i ran into the following problem when trying to install SEEK from GitHub.
Everything works fine until i execute the command
bundle install
When installing the dependencies,
can't be reached. Neither by server nor by client itself.


Fetching source index from https://rails-assets.org/
Retrying fetcher due to error (2/4): Bundler::HTTPError Could not fetch specs from https://rails-assets.org/
Retrying fetcher due to error (3/4): Bundler::HTTPError Could not fetch specs from https://rails-assets.org/
Retrying fetcher due to error (4/4): Bundler::HTTPError Could not fetch specs from https://rails-assets.org/
Could not fetch specs from https://rails-assets.org/



Is this problem already known? And is there any workaround?

Best regards
Cornelius

----
Specs:
Linux Ubuntu 18.4.2
SEEK v. 1.9.0

Stuart Owen

unread,
Jul 22, 2019, 11:45:50 AM7/22/19
to seek-de...@googlegroups.com

It sounds like a problem with https://rails-assets.org . We sometimes come across this, but its OK if we try again after a short while. Is it working for you now?

regards,

Stuart

--
You received this message because you are subscribed to the Google Groups "SEEK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to seek-develope...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/seek-developers/f1bb8cd7-9022-407d-a052-29b3dea9f44c%40googlegroups.com.

Cornelius Knopp

unread,
Jul 23, 2019, 7:39:32 AM7/23/19
to SEEK Developers
Hi,
Rails-Assets.org wasn't up % running yesterday. Today the platform is running, the `bundle install`still doesn't runs.
It seems, the rails-assets.org is still not working completely.

I manually downloaded, renamed and installed all gems (mainly from other github repos).
But this way doesn't work, as the individual gems have other versions.

Therefore i will wait until Rails-Assets.org is completely up again.

regards,
Cornelius

Stuart Owen

unread,
Jul 23, 2019, 8:36:47 AM7/23/19
to seek-de...@googlegroups.com

If this is a clean install, have you thought about using Docker, and our Docker compose setup: https://docs.seek4science.org/tech/docker/docker-compose.html

This already has all the gems installed, and is a quick way of getting up and running, and doing upgrades.

regards,

Stuart

--
You received this message because you are subscribed to the Google Groups "SEEK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to seek-develope...@googlegroups.com.

Cornelius Knopp

unread,
Jul 23, 2019, 3:16:34 PM7/23/19
to SEEK Developers
It's supposed to be a development instance to configure the OmniAuth-LDAP integration.
The productive instance runs perfect with docker, but the possibilities of configuring the OmniAuth are limited, as the docker-container is removed for every restart.

I might have to wait until Rails-Assets.org is again fully online.

Regards
Cornelius

Reply all
Reply to author
Forward
0 new messages