H19 went bad!

32 views
Skip to first unread message

norberto.collado koyado.com

unread,
Nov 27, 2022, 4:23:12 AM11/27/22
to se...@googlegroups.com

See attached picture! Any ideas on what I need to check to get it back working again?

 

Thanks,

Norberto

IMG_2591.jpg

glenn.f...@gmail.com

unread,
Nov 27, 2022, 6:36:18 AM11/27/22
to se...@googlegroups.com

David Troendle, Joe Travis and I have put together a collection of scans of many of the Heath service manuals. I have the action to host these on our site and put out an announcement but I’m woefully behind on that.  For now you could consult the version of the H19 manual in my Google Drive

 

https://drive.google.com/file/d/17oohogZtzRe473dtUdI5WA3dFJXqi71r/view?usp=sharing

 

there’s plenty of information there.  Here’s the quick “troubleshooting” suggestion on vertical deflection issues:

 

 

There’s a whole section on the vertical deflection circuit, and of course checking the power supply first is always a good idea…

 

Good luck!

 

  • Glenn
  •  

--
You received this message because you are subscribed to the Google Groups "SEBHC" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sebhc+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sebhc/SN6PR01MB3855B83990E044E6BA4A7187F7109%40SN6PR01MB3855.prod.exchangelabs.com.

image001.png

Joseph Travis

unread,
Nov 27, 2022, 10:07:48 AM11/27/22
to se...@googlegroups.com
A common cause of failures (not mentioned in the service manuals) on the video and power supply boards is poor / pitted solder joints.

Steven Feinsmith

unread,
Nov 27, 2022, 3:30:33 PM11/27/22
to se...@googlegroups.com
I have Heathkit H19 here, completed the overhaul with deep cleaning, and checked solder joints and components. The H19 was working flawlessly before the overhaul. I discovered and decided to replace all carbon resistors because they were out of tolerance and also replaced all electrolytic capacitors. Good thing that I still have an excellent condition on the picture tube, yoke assembly, and transformer, plus several obsoleted parts were in good condition too. Now, it is cleaned and works perfectly.

Your problem was evident with a vertical circuit. I read other people already answered with solutions and provided you with manuals. You may already solve the problem.

Steven

--

norberto.collado koyado.com

unread,
Nov 27, 2022, 6:06:43 PM11/27/22
to se...@googlegroups.com

norberto.collado koyado.com

unread,
Nov 27, 2022, 6:27:38 PM11/27/22
to se...@googlegroups.com

It is an H19-A version with all the shielding, so I need to find the correct schematics.

 

Reply all
Reply to author
Forward
0 new messages