test_resolve_tcp fail in Jenkins docker container

32 views
Skip to first unread message

Vanegicloh J

<vanegicloh@gmail.com>
unread,
Sep 22, 2022, 7:10:50 AMSep 22
to seastar-dev
Dear all,
Could you please help me with docker and Seastar tests?
I tried to build and run Seastar tests in docker container on remote server with Jenkins. While it executed test_resolve_tcp unit test from dns_test.cc it got this error:
"unknown location(0): fatal error: in "test_resolve_tcp": std::system_error: 185.199.108.153: Not found"
I found that it happened in ares_gethostbyaddr function in seastar/src/net/dns.cc.

Furthermore, I get this error only in docker container in Jenkins. When I build and run tests on my local PC (with and without docker) it works perfectly fine.
I guess it's the wrong Jenkins docker container or environment. I run docker in Jenkins script like this:
docker {
    image 'docker.io/scylladb/seastar-toolchain'
    args '--pids-limit -1 --security-opt seccomp=unconfined --network host -v /etc/passwd:/etc/passwd:ro -v /etc/group:/etc/group:ro --rm'
    reuseNode true
}

Do you have any ideas what could be wrong with this?
Thanks!
Reply all
Reply to author
Forward
0 new messages