Unable to import scoobi project into eclipse scala IDE

213 views
Skip to first unread message

Deepak Jain

unread,
Nov 22, 2014, 12:57:20 AM11/22/14
to scoob...@googlegroups.com

Mac OSX

Scala IDE build of Eclipse SDK

Build id: 3.0.3-20140327-1716-Typesafe

git clone g...@github.com:deepujain/scoobi.git  

sbt clean compile  package

....

....

[success] Total time: 2 s, completed Nov 22, 2014 11:23:45 AM

LM-BLR-00668331:scoobi dvasthimal$ 

File -> Import -> General -> Existing Projects into Workspace

Select Root directory = scoobi folder from finder

Error:  No projects are found to import

Attempted same thing with "Option:  Search for nested projects" and i see same error.

1) How do i use SCALA IDE for Scoobi project ? 

2) Are there any additional plugins that needs to be installed ?

Regards,

Deepak

Deepak Jain

unread,
Nov 22, 2014, 1:40:35 AM11/22/14
to scoob...@googlegroups.com
Included

addSbtPlugin("com.typesafe.sbteclipse" % "sbteclipse-plugin" % "2.5.0")

to project/plugins.sbt

And i was able to import scoobi project using below steps.

I see there are 27 errors (problems) all of similar type with different libs

Description Resource Path Location Type

dsinfo_2.11-0.4.0.jar is cross-compiled with an incompatible version of Scala (2.11). In case of errorneous report, this check can be disabled in the compiler preference page. scoobi Unknown Scala Classpath Problem


I have For Scala 2.11.2 version of SCALA IDE from http://scala-ide.org/download/sdk.html#

Any suggestions ?
Regards,
Deepak

Deepak Jain

unread,
Nov 23, 2014, 11:10:00 PM11/23/14
to scoob...@googlegroups.com
I downloaded both version of scala-ide for 2.11.2 and 2.10.4 and imported the project into it and i still see the same error.
Hence i disabled scala the check. Preferences => Scala -> Compiler -> BuildManager and unchecked withVersionClassPathValidator.

I then saw a different error 
IO error while decoding  scoobi/src/main/scala/com/nicta/scoobi/core/Reduction.scala with US-ASCII Please try specifying another one using the -encoding option scoobi Unknown Scala Problem

This was fixed by setting the encoding to UTF-8. Preferences->General->Workspace->TextFileEncoding -> From drop down select UTF-8.

Now i see compiler errors against the code itself and there 56 of them. Screenshot attached. These errors are with both versions of scala editor.

1. What scala editor needs to be used for development ? http://scala-ide.org/download/sdk.html  "For 2.11.2 or For 2.10.4" ?
2. How to fix the " is cross-compiled with an incompatible version" by not disabling the option. Or is it an incorrect error ?
3. Can anyone share what kind of dev environment is being used for scoobi dev?

Regards,
Deepak
Screen Shot 2014-11-24 at 9.37.48 AM.png

Alex Cozzi

unread,
Nov 24, 2014, 10:18:11 PM11/24/14
to scoob...@googlegroups.com
As far as I know the scoobi developers do not use an IDE. 
Nevertheless I successufully imported scoobi into eclipse IDE. I used the IDE for scala 2.10.4 and the sbt eclipse plugin. Pay attention to compile for 2.10 and not cross-compile. 

In general you do not need to have scoobi itself in your eclipse to develop scoobi programs.

Alex

Joseph Beynon

unread,
Nov 25, 2014, 3:44:32 PM11/25/14
to scoob...@googlegroups.com
By default, Scoobi's SBT config is building for 2.11 I believe, so if you just run "sbt eclipse" you'll have a project configured for scala 2.11. If you want to use 2.10, then after launching sbt you can run the command "++ 2.10.4" to change the scala version it uses and then use the "eclipse" command in the same SBT session.
Reply all
Reply to author
Forward
0 new messages