Problems with IDM_TOGGLE_FOLDALL

31 views
Skip to first unread message

holt...@gmail.com

unread,
Jun 13, 2021, 2:27:26 PMJun 13
to scite-interest

Hi,

I have upgraded by copy of SciTE:
  • OS:Windows
  • Version:5.0.3  
  • Scintilla:5.0.3  
  • Lexilla:5.0.3
Using a clean installation: when trying to toggle all folds I run into problems.

The effect of the menu command, a shortcut or a lua command is the same - the fold indicators change but the text is still displayed until something else trigger a redraw (e.g. looking at another tab).

Once something triggers a redraw the text folds and the next call to toggle all folds successfully unfolds.

After the unfolding another call to toggle all folds exhibits the same behavior.

I tested against .lua and .vbs files. This does not happen with Version 4.4.5.

Kind Regards Gavin Holt

Neil Hodgson

unread,
Jun 13, 2021, 6:40:25 PMJun 13
to scite-interest
Gavin Holt:

The effect of the menu command, a shortcut or a lua command is the same - the fold indicators change but the text is still displayed until something else trigger a redraw (e.g. looking at another tab). 

   That is most likely this bug:

   You could use the current code from the repository or download SciTE 5.0.2.

   Neil

holt...@gmail.com

unread,
Jun 15, 2021, 5:44:43 PMJun 15
to scite-interest
Hi

Many thanks, I stepped back to version 5.0.2 as you suggested and everything works beautifully.
 
It is a great testament to your team that my single Lua customization script continues to work without me having to make any alterations - since version 3.7.5.

Kind Regards Gavin Holt
Reply all
Reply to author
Forward
0 new messages