Scalismo Minimal Seed Warnings

80 views
Skip to first unread message

Luke

unread,
Apr 1, 2020, 4:27:26 AM4/1/20
to scalismo

 

 

Hi

I’m trying to start a new scalismo project in IntelliJ from the minimal scalismo seed, I have previously set this up on my mac without issue but now trying on a new computer windows 10.

 

On running the ExampleApp, I get:

 

"C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.3.4\jbr\bin\java.exe" "-…

WARNING: An illegal reflective access operation has occurred

WARNING: Illegal reflective access by com.jogamp.common.os.NativeLibrary$3 (file:/C:/Users/lukev/AppData/Local/Coursier/cache/v1/https/dl.bintray.com/unibas-gravis/maven/ch/unibas/cs/gravis/scalismo-native-stub/4.0.0/scalismo-native-stub-4.0.0.jar) to method java.lang.ClassLoader.findLibrary(java.lang.String)

WARNING: Please consider reporting this to the maintainers of com.jogamp.common.os.NativeLibrary$3

WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations

WARNING: All illegal access operations will be denied in a future release

 

The viewing window still opens with the face, its just a bit disconcerting that I am getting this error message every time I run the app and would like to clarify what this means before I move on with my project in detail. It seems to come up on  scalismo.initialize()

 

I installed per the specifications:

Git

git version 2.26.0.windows.1

sbt

sbt.version 1.3.4

java

openjdk version "1.8.0_242"

 

This is the build.sbt (I tried updating the scalismo version, had the same issue with the original minimalseed library dependencies):

 

import sbt.Resolver

organization  := "ch.unibas.cs.gravis"

name := "Humerus Virtual Reduction"

version       := "0.1"

scalaVersion  := "2.12.8"

scalacOptions := Seq("-unchecked", "-deprecation", "-encoding", "utf8")

resolvers ++= Seq(
 
Resolver.bintrayRepo("unibas-gravis", "maven"),
 
Resolver.bintrayRepo("cibotech", "public"),
 
Opts.resolver.sonatypeSnapshots
)


libraryDependencies  += "ch.unibas.cs.gravis" %% "scalismo-ui" % "0.14.0"


assemblyJarName in assembly := "Humerus Virtual Reduction.jar"

mainClass in assembly := Some("example.ExampleApp")

assemblyMergeStrategy in assembly :=  {
   
case PathList("META-INF", "MANIFEST.MF") => MergeStrategy.discard
   
case PathList("META-INF", s) if s.endsWith(".SF") || s.endsWith(".DSA") || s.endsWith(".RSA") => MergeStrategy.discard
   
case "reference.conf" => MergeStrategy.concat
   
case _ => MergeStrategy.first
}

 

I have tried a few versions of java with the same issue.

 

On running sbt new unibas-gravis/scalismo-seed.g8, I get the following response, though it still created a project folder that I can open up in IntelliJ.

 

[info] Set current project to lukev (in build file:/C:/Users/lukev/)

[info] Set current project to lukev (in build file:/C:/Users/lukev/)

 

A minimal Scalismo project

 

name [ScalismoSeed]: [error] java.io.IOException: Unable to delete file: C:\Users\lukev\AppData\Local\Temp\giter8-1649307584000\src\main\g8\.gitignore

[error] Use 'last' for the full log..

 

Any idea the cause and or solution for this?

 

Cheers

 

Luke

 

 

Marcel Luethi

unread,
Apr 2, 2020, 5:12:27 AM4/2/20
to Luke, scalismo
Dear Luke,

Thank you for reporting this.
We are aware of this issue. It is caused by the JOGL library, which provides OpenGL Access for java. There is a fix for it in later versions. Unfortunately,  as we are not using JOGL directly, but as part of the VTK package, we will not be able to upgrade at the moment.

To complicate matters even more, Apple has decided to deprecate OpenGL. We are currently observing the situation and see what strategies the project we depend on adopt before investing more time on it.

Best regards

Marcel



--
You received this message because you are subscribed to the Google Groups "scalismo" group.
To unsubscribe from this group and stop receiving emails from it, send an email to scalismo+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/scalismo/c462393a-9617-4c1d-90a5-f0794e1cc8fd%40googlegroups.com.

Fabio Fehr

unread,
May 18, 2020, 8:53:03 AM5/18/20
to scalismo
Dear Marcel and Luke

I am having the same problem without the UI even opening.

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.jogamp.common.os.NativeLibrary$3 (file:/tmp/sbt_94af9c8e/target/85c8645f/513389d3/scalismo-native-stub-4.0.0.jar) to method java.lang.ClassLoader.findLibrary(java.lang.String)
WARNING: Please consider reporting this to the maintainers of com.jogamp.common.os.NativeLibrary$3
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

I am using an Ubuntu 18.04.4 bionic system

Best regards
Fabio

Java version
openjdk version "11.0.7" 2020-04-14
OpenJDK Runtime Environment (build 11.0.7+10-post-Ubuntu-2ubuntu218.04)
OpenJDK 64-Bit Server VM (build 11.0.7+10-post-Ubuntu-2ubuntu218.04, mixed mode, sharing)

git version 
2.17.1

sbt version
 1.3.8

Patrick Kahr

unread,
May 18, 2020, 10:13:20 AM5/18/20
to scal...@googlegroups.com
Hi Fabio

I can confirm that the application will crash when using a recent
version of openjdk under Ubuntu. It seems that this is related to a
glibc bug in openjdk builds used by many distributions
(https://github.com/eclipse/openj9/issues/3607).

Currently I know of two ways to avoid this issue:

1. Downgrade your openjdk version: opendjk-8 builds from the Ubuntu
repositories are not affected by this bug.

2. Use an alternative build of a recent openjdk version that is not
affected. I tested this one:
https://adoptopenjdk.net/?variant=openjdk11&jvmVariant=hotspot


Let me know if this solved the problem for you.


Best,
Patrick


--
Patrick Kahr, M.Sc.
Graphics and Vision Research Group

Department of Mathematics and Computer Science
University of Basel
Spiegelgasse 1
CH-4051 Basel
Switzerland

tel.: +41-(0)61-207 0552
email: patric...@unibas.ch
web: https://gravis.cs.unibas.ch/

Fabio Fehr

unread,
May 18, 2020, 11:20:21 AM5/18/20
to scalismo
I followed your second option and managed to get it to work!

I cant tell you the smile this brought me, I tackled this all day. Thank you Patrick! 
scalismoWorking.png

Marcel Luethi

unread,
May 18, 2020, 11:48:55 AM5/18/20
to Fabio Fehr, scalismo
Thanks, Patrick. I did not know that there are problems with some java versions.

I will add a note to the instructions that Scalismo should only be used with LTS versions of Java (i.e. java 8 and java 11). Java is now evolving so rapidly, that not all the tools manage to catch up and also we have not done a good job of always updating to the latest scala version.

Best regards,

Marcel



On Mon, May 18, 2020 at 5:20 PM Fabio Fehr <fabio...@gmail.com> wrote:
I followed your second option and managed to get it to work!

I cant tell you the smile this brought me, I tackled this all day. Thank you Patrick! 

--
You received this message because you are subscribed to the Google Groups "scalismo" group.
To unsubscribe from this group and stop receiving emails from it, send an email to scalismo+u...@googlegroups.com.

Patrick Kahr

unread,
May 18, 2020, 11:58:22 AM5/18/20
to Marcel Luethi, Fabio Fehr, scalismo
Hi Marcel

To clarify: it is not enough to choose an LTS version of java. The official openjdk-11 build from the package repositories used by ubuntu (and other distributions) is affected by this issue.

Best,
Patrick
><https://groups.google.com/d/msgid/scalismo/b19306ab-ea7d-44f8-b386-be5dc47b9a7c%40googlegroups.com?utm_medium=email&utm_source=footer>
>> .

Patrick Kahr

unread,
May 18, 2020, 11:58:22 AM5/18/20
to Marcel Luethi, Fabio Fehr, scalismo
Hi Marcel

To clarify: it is not enough to choose an LTS version of java. The official openjdk-11 build from the package repositories used by ubuntu (and other distributions) is affected by this issue.

Best,
Patrick

On May 18, 2020 5:48:41 PM GMT+02:00, Marcel Luethi <marcel...@gmail.com> wrote:
><https://groups.google.com/d/msgid/scalismo/b19306ab-ea7d-44f8-b386-be5dc47b9a7c%40googlegroups.com?utm_medium=email&utm_source=footer>
>> .

Wenxuan Guo

unread,
Sep 7, 2020, 6:27:50 PM9/7/20
to scalismo
Hi Patrick! Thank you for the suggestions. Do you happen to know about macOS? I tried both of your solutions and the UI still crashed. I am still getting errors.

For JDK 8, I got this:
(I cannot screenshot the whole thing,  but the second line is saying:
2020-09-07 18:13:36.938 java[6357:324877] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'NSWindow drag regions should only be invalidated on the Main Thread!')
Screen Shot 2020-09-07 at 5.58.20 PM.png

For both the alternative build of JDK 11 and JDK 14, I got this error:
Screen Shot 2020-09-07 at 5.50.38 PM.png

I'd really, really appreciate your input and help! I cannot wait to explore scalismo, but the errors are bugging me from yesterday.

Best wishes,
Wen

Marcel Luethi

unread,
Sep 8, 2020, 2:37:00 AM9/8/20
to Wenxuan Guo, scalismo
Hi Wenxuan Guo,

Unfortunately, there are issues with the combination MacOS, OpenGL and Java, as the latter two are poorly supported on MacOS. We managed to run it on Catalina (and also previous versions) with openjdk 11. 

As OpenGL is officially deprecated on MacOS, we currently take no action and wait how other libraries such as vtk (on which we depend for visualization) will address that issue. 

Best regards,

Marcel

--
You received this message because you are subscribed to the Google Groups "scalismo" group.
To unsubscribe from this group and stop receiving emails from it, send an email to scalismo+u...@googlegroups.com.

Dennis Madsen

unread,
Sep 8, 2020, 8:31:46 AM9/8/20
to scalismo
Hi Wen, 

I also recently had a problem with scalismo and osx. 
I managed to get it running, but it'll show a lot of warnings on each run: 

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.jogamp.common.os.NativeLibrary$3 (file:/var/folders/1q/s35nlqw92jsg3_8296msb1l80000gn/T/sbt_aea8a64f/target/408d0989/513389d3/scalismo-native-stub-4.0.0.jar) to method java.lang.ClassLoader.findLibrary(java.lang.String)
WARNING: Please consider reporting this to the maintainers of com.jogamp.common.os.NativeLibrary$3
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
2020-09-08 14:25:10.483 java[65736:15709787] WARNING: NSWindow drag regions should only be invalidated on the Main Thread! This will throw an exception in the future. Called from (
0   AppKit                              0x00007fff33bc4629 -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 371
1   AppKit                              0x00007fff33bac052 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1416
2   AppKit                              0x00007fff33babac3 -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
3   libnativewindow_macosx.dylib        0x0000000129e14f9e Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
4   ???                                 0x00000001143ee950 0x0 + 4634634576

What I did (on OSX catalina): 
 - Remove all old java versions https://explainjava.com/uninstall-java-macos/ 
 - Install brew for OSX https://brew.sh/ 
 - Install java11 via brew: brew cask install java11 (https://medium.com/w-logs/installing-java-11-on-macos-with-homebrew-7f73c1e9fadf)
 - Enjoy scalismo and osx at the same time! 

/dennis
Message has been deleted

Wenxuan Guo

unread,
Sep 10, 2020, 1:43:52 AM9/10/20
to scalismo
Thank you so much, Marcel and Dennis! I will try out scalismo again after I update my system. Can't wait to create different face shapes! The online tutorials are amazing. Marcel's explanations in the course are really clear.

Just out of curiosity, was Scalismo Lab taken down?

Marcel Luethi

unread,
Sep 11, 2020, 3:39:02 AM9/11/20
to Wenxuan Guo, scalismo
HI Wenxuan Guo,

Thanks for the positive feedback.

Our server was down a few days ago. ScalismoLab should now be available again.

Best regards,

Marcel

--
You received this message because you are subscribed to the Google Groups "scalismo" group.
To unsubscribe from this group and stop receiving emails from it, send an email to scalismo+u...@googlegroups.com.

Wenxuan Guo

unread,
Oct 5, 2020, 8:27:40 PM10/5/20
to scalismo
Hey Dennis,

My old computer did not have enough room for updating the os so I just got a new computer with OSX Catalina, and I have:

jdk-11.0.7.jdk (no other versions)
sbt 1.3.8

It still doesn't work. It shows this:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.jogamp.common.os.NativeLibrary$3 (file:/var/folders/fk/ynxq_sb133ddbl3xpb4m9ffm0000gn/T/sbt_c15c369e/target/56437174/513389d3/scalismo-native-stub-4.0.0.jar) to method java.lang.ClassLoader.findLibrary(java.lang.String)
WARNING: Please consider reporting this to the maintainers of com.jogamp.common.os.NativeLibrary$3
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
2020-10-05 20:22:12.691 java[42765:318283] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'NSWindow drag regions should only be invalidated on the Main Thread!'
*** First throw call stack:
(
0   CoreFoundation                      0x00007fff37560b57 __exceptionPreprocess + 250
1   libobjc.A.dylib                     0x00007fff702135bf objc_exception_throw + 48
2   CoreFoundation                      0x00007fff3758934c -[NSException raise] + 9
3   AppKit                              0x00007fff347835ec -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 310
4   AppKit                              0x00007fff3476b052 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1416
5   AppKit                              0x00007fff3476aac3 -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
6   libnativewindow_macosx.dylib        0x000000012fb60f9e Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
7   ???                                 0x0000000119f816b0 0x0 + 4730656432
)
libc++abi.dylib: terminating with uncaught exception of type NSException
zsh: abort      sbt run

Do you happen to have any idea why this is happening again? :( Thanks a lot!

Best wishes,
Wen
On Tuesday, September 8, 2020 at 8:31:46 AM UTC-4 madsen...@gmail.com wrote:

Wenxuan Guo

unread,
Oct 5, 2020, 8:46:13 PM10/5/20
to scalismo
Sorry, I should add that I was not able to install Java 11 with brew cask (it showed an error message: Cask 'java11' is unavailable: No Cask with this name exists). I installed it from Oracle. Does it matter in this case?
On Tuesday, September 8, 2020 at 8:31:46 AM UTC-4 madsen...@gmail.com wrote:

Dennis Madsen

unread,
Oct 8, 2020, 10:11:14 AM10/8/20
to scalismo
Hi Wen, 

Sorry to hear that it still doesn't work. 

What if you run: java --version, which version java version does it then show? (mine shows openjdk 11.0.2 2019-01-15
Did you also completely remove all traces of the default java version on OSX before installing the newer version?
Also, remember to add the casks tap before installing java from homebrew (brew tap homebrew/cask-versions -> brew cask install java11)

Are you running sbt from the terminal (cd to your project directory and execute sbt run)? Or from within intellij?

Best
Dennis

Wenxuan Guo

unread,
Oct 13, 2020, 12:55:26 PM10/13/20
to scalismo
Dear Dennis,

Thank you for the instructions! Mine shows the same java version as yours and I removed all the default versions...However, I tried several times and it still doesn't work, so I gave up. Right now I'm writing a Python program that uses the Basel Face data. Luckily I won't need as many functions as scalismo library to achieve my goals. Thank you so much!

Best,
Wen

Marcel Luethi

unread,
Mar 6, 2021, 12:01:19 PMMar 6
to scalismo
Dear all,

A late addition to this thread regarding the crash on MacOS.  It seems what is causing the crash is an issue in many versions of openjdk (see this issue: https://github.com/AdoptOpenJDK/openjdk-support/issues/101). It turns out that the zulu builds of openjdk are not affected by this issue. Hence the solution is to use a zulu build of openJDK.

I updated the documentation on the scalismo website to include details on how to set up Scalismo on MacOS:

Best regards,

Marcel
Reply all
Reply to author
Forward
0 new messages