failure to create scalaris repo

16 views
Skip to first unread message

S Ma

unread,
Jul 19, 2016, 2:02:00 AM7/19/16
to scalaris
Hello All.
I am trying to install scalaris.
upon running:
sudo curl "http://download.opensuse.org/repositories/home:/scalaris/Fedora_20/home:scalaris.repo" -o /etc/yum.repos.d/home\:scalaris.repo
created repo:

ls -lt /etc/yum.repos.d/

total 68

-rw-r--r--  1 root root 1046 Jul 18 22:44 home:scalaris.repo

However, its contents are unusable:

cat /etc/yum.repos.d/home\:scalaris.repo 

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"

  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>

<title>Object not found!</title>

<link rev="made" href="mailto:webm...@opensuse.org" />

<style type="text/css"><!--/*--><![CDATA[/*><!--*/ 

    body { color: #000000; background-color: #FFFFFF; }

    a:link { color: #0000CC; }

    p, address {margin-left: 3em;}

    span {font-size: smaller;}

/*]]>*/--></style>

</head>


<body>

<h1>Object not found!</h1>

<p>


    The requested URL was not found on this server.


    If you entered the URL manually please check your

    spelling and try again.


</p>

<p>

If you think this is a server error, please contact

the <a href="mailto:webm...@opensuse.org">webmaster</a>.


</p>


<h2>Error 404</h2>

<address>

  <a href="/">download.opensuse.org</a><br />

  

  <span>Tue Jul 19 07:44:15 2016<br />

  Apache/2.2.12 (Linux/SUSE)</span>

</address>

</body>

</html>

I also been trying to build it out of source without much luck. the log file has been created but it doesn't say much what exactly it is unhappy with... :(

cat config.log 

This file contains any messages produced by compilers while

running configure, to aid debugging if configure makes a mistake.


It was created by scalaris configure 0.9.0+git, which was

generated by GNU Autoconf 2.69.  Invocation command line was


  $ ./configure 


## --------- ##

## Platform. ##

## --------- ##


hostname = centos7

uname -m = x86_64

uname -r = 3.10.0-327.22.2.el7.x86_64

uname -s = Linux

uname -v = #1 SMP Thu Jun 23 17:05:11 UTC 2016


/usr/bin/uname -p = x86_64

/bin/uname -X     = unknown


/bin/arch              = x86_64

/usr/bin/arch -k       = unknown

/usr/convex/getsysinfo = unknown

/usr/bin/hostinfo      = unknown

/bin/machine           = unknown

/usr/bin/oslevel       = unknown

/bin/universe          = unknown


PATH: /sbin

PATH: /bin

PATH: /usr/sbin

PATH: /usr/bin



## ----------- ##

## Core tests. ##

## ----------- ##


configure:2057: checking for false

configure:2075: found /bin/false

configure:2087: result: /bin/false

configure:2098: checking for true

configure:2116: found /bin/true

configure:2128: result: /bin/true

configure:2252: checking for g++

configure:2282: result: no

configure:2252: checking for c++

configure:2282: result: no

configure:2252: checking for gpp

configure:2282: result: no

configure:2252: checking for aCC

configure:2282: result: no

configure:2252: checking for CC

configure:2282: result: no

configure:2252: checking for cxx

configure:2282: result: no

configure:2252: checking for cc++

configure:2282: result: no

configure:2252: checking for cl.exe

configure:2282: result: no

configure:2252: checking for FCC

configure:2282: result: no

configure:2252: checking for KCC

configure:2282: result: no

configure:2252: checking for RCC

configure:2282: result: no

configure:2252: checking for xlC_r

configure:2282: result: no

configure:2252: checking for xlC

configure:2282: result: no

configure:2306: checking for C++ compiler version

configure:2315: g++ --version >&5

./configure: line 2317: g++: command not found

configure:2326: $? = 127

configure:2315: g++ -v >&5

./configure: line 2317: g++: command not found

configure:2326: $? = 127

configure:2315: g++ -V >&5

./configure: line 2317: g++: command not found

configure:2326: $? = 127

configure:2315: g++ -qversion >&5

./configure: line 2317: g++: command not found

configure:2326: $? = 127

configure:2346: checking whether the C++ compiler works

configure:2368: g++    conftest.cpp  >&5

./configure: line 2370: g++: command not found

configure:2372: $? = 127

configure:2410: result: no

configure: failed program was:

| /* confdefs.h */

| #define PACKAGE_NAME "scalaris"

| #define PACKAGE_TARNAME "scalaris"

| #define PACKAGE_VERSION "0.9.0+git"

| #define PACKAGE_STRING "scalaris 0.9.0+git"

| #define PACKAGE_BUGREPORT "scal...@googlegroups.com"

| #define PACKAGE_URL ""

| /* end confdefs.h.  */

| int

| main ()

| {

|   ;

|   return 0;

| }

configure:2415: error: in `/root/scalaris':

configure:2417: error: C++ compiler cannot create executables

See `config.log' for more details


## ---------------- ##

## Cache variables. ##

## ---------------- ##


ac_cv_env_CCC_set=

ac_cv_env_CCC_value=

ac_cv_env_CC_set=

ac_cv_env_CC_value=

ac_cv_env_CFLAGS_set=

ac_cv_env_CFLAGS_value=

ac_cv_env_CPPFLAGS_set=

ac_cv_env_CPPFLAGS_value=

ac_cv_env_CXXFLAGS_set=

ac_cv_env_CXXFLAGS_value=

ac_cv_env_CXX_set=

ac_cv_env_CXX_value=

ac_cv_env_ERLCFLAGS_set=

ac_cv_env_ERLCFLAGS_value=

ac_cv_env_ERLC_set=

ac_cv_env_ERLC_value=

ac_cv_env_ERL_set=

ac_cv_env_ERL_value=

ac_cv_env_LDFLAGS_set=

ac_cv_env_LDFLAGS_value=

ac_cv_env_LIBS_set=

ac_cv_env_LIBS_value=

ac_cv_env_build_alias_set=

ac_cv_env_build_alias_value=

ac_cv_env_host_alias_set=

ac_cv_env_host_alias_value=

ac_cv_env_target_alias_set=

ac_cv_env_target_alias_value=

ac_cv_path_FALSE=/bin/false

ac_cv_path_TRUE=/bin/true


## ----------------- ##

## Output variables. ##

## ----------------- ##


BITCASK_LIBS=''

BOOST_ASIO_LIB=''

BOOST_CPPFLAGS=''

BOOST_LDFLAGS=''

BOOST_PROGRAM_OPTIONS_LIB=''

BOOST_REGEX_LIB=''

BOOST_SYSTEM_LIB=''

BOOST_UNIT_TEST_FRAMEWORK_LIB=''

BROWSER=''

BUILDCLASSPATH=''

CC=''

CFLAGS=''

CPPFLAGS=''

CT_RUN_FILE=''

CXX='g++'

CXXFLAGS=''

DEFS=''

DIALYZER_FLAGS=''

DRIVER_OS=''

ECHO_C=''

ECHO_N='-n'

ECHO_T=''

EDOCMACROS=''

EMAKEFILECOMPILECOMPAT=''

EMAKEFILEDEFINES=''

ENABLEPYTHON2INSTALL=''

ENABLEPYTHON3=''

ENABLEPYTHON3INSTALL=''

ENABLERUBYINSTALL=''

EPMD=''

ERL=''

ERLANG_BITCASK_FLAGS=''

ERLANG_ERLANGJS_FLAGS=''

ERLANG_ERTS_VER=''

ERLANG_HANOIDB_FLAGS=''

ERLANG_LIB_DIR=''

ERLANG_LIB_DIR_bitcask=''

ERLANG_LIB_DIR_common_test=''

ERLANG_LIB_DIR_compiler=''

ERLANG_LIB_DIR_crypto=''

ERLANG_LIB_DIR_edoc=''

ERLANG_LIB_DIR_erlang_js=''

ERLANG_LIB_DIR_erts=''

ERLANG_LIB_DIR_hanoidb=''

ERLANG_LIB_DIR_inets=''

ERLANG_LIB_DIR_kernel=''

ERLANG_LIB_DIR_os_mon=''

ERLANG_LIB_DIR_ssl=''

ERLANG_LIB_DIR_stdlib=''

ERLANG_LIB_DIR_toke=''

ERLANG_LIB_DIR_tools=''

ERLANG_LIB_DIR_xmerl=''

ERLANG_LIB_VER_bitcask=''

ERLANG_LIB_VER_common_test=''

ERLANG_LIB_VER_compiler=''

ERLANG_LIB_VER_crypto=''

ERLANG_LIB_VER_edoc=''

ERLANG_LIB_VER_erlang_js=''

ERLANG_LIB_VER_erts=''

ERLANG_LIB_VER_hanoidb=''

ERLANG_LIB_VER_inets=''

ERLANG_LIB_VER_kernel=''

ERLANG_LIB_VER_os_mon=''

ERLANG_LIB_VER_ssl=''

ERLANG_LIB_VER_stdlib=''

ERLANG_LIB_VER_toke=''

ERLANG_LIB_VER_tools=''

ERLANG_LIB_VER_xmerl=''

ERLANG_ROOT_DIR=''

ERLANG_TOKE_FLAGS=''

ERLC=''

ERLCFLAGS=''

EXEEXT=''

FALSE='/bin/false'

HAVE_CXX11=''

INSTALL_INIT=''

JAVAFUNCTIONS=''

LDFLAGS=''

LIBOBJS=''

LIBS=''

LTLIBOBJS=''

NIFFLAGS=''

OBJEXT=''

PACKAGE_BUGREPORT='scal...@googlegroups.com'

PACKAGE_NAME='scalaris'

PACKAGE_STRING='scalaris 0.9.0+git'

PACKAGE_TARNAME='scalaris'

PACKAGE_URL=''

PACKAGE_VERSION='0.9.0+git'

PATH_SEPARATOR=':'

PYTHON2=''

PYTHON2SITELIBDIR=''

PYTHON3=''

PYTHON3SITELIBDIR=''

PYTHON3_2TO3=''

RT=''

RUBYSITELIBDIR=''

RUNUSER=''

RUN_TEST=''

RUN_TEST_FILE=''

SCREEN=''

SHELL='/bin/sh'

SUDO=''

SYSTEMD_UNITDIR=''

TRUE='/bin/true'

YAWS_OPTIONS=''

ac_ct_CC=''

ac_ct_CXX=''

bindir='${exec_prefix}/bin'

build=''

build_alias=''

build_cpu=''

build_os=''

build_vendor=''

datadir='${datarootdir}'

datarootdir='${prefix}/share'

docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'

dvidir='${docdir}'

exec_prefix='NONE'

host=''

host_alias=''

host_cpu=''

host_os=''

host_vendor=''

htmldir='${docdir}'

includedir='${prefix}/include'

infodir='${datarootdir}/info'

libdir='${exec_prefix}/lib'

libexecdir='${exec_prefix}/libexec'

localedir='${datarootdir}/locale'

localstatedir='${prefix}/var'

mandir='${datarootdir}/man'

oldincludedir='/usr/include'

pdfdir='${docdir}'

prefix='NONE'

program_transform_name='s,x,x,'

psdir='${docdir}'

sbindir='${exec_prefix}/sbin'

sharedstatedir='${prefix}/com'

sysconfdir='${prefix}/etc'

target_alias=''


## ----------- ##

## confdefs.h. ##

## ----------- ##


/* confdefs.h */

#define PACKAGE_NAME "scalaris"

#define PACKAGE_TARNAME "scalaris"

#define PACKAGE_VERSION "0.9.0+git"

#define PACKAGE_STRING "scalaris 0.9.0+git"

#define PACKAGE_BUGREPORT "scal...@googlegroups.com"

#define PACKAGE_URL ""


configure: exit 77

Can someone tell me, please, what exactly do I need to build it out of source?
I have erlang installed:











yum list installed | grep erlang

erlang.x86_64                          R16B-03.16.el7                  @epel    

erlang-appmon.x86_64                   R16B-03.16.el7                  @epel    

erlang-asn1.x86_64                     R16B-03.16.el7                  @epel    

erlang-common_test.x86_64              R16B-03.16.el7                  @epel    

erlang-compiler.x86_64                 R16B-03.16.el7                  @epel    

erlang-cosEvent.x86_64                 R16B-03.16.el7                  @epel    

erlang-cosEventDomain.x86_64           R16B-03.16.el7                  @epel    

erlang-cosFileTransfer.x86_64          R16B-03.16.el7                  @epel    

erlang-cosNotification.x86_64          R16B-03.16.el7                  @epel    

erlang-cosProperty.x86_64              R16B-03.16.el7                  @epel    

erlang-cosTime.x86_64                  R16B-03.16.el7                  @epel    

erlang-cosTransactions.x86_64          R16B-03.16.el7                  @epel    

erlang-crypto.x86_64                   R16B-03.16.el7                  @epel    

erlang-debugger.x86_64                 R16B-03.16.el7                  @epel    

erlang-dialyzer.x86_64                 R16B-03.16.el7                  @epel    

erlang-diameter.x86_64                 R16B-03.16.el7                  @epel    

erlang-edoc.x86_64                     R16B-03.16.el7                  @epel    

erlang-eldap.x86_64                    R16B-03.16.el7                  @epel    

erlang-erl_docgen.x86_64               R16B-03.16.el7                  @epel    

erlang-erl_interface.x86_64            R16B-03.16.el7                  @epel    

erlang-erts.x86_64                     R16B-03.16.el7                  @epel    

erlang-et.x86_64                       R16B-03.16.el7                  @epel    

erlang-eunit.x86_64                    R16B-03.16.el7                  @epel    

erlang-examples.x86_64                 R16B-03.16.el7                  @epel    

erlang-gs.x86_64                       R16B-03.16.el7                  @epel    

erlang-hipe.x86_64                     R16B-03.16.el7                  @epel    

erlang-ic.x86_64                       R16B-03.16.el7                  @epel    

erlang-inets.x86_64                    R16B-03.16.el7                  @epel    

erlang-jinterface.x86_64               R16B-03.16.el7                  @epel    

erlang-kernel.x86_64                   R16B-03.16.el7                  @epel    

erlang-megaco.x86_64                   R16B-03.16.el7                  @epel    

erlang-mnesia.x86_64                   R16B-03.16.el7                  @epel    

erlang-observer.x86_64                 R16B-03.16.el7                  @epel    

erlang-odbc.x86_64                     R16B-03.16.el7                  @epel    

erlang-orber.x86_64                    R16B-03.16.el7                  @epel    

erlang-os_mon.x86_64                   R16B-03.16.el7                  @epel    

erlang-otp_mibs.x86_64                 R16B-03.16.el7                  @epel    

erlang-parsetools.x86_64               R16B-03.16.el7                  @epel    

erlang-percept.x86_64                  R16B-03.16.el7                  @epel    

erlang-pman.x86_64                     R16B-03.16.el7                  @epel    

erlang-public_key.x86_64               R16B-03.16.el7                  @epel    

erlang-reltool.x86_64                  R16B-03.16.el7                  @epel    

erlang-runtime_tools.x86_64            R16B-03.16.el7                  @epel    

erlang-sasl.x86_64                     R16B-03.16.el7                  @epel    

erlang-snmp.x86_64                     R16B-03.16.el7                  @epel    

erlang-ssh.x86_64                      R16B-03.16.el7                  @epel    

erlang-ssl.x86_64                      R16B-03.16.el7                  @epel    

erlang-stdlib.x86_64                   R16B-03.16.el7                  @epel    

erlang-syntax_tools.x86_64             R16B-03.16.el7                  @epel    

erlang-test_server.x86_64              R16B-03.16.el7                  @epel    

erlang-toolbar.x86_64                  R16B-03.16.el7                  @epel    

erlang-tools.x86_64                    R16B-03.16.el7                  @epel    

erlang-tv.x86_64                       R16B-03.16.el7                  @epel    

erlang-typer.x86_64                    R16B-03.16.el7                  @epel    

erlang-webtool.x86_64                  R16B-03.16.el7                  @epel    

erlang-wx.x86_64                       R16B-03.16.el7                  @epel    

erlang-xmerl.x86_64                    R16B-03.16.el7                  @epel   

what else is needed to build scalaris? or, perhaps rpm for Centos 7 exists somewhere? ... :)
thank you! :)

Nico Kruber

unread,
Jul 19, 2016, 3:20:46 AM7/19/16
to scal...@googlegroups.com
Hi,
you can get a list of supported distributions by browsing the repository
(depending on whether you'd like a development snapshot or the latest stable):
http://download.opensuse.org/repositories/home:/scalaris/
http://download.opensuse.org/repositories/home:/scalaris:/svn/

-> Fedora 20 is not supported (by Fedora) anymore and this is why we removed
it in the meanwhile

-> there are CentOS 7 packages

-> the configure output (not the log file) should have told you what is
missing and unless you use the "--disable-cpp" flag, a working c++ compiler
which can work with C++11 is needed

-> a general advice: you should probably not run external code as root ;)


Regards
Nico Kruber
> *erlang*.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-appmon.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-asn1.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-common_test.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-compiler.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosEvent.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosEventDomain.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosFileTransfer.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosNotification.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosProperty.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosTime.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-cosTransactions.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-crypto.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-debugger.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-dialyzer.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-diameter.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-edoc.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-eldap.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-erl_docgen.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-erl_interface.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-erts.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-et.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-eunit.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-examples.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-gs.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-hipe.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-ic.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-inets.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-jinterface.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-kernel.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-megaco.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-mnesia.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-observer.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-odbc.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-orber.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-os_mon.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-otp_mibs.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-parsetools.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-percept.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-pman.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-public_key.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-reltool.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-runtime_tools.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-sasl.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-snmp.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-ssh.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-ssl.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-stdlib.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-syntax_tools.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-test_server.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-toolbar.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-tools.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-tv.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-typer.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-webtool.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-wx.x86_64 R16B-03.16.el7
> @epel
>
> *erlang*-xmerl.x86_64 R16B-03.16.el7
> @epel
>
>
> what else is needed to build scalaris? or, perhaps rpm for Centos 7 exists
> somewhere? ... :)
>
> thank you! :)

--
kru...@zib.de PGP key: 20F2724BDAEA9E59
signature.asc
Reply all
Reply to author
Forward
0 new messages