最后的else里这样就可以了…… 不过前边也有一点点点不同…… (不直接发全部代码了@。@countChange(money, coins.tail) + countChange(money-coins.head, coins)
Finally, the use of the/:and:\should be avoided in preference to the more explicitfoldLeftandfoldRightmethod ofIterator. The right-associativity of the/:can lead to extremely confusing code, at the benefit of saving a few characters.