Breeze 2.0 Released

68 views
Skip to first unread message

David Hall

unread,
Oct 5, 2021, 1:20:22 AM10/5/21
to scala-...@googlegroups.com
Hi everyone,

(This email is basically the same as the RC1 email, but now it's officially 2.0!)

I have now finally published Breeze artifacts for Scala 2.12, 2.13, and 3.

There's been a fairly major overhaul to the way Breeze operators are organized to support the cross build. In addition, we now use Ludovic Henry's (@luhenry) new netlib library for BLAS and LAPACK, which should be faster and lighter than what we were using before. Other than that, there should be some fixed bugs but no real feature changes.

I also did something a little not good, which is that the Scala 3 build of Breeze relies on Spire 2.13 because AFAICT there's no Scala 3 artifact yet.

This is a major version bump mainly because of the reorganization of implicits to support the cross build. I would hope that very little client usage of Breeze code will need to change, though I imagine some will.

Thanks,
David

quaf...@gmail.com

unread,
Nov 8, 2021, 11:53:35 AM11/8/21
to Scala Breeze
I'm having some trouble with converting between breeze collections and vanilla scala collections post 2.0... 

        val asVector: DenseVector[Int] = DenseVector(inFreq: _*) // for slicing
         .....
          val idx         = convert(sorted(::, 1), Int)
          val changeThese = idx(0 until anz)
          asVector(changeThese.toScalaVector())  -= 1

I seem to be getting a lot of these, after upgrading to Breeze 2.0. Would anyone have a hint here? It's the last line above, .toScalaVector() in bold, which seems to generate the issue...

missing argument for parameter i of method apply in trait SeqOps: (i: Int): Int

Would anyone have a hint?

Darren Wilkinson

unread,
May 21, 2022, 3:25:38 PMMay 21
to Scala Breeze
Would it be possible to have a release (or release candidate) sometime soon which doesn't have any (transitive) dependencies on Scala 2 libraries? I think that the 2.0.1-RC1 release still has a dependency on a Scala 2 version of cats-kernel which is causing me some pain.

Thanks,

David Hall

unread,
May 22, 2022, 9:25:12 PMMay 22
to scala-...@googlegroups.com
sure. No promises on the spire compat though... It's still only a "milestone" release that's 4 months old.

--
You received this message because you are subscribed to the Google Groups "Scala Breeze" group.
To unsubscribe from this group and stop receiving emails from it, send an email to scala-breeze...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/scala-breeze/ae481679-1f98-4bec-a12d-cc4ab9b782a4n%40googlegroups.com.

Darren Wilkinson

unread,
Jun 18, 2022, 12:45:16 PM (13 days ago) Jun 18
to Scala Breeze
I notice that spire 0.18.0 has been released. Does that help?

Thanks,
Reply all
Reply to author
Forward
0 new messages