cygwin-specific patch for python-2.6 spkg

8 views
Skip to first unread message

Dima Pasechnik

unread,
Mar 24, 2010, 12:38:18 AM3/24/10
to sage-windows
I have circumstantial (although strong) evidence that one needs to
disable threads in ssl module;
if it is on, I get strange hard to explain crashes during the building
process, like the one I reported in another
thread here.
If it is off, then it goes smoothly (and stops at gdmodule spkg, which
is, I believe, known not to build on 4.3.4)

The rationale for this patch is described here:
http://cygwin.com/ml/cygwin/2009-07/msg00831.html
(see also http://old.nabble.com/Python-2.6---tt27319566.html#a27345569
for a more recent (Jan 2010) discussion
on when and how python2.6 should come into cygwin, that in particular
confirms that that patch is still apparently needed)

The patch itself is trivial:
in python-2.6.4.p7/src/Modules/_ssl.c
put

#ifdef CYGWIN
#undef WITH_THREADS
#endif

immediately after #include "Python.h"

Should I open a ticket for this?

Dima

Reply all
Reply to author
Forward
0 new messages