init.sage not running anymore

99 views
Skip to first unread message

David Ayotte

unread,
Mar 3, 2024, 3:40:50 PMMar 3
to sage-support
Hello,

Since I upgraded my SageMath to version 10.3.beta8, the init.sage script located at ~/.sage/init.sage stopped running when I start sage. I also get the following message right after the SageMath banner:

/home/user/sage/local/var/lib/sage/venv-python3.11.1/lib/python3.11/site-packages/prompt_toolkit/application/application.py:988: DeprecationWarning: There is no current event loop
  loop = asyncio.get_event_loop()

Do anybody know what happened here? I like to use this script for defining some frequently used variables.

Best,

David A.


Jan Groenewald

unread,
Mar 3, 2024, 11:43:19 PMMar 3
to sage-s...@googlegroups.com

--
You received this message because you are subscribed to the Google Groups "sage-support" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/6f301e88-00af-48e3-9950-29a7e1e5fda3n%40googlegroups.com.

Emmanuel Charpentier

unread,
Mar 4, 2024, 3:01:35 PMMar 4
to sage-support

FWIW, Someone going under the nickname of stillconfused posted alpost exactly the same problem on ask.sagemath.org. Is that you ?

kcrisman

unread,
Mar 4, 2024, 5:04:28 PMMar 4
to sage-support

Hello,

Since I upgraded my SageMath to version 10.3.beta8, the init.sage script located at ~/.sage/init.sage stopped running when I start sage. I also get the following message right after the SageMath banner:

/home/user/sage/local/var/lib/sage/venv-python3.11.1/lib/python3.11/site-packages/prompt_toolkit/application/application.py:988: DeprecationWarning: There is no current event loop
  loop = asyncio.get_event_loop()


I haven't noticed about init.sage (didn't really check), but I am also seeing this with a recent upgrade. (On Mac M1 chip running Ventura, for what it's worth.)  Any opinions on whether this should be a blocker if the init.sage is confirmed?   I think Volker already started rcs.

David Ayotte

unread,
Mar 4, 2024, 10:55:29 PMMar 4
to sage-support
I am still confused, but I'm not "stillconfused" :-)

I forgot to mention, but, like the user in AskSageMath, I'm also running sage under WSL2 Ubuntu 22.04.4 LTS, so it might be related. Moreover, I just upgraded sage to 10.3.rc2 and still have the same problem. I will open a GH issue.

Thanks for your replies!

David A.

David Ayotte

unread,
Mar 4, 2024, 10:55:29 PMMar 4
to sage-support
I opened the following issue: #37539

Best,

David A.

Le lundi 4 mars 2024 à 17:04:28 UTC-5, kcrisman a écrit :
Reply all
Reply to author
Forward
0 new messages