Sage 9.2 configure fails when forced to use system atlas

11 views
Skip to first unread message

A A

unread,
Apr 8, 2021, 3:21:15 AMApr 8
to sage-support

Sage 9.2 configuration fails when passed `--with-system-atlas=forced`.
Thefollowing snippets demonstrates the setup:

    $ export SAGE_ATLAS_LIB='/usr/local/atlas/lib/'
    $ ./configure --with-blas=atlas --enable-atlas=yes --with-system-atlas=force --prefix=$HOME/sage --with-python='/usr/local/bin/python3.9'

The error message is as follows:
    Checking whether SageMath should install SPKG atlas...
    configure: error: given --with-system-atlas=force but no system package could be used

From the documentation
(https://doc.sagemath.org/html/en/installation/source.html#environment-variables),
Setting SAGE_ATLAS_LIB should enable ./configure find the requisite libraries.

Any advice on navigating this? 

Dima Pasechnik

unread,
Apr 8, 2021, 3:54:49 AMApr 8
to sage-support
This looks like a bug. However, we are planning to stop supporting atlas:
https://trac.sagemath.org/ticket/30350

if you absolutely must use system's atlas, one can perhaps try to work
around it by
creating openblas.pc file pointing at the atlas' libblas
> --
> You received this message because you are subscribed to the Google Groups "sage-support" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/6d70993e-0dbb-460b-9c31-f38836d4c6d9n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages