about Sage 9.3

42 views
Skip to first unread message

GÖKHAN SOYDAN

unread,
Sep 9, 2021, 11:01:00 AMSep 9
to sage-support
hello everybody,
I first installed Sage 9.4 on my IMac (Catalina 10.15.7).
It was running, but some old codes did not run. (I know these codes are working on another computer which has Sage 9.3.) After deleting all Sage installation documents, 
I installed Sage 9.3, but Sage 9.3 did not work. On my screen, the following message seems:

│ SageMath version 9.3, Release Date: 2021-05-09                     │

│ Using Python 3.9.2. Type "help()" for help.                        │

└────────────────────────────────────────────────────────────────────┘

------------------------------------------------------------------------

(no backtrace available)

------------------------------------------------------------------------

Unhandled SIGILL: An illegal instruction occurred.

This probably occurred because a *compiled* module has a bug

in it and is not properly wrapped with sig_on(), sig_off().

Python will now terminate.

------------------------------------------------------------------------

Illegal instruction: 4

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

===============================================================

Can someone help me? What should I do to use Sage 9.3?

Dima Pasechnik

unread,
Sep 9, 2021, 11:20:59 AMSep 9
to sage-support
BInary installations of Sage 9.3 are known to have this issue (too
much is assumed from the CPU you have)
As well, your macOS version came out after 9.3 was released, no
guarantee it will work if you built
it from source (if you manage to do this at all)

The best way would be to port your code to Sage 9.4, surely it cannot
be much work.

Feel free to ask questions on this here.



>
> --
> You received this message because you are subscribed to the Google Groups "sage-support" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/51c823f0-6474-45ce-9134-f785244208f8n%40googlegroups.com.

Matthias Koeppe

unread,
Sep 10, 2021, 12:26:24 AMSep 10
to sage-support
This is a known issue with the binary distributions for Sage 9.3 and 9.4. See https://wiki.sagemath.org/ReleaseTours/sage-9.4#Availability_as_binaries_and_in_distributions
Install from source instead.

GÖKHAN SOYDAN

unread,
Sep 12, 2021, 8:14:32 AMSep 12
to sage-s...@googlegroups.com
thank you for your suggestions.

Dima Pasechnik <dim...@gmail.com>, 9 Eyl 2021 Per, 18:21 tarihinde şunu yazdı:
You received this message because you are subscribed to a topic in the Google Groups "sage-support" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sage-support/V5UpJsMrubs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq1anRzUmk0A%3D7c1i%2Bjc2xSbn-gh_qJmNiUo3T4R3yjW9Q%40mail.gmail.com.


--
-------------------------------------------------------
-------------------------------------------------------
Gokhan SOYDAN (Ph.D.)

Professor

Bursa Uludag University,
Faculty of Arts and Science,
Department of Mathematics,
16059 Gorukle, Bursa/TURKEY
Tel: +90 224 2942870
Fax: +90 224 2941898

e-mail: gso...@uludag.edu.tr

alternative e-mail: gsoy...@gmail.com

web: http://gsoydan.home.uludag.edu.tr 
-------------------------------------------------------------------
-------------------------------------------------------------------
Reply all
Reply to author
Forward
0 new messages