problem compiling sage 9.2 on RHEL 6

44 views
Skip to first unread message

Klaus Hackenberg

unread,
Mar 3, 2021, 12:15:53 PMMar 3
to sage-support
High,
I tried to compile sage 9.2 on a server running RHEL 6.
I use gcc 9.2.0 to compile and the following commands

./configure --with-gmp=gmp
make -j4

ppl-1.2 fails to compile whith the attached error log file.
Do you have any idea what's going wrong and how to fix it?
Regards, Klaus Hackenberg
ppl-1.2.p1.log

Dima Pasechnik

unread,
Mar 3, 2021, 12:28:31 PMMar 3
to sage-support
On Wed, Mar 3, 2021 at 5:15 PM 'Klaus Hackenberg' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
> I tried to compile sage 9.2 on a server running RHEL 6.
> I use gcc 9.2.0 to compile and the following commands
>
> ./configure --with-gmp=gmp
might be in error.

What did you mean to achieve by '--with-gmp=gmp' ? By default Sage
will look for a systemwide GMP
installation and try to use it (else it will build its own)
But Sage needs GMP version 6.1, at least. Most probably what you have
on the 10-years old RHEL 6
is still GMP version 4, so it won't fly.

You probably want to force building GMP rather than much iffier MPIR, so you'd
probably need '--with-mp=gmp' in this case.



> make -j4
>
> ppl-1.2 fails to compile whith the attached error log file.
> Do you have any idea what's going wrong and how to fix it?
> Regards, Klaus Hackenberg
>
> --
> You received this message because you are subscribed to the Google Groups "sage-support" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/e1713003-dbe6-475b-9ffd-214d005cfec5n%40googlegroups.com.

Hackenberg, Klaus

unread,
Mar 4, 2021, 9:06:46 AMMar 4
to sage-s...@googlegroups.com
High,

I startet in a fresh directory sage-9.2 (from sage-9.2.tag.gz)
using the commands

./configure
make -j4

and ran into the same error.

gmp binaries are build automatically

ls -lrt sage-9.2/local/lib/*gmp*
-rwxr-xr-x 1 lsf lsf 3342817 Mar 4 12:35 sage-9.2/local/lib/libgmp.so.23.0.3
lrwxrwxrwx 1 lsf lsf 16 Mar 4 12:35 sage-9.2/local/lib/libgmp.so.23 -> libgmp.so.23.0.3
lrwxrwxrwx 1 lsf lsf 16 Mar 4 12:35 sage-9.2/local/lib/libgmp.so -> libgmp.so.23.0.3
-rwxr-xr-x 1 lsf lsf 318950 Mar 4 12:36 sage-9.2/local/lib/libgmpxx.so.8.4.3
lrwxrwxrwx 1 lsf lsf 17 Mar 4 12:36 sage-9.2/local/lib/libgmpxx.so.8 -> libgmpxx.so.8.4.3
lrwxrwxrwx 1 lsf lsf 17 Mar 4 12:36 sage-9.2/local/lib/libgmpxx.so -> libgmpxx.so.8.4.3
-rw-r--r-- 1 lsf lsf 6804714 Mar 4 12:36 sage-9.2/local/lib/libgmp.a
-rw-r--r-- 1 lsf lsf 796188 Mar 4 12:36 sage-9.2/local/lib/libgmpxx.a
-rwxr-xr-x 1 lsf lsf 955210 Mar 4 12:43 sage-9.2/local/lib/libcddgmp.so.0.0.0
lrwxrwxrwx 1 lsf lsf 18 Mar 4 12:43 sage-9.2/local/lib/libcddgmp.so.0 -> libcddgmp.so.0.0.0
lrwxrwxrwx 1 lsf lsf 18 Mar 4 12:43 sage-9.2/local/lib/libcddgmp.so -> libcddgmp.so.0.0.0
-rw-r--r-- 1 lsf lsf 1532644 Mar 4 12:43 sage-9.2/local/lib/libcddgmp.a

I attach the error log file.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Mittwoch, 3. März 2021 18:28
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6
You received this message because you are subscribed to a topic in the Google Groups "sage-support" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sage-support/GniJKQ0MaMY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq0i67G3DRu4oeLSTegkFw0Dr-FtFVHnpQShXze%3DSi7h5g%40mail.gmail.com.

ppl-1.2.p1.log

Dima Pasechnik

unread,
Mar 4, 2021, 9:57:05 AMMar 4
to sage-support
Please post the top-level config.log, then we'll see more details about GMP.

In Sage 9.2, if you do ./configure without arguments, Sage is building
a GMP-compatible MPIR, not "real" GMP.
(Perhaps MPIR is broken now beyond repair, and shoud not be used on
RHEL 6,I don't know)
We're changing with in the coming 9.3, see
https://trac.sagemath.org/ticket/30752
Meanwhile please do

make mpir-clean
./configure --with-mp=gmp
make -j4


On Thu, Mar 4, 2021 at 2:06 PM 'Hackenberg, Klaus' via sage-support
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/e501b240a4bc4e2f96d0440c10d06199%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 4, 2021, 11:04:52 AMMar 4
to sage-s...@googlegroups.com
High,

I startet in a fresh directory sage-9.2 (from sage-9.2.tag.gz)
using the command " make mpir-clean" and got

=========================================================================
[lsf@dlp762 sage-9.2]$ make mpir-clean
make build/make/Makefile --stop
make[1]: Entering directory `/net/dlp762/share/application-software/Sage/sage-9.2'
rm -f config.log
mkdir -p logs/pkgs
ln -s logs/pkgs/config.log config.log
****************************************************************************
error: Sage source tree is unconfigured. Please run "./configure" first.
note: Type "./configure --help" to see the available configuration options.
****************************************************************************
make[1]: *** [build/make/Makefile] Error 1
make[1]: Leaving directory `/net/dlp762/share/application-software/Sage/sage-9.2'
make: *** [mpir-clean] Error 2
[lsf@dlp762 sage-9.2]$
=========================================================================

I then used

./configure --with-mp=gmp
make mpir-clean
make -j4

and ppl-1.2 compiled !

But now I get a new error with symmetrica-3.0.1.
I attach the error log file

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Donnerstag, 4. März 2021 15:57
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq3663awZ35af7%3D2ROLRkWF_%2B8w7dM41BCk9c2jGU7kAoQ%40mail.gmail.com.
symmetrica-3.0.1.log

Dima Pasechnik

unread,
Mar 4, 2021, 11:18:29 AMMar 4
to sage-support
your system python cannot uncompress .xz files... :(

how old is it?

can you install systemwide python2 to be python 2.7?

Hackenberg, Klaus

unread,
Mar 4, 2021, 12:08:45 PMMar 4
to sage-s...@googlegroups.com

High,

 

on my RHEL6 server I see

 

[root@dlp762 Sage]# python --version

Python 2.6.6

 

  But the server has installed xz packages

 

[root@dlp762 Sage]# rpm -qa --last|grep xz

xz-devel-4.999.9-0.5.beta.20091007git.el6.x86_64 Tue Jun 18 11:06:45 2019

xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:37 2015

xz-4.999.9-0.5.beta.20091007git.el6.x86_64    Fri Sep 18 09:39:26 2015

xz-libs-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:03 2015

 

  Is it possible to use the buildin xz ?

 

Regards, Klaus Hackenberg

 

--

Klaus Hackenberg

IT-Systeme und Software-Integration

IT.SERVICES

Ruhr-Universität Bochum | 44780 Bochum

fon: +49 234 32 23485

http://www.it-services.rub.de/

 

Dima Pasechnik

unread,
Mar 4, 2021, 12:53:28 PMMar 4
to sage-support
On Thu, Mar 4, 2021 at 5:08 PM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
>
>
> on my RHEL6 server I see
>
>
>
> [root@dlp762 Sage]# python --version
>
> Python 2.6.6
>
>
>
> But the server has installed xz packages
>
>
>
> [root@dlp762 Sage]# rpm -qa --last|grep xz
>
> xz-devel-4.999.9-0.5.beta.20091007git.el6.x86_64 Tue Jun 18 11:06:45 2019
>
> xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:37 2015
>
> xz-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:26 2015
>
> xz-libs-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:03 2015
>
>
>
> Is it possible to use the buildin xz ?

Do you have xz application installed and accepted by Sage (it should
be visible in
config.log)? If so, something is breaking in
https://github.com/sagemath/sage/blob/master/build/sage_bootstrap/uncompress/tar_file.py#L161

Mind you, python 2.6.6 has been released about 12 years ago, not sure
this code, from 2016, was ever tested
on 2.6.6 (perhaps on less buggy 2.6.7...)

You may try installing pyenv with newer python and
run Sage installation from there. See https://gist.github.com/ysaotome/7956676
(you ought to replace 2.7.6 with 3.9.1 there, to escape the Python2
hell completely)
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/f9988b1b364447a883f1679f65752daf%40ruhr-uni-bochum.de.

Matthias Koeppe

unread,
Mar 4, 2021, 1:18:32 PMMar 4
to sage-support
Looks like we cannot bootstrap using Python 2.6 any more.

Dima Pasechnik

unread,
Mar 4, 2021, 1:25:35 PMMar 4
to sage-support
On Thu, Mar 4, 2021 at 6:18 PM Matthias Koeppe <matthia...@gmail.com> wrote:
>
> Looks like we cannot bootstrap using Python 2.6 any more.
>
> The error seen in the log is: https://stackoverflow.com/questions/19668395/str-format-for-python-2-6-gives-error-where-2-7-does-not

yes, but this is the secondary error, in processing ValueError thrown by
https://github.com/sagemath/sage/blob/master/build/sage_bootstrap/uncompress/cmdline.py#L53
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/18a44eec-2e03-48c8-88b3-94008c46ea4fn%40googlegroups.com.

Matthias Koeppe

unread,
Mar 4, 2021, 2:39:48 PMMar 4
to sage-support
OK, time to officially remove support for building with python 2.6 as sage-bootstrap-python - https://trac.sagemath.org/ticket/20023 (needs review).

Hackenberg, Klaus

unread,
Mar 5, 2021, 5:02:53 AMMar 5
to sage-s...@googlegroups.com
High,

I installed python 3.9.2 in /usr/local/Python and added it to PATH variable

[lsf@dlp762 root]$ echo $PATH
/usr/local/Python/bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
[lsf@dlp762 root]$ python --version
Python 3.9.2

Now symmetrica-3.0.1. compiles successfull.
But ppl-1.2 no longer compiles !!!
So I seem to be in a deadlock .

I include ppl error logs.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Donnerstag, 4. März 2021 18:53
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq2fRF5Ybh_3S33r7PWRDSAxXeEey6dzWBKKxJAsKZf%3Dgw%40mail.gmail.com.

config.log
ppl-1.2.p1.log

Dima Pasechnik

unread,
Mar 5, 2021, 5:31:45 AMMar 5
to sage-support
On Fri, Mar 5, 2021 at 10:02 AM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
> I installed python 3.9.2 in /usr/local/Python and added it to PATH variable
>
> [lsf@dlp762 root]$ echo $PATH
> /usr/local/Python/bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
> [lsf@dlp762 root]$ python --version
> Python 3.9.2
>
> Now symmetrica-3.0.1. compiles successfull.
> But ppl-1.2 no longer compiles !!!
> So I seem to be in a deadlock .
>
It's the same misconfiguration of mp/gmp stuff as before.
Without knowning what exactly you did after changing PATH, it's hard to tell.

please post the top level config.log (the one in the same directory as
the main ./configure script)
- the ppl problems come from the top level misconfiguration.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/54a874a0bf42431ea3db426b29b68676%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 5, 2021, 6:24:23 AMMar 5
to sage-s...@googlegroups.com
High,

I did the following

[lsf@dlp762 Sage]$ cd sage-9.2
[lsf@dlp762 sage-9.2]$ ./configure --with-gmp=gmp > /tmp/configure.log 2>&1
[lsf@dlp762 sage-9.2]$ make mpir-clean > /tmp/mpir.clean.log 2>&1

and include the logs.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Freitag, 5. März 2021 11:31
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq2QRO4u8j%2BHQEigifeisNMe2vpm74GvfK48YFih7K59pw%40mail.gmail.com.
mpir.clean.log
configure.log

Dima Pasechnik

unread,
Mar 5, 2021, 6:45:39 AMMar 5
to sage-support
On Fri, Mar 5, 2021 at 11:24 AM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
> I did the following
>
> [lsf@dlp762 Sage]$ cd sage-9.2
> [lsf@dlp762 sage-9.2]$ ./configure --with-gmp=gmp > /tmp/configure.log 2>&1

and so you once again mixed up --with-gmp= and --with-mp=

It should be --with-mp=gmp
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/d24735ac92e14e8abdc137ea8b99538d%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 5, 2021, 7:55:39 AMMar 5
to sage-s...@googlegroups.com
High,

when using "./configure --with-mp=gmp" things look much better.

But now I get an error for gfan-0.6.2.p1.
I include the error log.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Freitag, 5. März 2021 12:45
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq1EwxC7Uk_VenFViiQJG56fVSZAgRqGWMXve7cwoKnUxQ%40mail.gmail.com.
gfan-0.6.2.p1.log

Dima Pasechnik

unread,
Mar 5, 2021, 9:08:14 AMMar 5
to sage-support
On Fri, Mar 5, 2021 at 12:55 PM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
> when using "./configure --with-mp=gmp" things look much better.
>
> But now I get an error for gfan-0.6.2.p1.
> I include the error log.
it says

./gfan: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found
(required by ./gfan)
./gfan: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found
(required by ./gfan)
./gfan: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.26' not found
(required by ./gfan)
./gfan: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found
(required by ./gfan)
./gfan: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.22' not found
(required by ./gfan)
./gfan: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found
(required by ./gfan)

Something is not quite right with your C++ toolchain. As
your gcc/g++ data says --prefix=/usr/local/Gcc
one would expect libstdc++.so.6 to be in /usr/local/Gcc, and not in /usr/lib64/
(where you probably have old RHEL 6 gcc/g++ things)

No idea what exactly. What is the output of

g++ -v

Do you have libstdc++.so.6 in /usr/local/ at all?
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/a61197ac5bbb42879976b6a7d0b36043%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 5, 2021, 9:30:48 AMMar 5
to sage-s...@googlegroups.com
High,

I find the following

[lsf@dlp762 Sage]$ echo $PATH
/usr/local/Gcc/bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
[lsf@dlp762 Sage]$
[lsf@dlp762 Sage]$ g++ -v
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/net/dlp762/share/application-software/Gcc/bin/../libexec/gcc/x86_64-pc-linux-gnu/9.2.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: ../gcc-9.2.0/configure --disable-multilib --exec-prefix=/usr/local/Gcc --prefix=/usr/local/Gcc
Thread model: posix
gcc version 9.2.0 (GCC)
[lsf@dlp762 Sage]$
[lsf@dlp762 Sage]$ find /usr/local/Gcc/ -name libstdc++.so.6
/usr/local/Gcc/lib64/libstdc++.so.6
/usr/local/Gcc/gcc-build/stage1-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
/usr/local/Gcc/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
/usr/local/Gcc/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
[lsf@dlp762 Sage]$

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Freitag, 5. März 2021 15:08
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq0af9NOUvZSaqvD-%2BBcjjHz2uEE%2BYqK7TmtznxB88u%3DAg%40mail.gmail.com.

Dima Pasechnik

unread,
Mar 5, 2021, 9:57:53 AMMar 5
to sage-support
On Fri, Mar 5, 2021 at 2:30 PM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
> I find the following
>
> [lsf@dlp762 Sage]$ echo $PATH
> /usr/local/Gcc/bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
> [lsf@dlp762 Sage]$
> [lsf@dlp762 Sage]$ g++ -v
> Using built-in specs.
> COLLECT_GCC=g++
> COLLECT_LTO_WRAPPER=/net/dlp762/share/application-software/Gcc/bin/../libexec/gcc/x86_64-pc-linux-gnu/9.2.0/lto-wrapper
> Target: x86_64-pc-linux-gnu
> Configured with: ../gcc-9.2.0/configure --disable-multilib --exec-prefix=/usr/local/Gcc --prefix=/usr/local/Gcc
> Thread model: posix
> gcc version 9.2.0 (GCC)
> [lsf@dlp762 Sage]$
> [lsf@dlp762 Sage]$ find /usr/local/Gcc/ -name libstdc++.so.6
> /usr/local/Gcc/lib64/libstdc++.so.6
> /usr/local/Gcc/gcc-build/stage1-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
> /usr/local/Gcc/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
> /usr/local/Gcc/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6
> [lsf@dlp762 Sage]$

try

export LD_LIBRARY_PATH=/usr/local/Gcc/lib64:$LD_LIBRARY_PATH

and then run make
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/5e0ec7b0d1854d53b32165745770e8c6%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 5, 2021, 11:17:06 AMMar 5
to sage-s...@googlegroups.com
High,

adding /usr/local/Gcc/lib64 to $LD_LIBRARY_PATH helps compiling gfan-0.6.2.p1.

Next problem is with r-3.6.3:
The bzip2 from RHEL6 seem to be to old:

[root@dlp762 Sage]# bzip2 --version
bzip2, a block-sorting file compressor. Version 1.0.5, 10-Dec-2007.

Is there any option to use another version (built within sage)?

I include the error log.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Freitag, 5. März 2021 15:58
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq3MEeHBH8XBCgn3MnfY4OVr8tOj57XmCukKnnQg65n85Q%40mail.gmail.com.

r-3.6.3.log

Hackenberg, Klaus

unread,
Mar 5, 2021, 11:21:12 AMMar 5
to sage-s...@googlegroups.com
High,

I found the following article

https://access.redhat.com/discussions/3133111

stating that redhat bzip2 version 1.0.5 is version 1.0.6 in reality.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Freitag, 5. März 2021 15:58
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

On Fri, Mar 5, 2021 at 2:30 PM 'Hackenberg, Klaus' via sage-support <sage-s...@googlegroups.com> wrote:
>
> High,
>
> I find the following
>
> [lsf@dlp762 Sage]$ echo $PATH
> /usr/local/Gcc/bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bi
> n:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
> [lsf@dlp762 Sage]$
> [lsf@dlp762 Sage]$ g++ -v
> Using built-in specs.
> COLLECT_GCC=g++
> COLLECT_LTO_WRAPPER=/net/dlp762/share/application-software/Gcc/bin/../
> libexec/gcc/x86_64-pc-linux-gnu/9.2.0/lto-wrapper
> Target: x86_64-pc-linux-gnu
> Configured with: ../gcc-9.2.0/configure --disable-multilib
> --exec-prefix=/usr/local/Gcc --prefix=/usr/local/Gcc Thread model:
> posix gcc version 9.2.0 (GCC)
> [lsf@dlp762 Sage]$
> [lsf@dlp762 Sage]$ find /usr/local/Gcc/ -name libstdc++.so.6
> /usr/local/Gcc/lib64/libstdc++.so.6
> /usr/local/Gcc/gcc-build/stage1-x86_64-pc-linux-gnu/libstdc++-v3/src/.
> libs/libstdc++.so.6
> /usr/local/Gcc/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/li
> bstdc++.so.6
> /usr/local/Gcc/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.li
> bs/libstdc++.so.6
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq3MEeHBH8XBCgn3MnfY4OVr8tOj57XmCukKnnQg65n85Q%40mail.gmail.com.

Dima Pasechnik

unread,
Mar 5, 2021, 11:30:47 AMMar 5
to sage-support
On Fri, 5 Mar 2021, 16:17 'Hackenberg, Klaus' via sage-support, <sage-s...@googlegroups.com> wrote:
High,

  adding /usr/local/Gcc/lib64 to $LD_LIBRARY_PATH helps compiling gfan-0.6.2.p1.

  Next problem is with r-3.6.3:
  The bzip2 from RHEL6 seem to be to old:

[root@dlp762 Sage]# bzip2 --version
bzip2, a block-sorting file compressor.  Version 1.0.5, 10-Dec-2007.

  Is there any option to use another version (built within sage)?

make bzip2


Dima Pasechnik

unread,
Mar 5, 2021, 11:34:57 AMMar 5
to sage-support


On Fri, 5 Mar 2021, 16:30 Dima Pasechnik, <dim...@gmail.com> wrote:


On Fri, 5 Mar 2021, 16:17 'Hackenberg, Klaus' via sage-support, <sage-s...@googlegroups.com> wrote:
High,

  adding /usr/local/Gcc/lib64 to $LD_LIBRARY_PATH helps compiling gfan-0.6.2.p1.

  Next problem is with r-3.6.3:
  The bzip2 from RHEL6 seem to be to old:

[root@dlp762 Sage]# bzip2 --version
bzip2, a block-sorting file compressor.  Version 1.0.5, 10-Dec-2007.

  Is there any option to use another version (built within sage)?

make bzip2

this will build sage's version of bzip2

Then run make again, to build r, etc

Hackenberg, Klaus

unread,
Mar 5, 2021, 11:58:55 AMMar 5
to sage-s...@googlegroups.com

High,

 

  „make bzip2“ helps further, but r-3.6.3 still does not compile.

  RHEL6 contains

 

[root@dlp762 Sage]# rpm -qa --last|grep xz

xz-devel-4.999.9-0.5.beta.20091007git.el6.x86_64 Tue Jun 18 11:06:45 2019

xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:37 2015

xz-4.999.9-0.5.beta.20091007git.el6.x86_64    Fri Sep 18 09:39:26 2015

xz-libs-4.999.9-0.5.beta.20091007git.el6.x86_64 Fri Sep 18 09:39:03 2015

 

  but 5.0.3 seems tob e necessary

 

checking if lzma version >= 5.0.3... no

configure: error: "liblzma library and headers are required"

 

  Is there a suitable version within sage?

 

  I include the error log.

 

Regards, Klaus Hackenberg

 

--

Klaus Hackenberg

IT-Systeme und Software-Integration

IT.SERVICES

Ruhr-Universität Bochum | 44780 Bochum

fon: +49 234 32 23485

http://www.it-services.rub.de/

 

r-3.6.3.log

Dima Pasechnik

unread,
Mar 5, 2021, 12:00:47 PMMar 5
to sage-support
make xz

followed by make

Hackenberg, Klaus

unread,
Mar 5, 2021, 12:37:12 PMMar 5
to sage-s...@googlegroups.com

High,

 

  I succeeded compiling r-3.6.3.

 

  But now next stop when compiling numpy-1.19.1.

numpy-1.19.1.log

Dima Pasechnik

unread,
Mar 5, 2021, 7:08:34 PMMar 5
to sage-support, Matthias Koeppe
"Error building wheel for numpy"

please post
/net/dlp762/share/application-software/Sage/sage-9.2/config.log

could you also please try running

make toolchain

and then run make.



Matthias,
is it another instance of not having .pc files ready for blas/lapack etc?

Running from numpy source directory.
/net/dlp762/share/application-software/Sage/sage-9.2/local/var/tmp/sage/build/numpy-1.19.1/src/numpy/distutils/system_info.py:1914:
UserWarning:
Optimized (vendor) Blas libraries are not found.
Falls back to netlib Blas library which has worse performance.
A better performance should be easily gained by switching
Blas library.
if self._calc_info(blas):
/net/dlp762/share/application-software/Sage/sage-9.2/local/lib/python3.8/distutils/dist.py:274:
UserWarning: Unknown distribution option: 'define_macros'
warnings.warn(msg)
error: Command "gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g
-fwrapv -O3 -Wall -Wno-unused -fPIC -DNPY_INTERNAL_BUILD=1
-DHAVE_NPY_CONFIG_H=1 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE=1
-D_LARGEFILE64_SOURCE=1 -DNO_ATLAS_INFO=1 -DHAVE_CBLAS
-I/net/dlp762/share/application-software/Sage/sage-9.2/local/include
-Ibuild/src.linux-x86_64-3.8/numpy/core/src/umath
-Ibuild/src.linux-x86_64-3.8/numpy/core/src/npymath
-Ibuild/src.linux-x86_64-3.8/numpy/core/src/common
-Inumpy/core/include
-Ibuild/src.linux-x86_64-3.8/numpy/core/include/numpy
-Inumpy/core/src/common -Inumpy/core/src -Inumpy/core
-Inumpy/core/src/npymath -Inumpy/core/src/multiarray
-Inumpy/core/src/umath -Inumpy/core/src/npysort
-I/net/dlp762/share/application-software/Sage/sage-9.2/local/include/python3.8
-Ibuild/src.linux-x86_64-3.8/numpy/core/src/common
-Ibuild/src.linux-x86_64-3.8/numpy/core/src/npymath -c
build/src.linux-x86_64-3.8/numpy/core/src/umath/loops.c -o
build/temp.linux-x86_64-3.8/build/src.linux-x86_64-3.8/numpy/core/src/umath/loops.o
-MMD -MF build/temp.linux-x86_64-3.8/build/src.linux-x86_64-3.8/numpy/core/src/umath/loops.o.d
-std=c99" failed with exit status 1
********************************************************************************
Error building wheel for numpy
********************************************************************************

On Fri, Mar 5, 2021 at 5:37 PM 'Hackenberg, Klaus' via sage-support
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/8fbc9b7c91c242af9a1f593642632c76%40ruhr-uni-bochum.de.

Matthias Koeppe

unread,
Mar 5, 2021, 7:21:12 PMMar 5
to sage-support
On Friday, March 5, 2021 at 4:08:34 PM UTC-8 Dima Pasechnik wrote:
Matthias,
is it another instance of not having .pc files ready for blas/lapack etc?

I don't think so. From Klaus' configure.log above, 

===
Checking whether SageMath should install SPKG openblas...
checking BLAS library... openblas
checking whether any of gfortran is installed as or will be installed as SPKG... no
checking for OPENBLAS... no
checking for library containing openblas_get_config... no
checking for library containing cblas_dgemm... no
checking for library containing dgeqrf... no
checking for library containing dgeqrf_... no
checking for library containing DGEQRF... no
checking for library containing DGEQRF_... no
configure: no suitable system package found for SPKG openblas
===

So Sage should have installed openblas, which always installs the correct .pc files. 
But who knows what may have happened in the incremental build here. 



Hackenberg, Klaus

unread,
Mar 6, 2021, 4:55:15 AMMar 6
to sage-s...@googlegroups.com
High,

running "make toolchain shows only

[lsf@dlp762 sage-9.2]$ make toolchain
make build/make/Makefile --stop
make[1]: Entering directory `/net/dlp762/share/application-software/Sage/sage-9.2'
make[1]: `build/make/Makefile' is up to date.
make[1]: Leaving directory `/net/dlp762/share/application-software/Sage/sage-9.2'
build/bin/sage-logger \
"cd build/make && ./install 'toolchain'" logs/install.log
make[1]: Entering directory `/net/dlp762/share/application-software/Sage/sage-9.2/build/make'
make[1]: Leaving directory `/net/dlp762/share/application-software/Sage/sage-9.2/build/make'
Nothing to (re)build / all up-to-date.
[lsf@dlp762 sage-9.2]$

I include the config log.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/

-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Samstag, 6. März 2021 01:08
An: sage-support <sage-s...@googlegroups.com>; Matthias Koeppe <mko...@math.ucdavis.edu>
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq2y2G0kdcGTO5GCnc8%2BRLarfzzk400CoLcuQLkKF5AXZQ%40mail.gmail.com.
config.log

Dima Pasechnik

unread,
Mar 6, 2021, 5:36:40 AMMar 6
to sage-support
why did you run ./configure with the option "--with-blas=openblas" ?

Please try re-running ./configure without it.

Then hopefully numpy etc will be built.



Dima Pasechnik

unread,
Mar 6, 2021, 10:13:06 AMMar 6
to sage-support
On Sat, Mar 6, 2021 at 10:36 AM Dima Pasechnik <dim...@gmail.com> wrote:
>
> why did you run ./configure with the option "--with-blas=openblas" ?
>
> Please try re-running ./configure without it.
>
> Then hopefully numpy etc will be built.

Sorry, that was wrong.

It's probably your new Python interfering.
Start from scratch

make distclean
./configure --with-mp=gmp

I suppose it will pick up your newly installed Python3 and use it, you can
check config.log for this, or just the output of ./configure

Hackenberg, Klaus

unread,
Mar 6, 2021, 1:35:39 PMMar 6
to sage-s...@googlegroups.com
High,

I did a fresh start over:

cd sage-9.2
make distclean
./configure --with-mp=gmp
make mpir-clean
make bzip2 xz pcre -j3
make -j8

But compilation still fails for numpy-1.19.1.
I include config.log and error log.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/

-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Samstag, 6. März 2021 16:13
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

>> *********************************************************************
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq3TUWgvf%3DCa7GLQS3T4Qq90uVEhmgW717zhNtkO8tsW3w%40mail.gmail.com.

config.log
numpy-1.19.1.log

Nathan Dunfield

unread,
Mar 6, 2021, 3:17:07 PMMar 6
to sage-support
Is there some reason you need to build from source?  Last fall, I struggled without success to get Sage 9.1 to build on RHEL 6 (technically Scientific Linux 6, which is clone of RHEL), but the conda version worked fine for me on that platform:


Best, Nathan

Dima Pasechnik

unread,
Mar 6, 2021, 3:18:53 PMMar 6
to sage-support
OK, I should have seen this already in the 1st numpy problem report.

Basically, compiling C-code in
build/src.linux-x86_64-3.8/numpy/core/src/umath/loops.c fails.

Try

SAGE_FAT_BINARY=yes make -j8 numpy

Anyhow, can we get the output of

lscpu

or

cat /proc/cpuinfo

One has to tell numpy to

On Sat, Mar 6, 2021 at 6:35 PM 'Hackenberg, Klaus' via sage-support
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/ff0933d0a57746469a1380db4b2c07c8%40ruhr-uni-bochum.de.

Dima Pasechnik

unread,
Mar 6, 2021, 5:58:05 PMMar 6
to sage-support
On Sat, Mar 6, 2021 at 8:17 PM Nathan Dunfield <nat...@dunfield.info> wrote:
>
> Is there some reason you need to build from source? Last fall, I struggled without success to get Sage 9.1 to build on RHEL 6 (technically Scientific Linux 6, which is clone of RHEL), but the conda version worked fine for me on that platform:
>
> https://doc.sagemath.org/html/en/installation/conda.html

indeed, this it worth trying, although with these highly non-standard
HPC cluster machines one never knowns...

>
> Best, Nathan
>
> --
> You received this message because you are subscribed to the Google Groups "sage-support" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/4225e2cf-d872-409d-b25c-4d4b11515e9an%40googlegroups.com.

Matthias Koeppe

unread,
Mar 7, 2021, 3:33:22 PMMar 7
to sage-support
From numpy.log:

gcc: numpy/core/src/multiarray/flagsobject.c
gcc: numpy/core/src/multiarray/nditer_api.c
In file included from /net/dlp762/share/application-software/Gcc/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include/immintrin.h:51,
                 from numpy/core/src/umath/simd.inc.src:25,
                 from numpy/core/src/umath/loops.c.src:50:
/net/dlp762/share/application-software/Gcc/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include/avxintrin.h:1194:1: error: inlining failed in call to always_inline '_mm256_movemask_ps': target specific option mismatch

Try upgrading your compiler.




Dima Pasechnik

unread,
Mar 7, 2021, 3:37:31 PMMar 7
to sage-support


On Sun, 7 Mar 2021, 20:33 Matthias Koeppe, <matthia...@gmail.com> wrote:
From numpy.log:

gcc: numpy/core/src/multiarray/flagsobject.c
gcc: numpy/core/src/multiarray/nditer_api.c
In file included from /net/dlp762/share/application-software/Gcc/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include/immintrin.h:51,
                 from numpy/core/src/umath/simd.inc.src:25,
                 from numpy/core/src/umath/loops.c.src:50:
/net/dlp762/share/application-software/Gcc/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include/avxintrin.h:1194:1: error: inlining failed in call to always_inline '_mm256_movemask_ps': target specific option mismatch

Try upgrading your compiler.

I presume it is one of these very expensive and very non-standard HPC clusters, with some special soft that just can't be upgraded.

Thank goodness it is not a Cray :-)

Hackenberg, Klaus

unread,
Mar 8, 2021, 5:31:12 AMMar 8
to sage-s...@googlegroups.com
High,

i tried

SAGE_FAT_BINARY=yes make -j8 numpy

But it also fails.
I include the error log.

"lscpu" shows

[root@dlp762 Sage]# lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 80
On-line CPU(s) list: 0-79
Thread(s) per core: 2
Core(s) per socket: 10
Socket(s): 4
NUMA node(s): 4
Vendor ID: GenuineIntel
CPU family: 6
Model: 62
Model name: Intel(R) Xeon(R) CPU E7-4830 v2 @ 2.20GHz
Stepping: 7
CPU MHz: 2199.930
BogoMIPS: 4399.34
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 20480K
NUMA node0 CPU(s): 0,4,8,12,16,20,24,28,32,36,40,44,48,52,56,60,64,68,72,76
NUMA node1 CPU(s): 1,5,9,13,17,21,25,29,33,37,41,45,49,53,57,61,65,69,73,77
NUMA node2 CPU(s): 2,6,10,14,18,22,26,30,34,38,42,46,50,54,58,62,66,70,74,78
NUMA node3 CPU(s): 3,7,11,15,19,23,27,31,35,39,43,47,51,55,59,63,67,71,75,79
[root@dlp762 Sage]#

It's a Dell server with 4 CPUs à 10 cores .

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/

-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Samstag, 6. März 2021 21:19
> >> > > > > > > ==
> >> > > > > > > ===
> >> > > > > > > ==
> >> > > > > > > ==
> >> > > > > > > ==
> >> > > > > > > ==
> >> > > > > > > ==
> >> > > > > > > ===
> >> > > > > > > [lsf@dlp762 sage-9.2]$ make mpir-clean make
> >> > > > > > > build/make/Makefile --stop
> >> > > > > > > make[1]: Entering directory `/net/dlp762/share/application-software/Sage/sage-9.2'
> >> > > > > > > rm -f config.log
> >> > > > > > > mkdir -p logs/pkgs
> >> > > > > > > ln -s logs/pkgs/config.log config.log
> >> > > > > > > *******************************************************
> >> > > > > > > **
> >> > > > > > > ***
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > ******
> >> > > > > > > error: Sage source tree is unconfigured. Please run "./configure" first.
> >> > > > > > > note: Type "./configure --help" to see the available configuration options.
> >> > > > > > > *******************************************************
> >> > > > > > > **
> >> > > > > > > ***
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > **
> >> > > > > > > ******
> >> > > > > > > make[1]: *** [build/make/Makefile] Error 1
> >> > > > > > > make[1]: Leaving directory `/net/dlp762/share/application-software/Sage/sage-9.2'
> >> > > > > > > make: *** [mpir-clean] Error 2
> >> > > > > > > [lsf@dlp762 sage-9.2]$
> >> > > > > > > =======================================================
> >> > > > > > > ==
> >> > > > > > > ===
> >> > > > > > > ==
> >> > > > > > > ==
> >> > > > > > > ==
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq0%3DhcN5HY5mTUui4pr1DehJBY%2BGC_mmnWP45aH3WY1gPg%40mail.gmail.com.

numpy-1.19.1.log

Hackenberg, Klaus

unread,
Mar 8, 2021, 6:49:44 AMMar 8
to sage-s...@googlegroups.com

High,

 

  I upgraded gcc to 10.2.0 but that did not help.

 

Regards Klaus

Dima Pasechnik

unread,
Mar 8, 2021, 7:14:56 AMMar 8
to sage-support
You're now hacking numpy on a 7-year old CPU (that's your Intel(R)
Xeon(R) CPU E7-4830 v2 @ 2.20GHz)...
Probably its AVX support in gcc is a bit broken.
Try

CC="gcc -march=core2" make -j8 numpy

(this should create a numpy build without AVX support)


On Mon, Mar 8, 2021 at 11:49 AM 'Hackenberg, Klaus' via sage-support
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/f221df2280aa43ed963a3f7559dc0107%40ruhr-uni-bochum.de.

Hackenberg, Klaus

unread,
Mar 8, 2021, 7:48:04 AMMar 8
to sage-s...@googlegroups.com
High,

I installed Miniconda3 and then issued

conda config --add channels conda-forge
conda create -n sage sage python=3.8.5
conda activate sage

and now " sage --version" tells me

SageMath version 9.2, Release Date: 2020-10-24
hackekc6@dlp762 R --version
R version 4.0.3 (2020-10-10) -- "Bunny-Wunnies Freak Out"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-conda-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under the terms of the
GNU General Public License versions 2 or 3.
For more information about these matters see
https://www.gnu.org/licenses/.

I have asked the user originally requesting a new version of sage to test.

But I don't understand why the precompiled binary seems to work
and I am not able to compile the source myself.

Regards, Klaus Hackenberg

--
Klaus Hackenberg
IT-Systeme und Software-Integration
IT.SERVICES
Ruhr-Universität Bochum | 44780 Bochum
fon: +49 234 32 23485
http://www.it-services.rub.de/


-----Ursprüngliche Nachricht-----
Von: sage-s...@googlegroups.com <sage-s...@googlegroups.com> Im Auftrag von Dima Pasechnik
Gesendet: Samstag, 6. März 2021 23:58
An: sage-support <sage-s...@googlegroups.com>
Betreff: Re: [sage-support] problem compiling sage 9.2 on RHEL 6

You received this message because you are subscribed to a topic in the Google Groups "sage-support" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sage-support/GniJKQ0MaMY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/CAAWYfq1JGyGuws3k4egj%2BwGXk5ezjF6tx-%2BMyvuW0iLksmLPbg%40mail.gmail.com.

Dima Pasechnik

unread,
Mar 8, 2021, 8:36:50 AMMar 8
to sage-support
On Mon, Mar 8, 2021 at 12:48 PM 'Hackenberg, Klaus' via sage-support
<sage-s...@googlegroups.com> wrote:
>
> High,
>
> I installed Miniconda3 and then issued
>
> conda config --add channels conda-forge
> conda create -n sage sage python=3.8.5
> conda activate sage
>
> and now " sage --version" tells me
>
> SageMath version 9.2, Release Date: 2020-10-24
> hackekc6@dlp762 R --version
> R version 4.0.3 (2020-10-10) -- "Bunny-Wunnies Freak Out"
> Copyright (C) 2020 The R Foundation for Statistical Computing
> Platform: x86_64-conda-linux-gnu (64-bit)
>
> R is free software and comes with ABSOLUTELY NO WARRANTY.
> You are welcome to redistribute it under the terms of the
> GNU General Public License versions 2 or 3.
> For more information about these matters see
> https://www.gnu.org/licenses/.
>
> I have asked the user originally requesting a new version of sage to test.
>
> But I don't understand why the precompiled binary seems to work
> and I am not able to compile the source myself.

They have a good toolchain, specifically targeting the widest possible
variety of
Linux installations on x86/x86_64.
You can build sage using their toochain (as you basically already have
99% of the needed conda packages installed)
see
https://wiki.sagemath.org/Conda

And as the numpy issue shows, there are quirks with CPU support on your box.

Hope this explains.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/786bb402a40045b68ee3bc565828cfdb%40ruhr-uni-bochum.de.
Reply all
Reply to author
Forward
0 new messages