What can I do to get sage not to compile numpy?

15 views
Skip to first unread message

Al Kelley

unread,
Jul 17, 2021, 10:41:16 PMJul 17
to sage-support
Using dnf to install sagemath works on Fedora 34,  but then /usr/bin/sage gives
a weird error message.  Compiling sage from sage-9.2.tar.gz does not work.
Using CC=clang CXX=clang++ FC=flang it hangs.  Here are the last three
lines that get printed to the screen:

[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy
[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy/distutils
[numpy-1.19.5] building library "npymath" sources

What can I do to get sage not to compile numpy?
Sage seems to be happy with my python3.
Why does it not like my numpy?
This is what I have installed:
           boost-numpy3.x86_64    1.75.0-4.fc34  @fedora
          python3-numpy.x86_64  1:1.20.1-1.fc34  @fedora
     python3-numpy-f2py.x86_64  1:1.20.1-1.fc34  @fedora
      python3-numpy-stl.x86_64    2.11.2-3.fc34  @fedora

Matthias Koeppe

unread,
Jul 18, 2021, 12:04:04 AMJul 18
to sage-support
On Saturday, July 17, 2021 at 7:41:16 PM UTC-7 bluf...@gmail.com wrote:
Using dnf to install sagemath works on Fedora 34,  but then /usr/bin/sage gives
a weird error message. 

Please report Fedora packaging bugs to Fedora.
 
Compiling sage from sage-9.2.tar.gz does not work.
Using CC=clang CXX=clang++ FC=flang it hangs.  Here are the last three
lines that get printed to the screen:

[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy
[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy/distutils
[numpy-1.19.5] building library "npymath" sources

This is much too little information. We need at least the top-level config.log, and the full build log of the package.

In any case, 9.2 is outdated, but also 9.3 does not support building on Fedora 34 with the default compilers.
You can try the branch at https://trac.sagemath.org/ticket/31786
 
What can I do to get sage not to compile numpy?

This is not supported by the Sage distribution.


Dima Pasechnik

unread,
Jul 18, 2021, 3:30:32 AMJul 18
to sage-support


On Sun, 18 Jul 2021, 05:04 Matthias Koeppe, <matthia...@gmail.com> wrote:
On Saturday, July 17, 2021 at 7:41:16 PM UTC-7 bluf...@gmail.com wrote:
Using dnf to install sagemath works on Fedora 34,  but then /usr/bin/sage gives
a weird error message. 

Please report Fedora packaging bugs to Fedora.
 
Compiling sage from sage-9.2.tar.gz does not work.
Using CC=clang CXX=clang++ FC=flang it hangs.  Here are the last three
lines that get printed to the screen:

[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy
[numpy-1.19.5] creating build/src.linux-x86_64-3.9/numpy/distutils
[numpy-1.19.5] building library "npymath" sources

install gfortran and do not set FC
(or set FC=gfortran)

I am not aware of successful attempts to
build Sage using flang 



This is much too little information. We need at least the top-level config.log, and the full build log of the package.

In any case, 9.2 is outdated, but also 9.3 does not support building on Fedora 34 with the default compilers.
You can try the branch at https://trac.sagemath.org/ticket/31786
 
What can I do to get sage not to compile numpy?

This is not supported by the Sage distribution.


--
You received this message because you are subscribed to the Google Groups "sage-support" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/b2302361-6011-4833-bf10-95274db9c67dn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages