Sage Crash Report

20 views
Skip to first unread message

Gaël Cousin

unread,
Aug 16, 2021, 5:20:15 PMAug 16
to sage-s...@googlegroups.com

Ubuntu 20.04 Focal Fossa


Dear all,

Here follows attached a sage crash report. I think the sage install was broken by installation of Blender.


Sage was installed this way on my fresh Ubuntu 20.04 Focal Fossa:
sudo apt install sagemath sagetex- texlive-latex-base- sagemath-jupyter- pari-doc- sagemath-doc-

(afterwards I did

sudo apt install jupyter

and

sudo apt install sagemath-jupyter

everything was working fine)


Today I installed Blender

  sudo add-apt-repository ppa:savoury1/ffmpeg4

  sudo add-apt-repository ppa:savoury1/blender

  sudo apt-get update

  sudo apt-get upgrade && sudo apt-get dist-upgrade

  sudo apt-get install blender


Afterwards

I tried the command
maxima('plotdf([-y,-x],[x,y],[x,-2,2],[y,-2,2])')

in the jupyter notebook and I got a missing Kernel error

afterwards the kernel would not restart successfully and I restarted my computer.


Then I run

sage

in the terminal, which generated this crash report.

Currently, Sage is not working anymore on my computer.


There are strange things about python and numpy written in Blender's ppa description. I attach this description too (see lines 23 and 43).

I checked the result of python3 --version in the terminal and got

Python 3.8.10


Any hint towards the resolution of this sad situation is welcome.

Thanks fo your work on Sage.


Best,

Gaël Cousin.




Sage_crash_report.txt
blender_ppa_strange_messages

Gaël Cousin

unread,
Aug 16, 2021, 5:20:16 PMAug 16
to sage-s...@googlegroups.com

I solved the problem. I think the blender ppa came with a strange version of libgivaro9 and libgivaro-dev. I downgraded them and reinstalled Sage. Now it works!

Blender also seems to work!


Best,

G

Dima Pasechnik

unread,
Aug 16, 2021, 11:46:24 PMAug 16
to sage-support
it appears that installing blender changed Python used to in Sage's venv.

All bets are off in such a scenario - you'd need to rebuild Sage.



--
You received this message because you are subscribed to the Google Groups "sage-support" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-support/4600086d-51fa-f96c-c725-08ad013ab42c%40gmail.com.
Reply all
Reply to author
Forward
0 new messages